aboutsummaryrefslogtreecommitdiff
path: root/devel/arduino-builder
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2016-10-22 20:27:17 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2016-10-22 20:27:17 +0000
commit8b95368bc06f8b0717a79c30e5dc48b8c9b0674a (patch)
tree2f122f7db28b4504145994c9cc19ff9bd27e2784 /devel/arduino-builder
parent29c086c498e7d93fc12de3040cf45b434d1dbb9c (diff)
Notes
Diffstat (limited to 'devel/arduino-builder')
-rw-r--r--devel/arduino-builder/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/devel/arduino-builder/Makefile b/devel/arduino-builder/Makefile
index 6422c9bebf1d..9fb4d259bb96 100644
--- a/devel/arduino-builder/Makefile
+++ b/devel/arduino-builder/Makefile
@@ -2,7 +2,7 @@
PORTNAME= arduino-builder
PORTVERSION= 1.3.21
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MAINTAINER= bsdports@kyle-evans.net
@@ -20,6 +20,7 @@ GH_TUPLE= go-errors:errors:a418503:goerrors/src/github.com/go-errors/errors \
stretchr:testify:v1.1.3:stretchr/src/github.com/stretchr/testify \
jstemmer:go-junit-report:833f8ea:jstemmer/src/github.com/jstemmer/go-junit-report
+GO_ENV+= GOPATH=${WRKSRC}
STRIP= # stripping can break go binaries
PLIST_FILES= arduino/hardware/platform.keys.rewrite.txt \
@@ -27,7 +28,7 @@ PLIST_FILES= arduino/hardware/platform.keys.rewrite.txt \
bin/${PORTNAME}
do-build:
- @( cd ${WRKSRC} ; ${SETENV} GOPATH=${WRKSRC} go build arduino.cc/arduino-builder )
+ @( cd ${WRKSRC} ; ${SETENV} ${GO_ENV} go build arduino.cc/arduino-builder )
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}