aboutsummaryrefslogtreecommitdiff
path: root/devel/arduino-tools
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2016-10-19 20:53:14 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2016-10-19 20:53:14 +0000
commit3cf82fc48b98cac04a668112dcd4eb3be42ac0f2 (patch)
tree9c295709786f9806589c2a1c230e97384e2a7f9d /devel/arduino-tools
parent0fb206243194eccfb5c8462959b7bb0e0f4f25a2 (diff)
downloadports-3cf82fc48b98cac04a668112dcd4eb3be42ac0f2.tar.gz
ports-3cf82fc48b98cac04a668112dcd4eb3be42ac0f2.zip
Notes
Diffstat (limited to 'devel/arduino-tools')
-rw-r--r--devel/arduino-tools/Makefile57
-rw-r--r--devel/arduino-tools/pkg-descr5
-rw-r--r--devel/arduino-tools/pkg-plist10
3 files changed, 72 insertions, 0 deletions
diff --git a/devel/arduino-tools/Makefile b/devel/arduino-tools/Makefile
new file mode 100644
index 000000000000..7aad6ee72f1b
--- /dev/null
+++ b/devel/arduino-tools/Makefile
@@ -0,0 +1,57 @@
+# $FreeBSD$
+
+PORTNAME= arduino-tools
+PORTVERSION= 1.6.12
+CATEGORIES= devel
+MASTER_SITES= # Mostly metaport - installs files, no build
+DISTFILES= #
+EXTRACT_ONLY= #
+
+MAINTAINER= bsdports@kyle-evans.net
+COMMENT= Brings together all of the tool dependencies used for Arduino 1.6
+
+LICENSE= NONE
+
+RUN_DEPENDS= avrdude:devel/avrdude \
+ bossac:devel/bossa \
+ avr-as:devel/avr-binutils \
+ avr-ld:devel/avr-binutils \
+ avr-gcc:devel/avr-gcc \
+ arm-none-eabi-gcc:devel/arm-none-eabi-gcc \
+ arm-none-eabi-g++:devel/arm-none-eabi-gcc \
+ ${LOCALBASE}/arduino/tools-builder/ctags/${CTAGS_VERS}/ctags:devel/arduino-ctags \
+ arm-none-eabi-newlib>=0:devel/arm-none-eabi-newlib \
+ arduino-core>=0:devel/arduino-core
+
+NO_BUILD= yes
+NO_ARCH= yes
+
+ARMGCC_VERS= 4.9.2
+AVRDUDE_VERS= 6.3.0-arduino6
+AVRGCC_VERS= 4.9.2-atmel3.5.3-arduino2
+BOSSAC_VERS= 1.7.0
+CMSIS_VERS= ${PORTVERSION}
+CTAGS_VERS= 5.8-arduino10
+
+PLIST_SUB+= ARMGCC_VERS=${ARMGCC_VERS} \
+ AVRDUDE_VERS=${AVRDUDE_VERS} \
+ AVRGCC_VERS=${AVRGCC_VERS} \
+ BOSSAC_VERS=${BOSSAC_VERS} \
+ CMSIS_VERS=${CMSIS_VERS}
+
+_STD_TOOLS_= arm-none-eabi-gcc:${ARMGCC_VERS} \
+ avr-gcc:${AVRGCC_VERS} \
+ avrdude:${AVRDUDE_VERS} \
+ bossac:${BOSSAC_VERS}
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/arduino/tools-builder/CMSIS/${CMSIS_VERS}
+ ${LN} -s ../../../hardware/arduino/sam/system/CMSIS/CMSIS ${STAGEDIR}${PREFIX}/arduino/tools-builder/CMSIS/${CMSIS_VERS}/CMSIS
+ ${LN} -s ../../../hardware/arduino/sam/system/CMSIS/Device ${STAGEDIR}${PREFIX}/arduino/tools-builder/CMSIS/${CMSIS_VERS}/Device
+.for _tool in ${_STD_TOOLS_}
+ ${MKDIR} ${STAGEDIR}${PREFIX}/arduino/tools-builder/${_tool:C/:.*//}/${_tool:C/.*://}
+ ${LN} -s ../../../../bin ${STAGEDIR}${PREFIX}/arduino/tools-builder/${_tool:C/:.*//}/${_tool:C/.*://}/bin
+ ${LN} -s ../../../../etc ${STAGEDIR}${PREFIX}/arduino/tools-builder/${_tool:C/:.*//}/${_tool:C/.*://}/etc
+.endfor
+
+.include <bsd.port.mk>
diff --git a/devel/arduino-tools/pkg-descr b/devel/arduino-tools/pkg-descr
new file mode 100644
index 000000000000..b65e6c89a9cd
--- /dev/null
+++ b/devel/arduino-tools/pkg-descr
@@ -0,0 +1,5 @@
+arduino-tools is mostly a meta-port to ensure installation of the tools
+required by Arduino 1.6. It does some installation to properly structure
+the arduino/tools-builder/ structure in such a way that we may use
+all of the tools available from ports while not requiring modifications
+to devel/arduino-builder to auto-detect the tools.
diff --git a/devel/arduino-tools/pkg-plist b/devel/arduino-tools/pkg-plist
new file mode 100644
index 000000000000..9d978c1c7267
--- /dev/null
+++ b/devel/arduino-tools/pkg-plist
@@ -0,0 +1,10 @@
+arduino/tools-builder/CMSIS/%%CMSIS_VERS%%/CMSIS
+arduino/tools-builder/CMSIS/%%CMSIS_VERS%%/Device
+arduino/tools-builder/arm-none-eabi-gcc/%%ARMGCC_VERS%%/bin
+arduino/tools-builder/arm-none-eabi-gcc/%%ARMGCC_VERS%%/etc
+arduino/tools-builder/avr-gcc/%%AVRGCC_VERS%%/bin
+arduino/tools-builder/avr-gcc/%%AVRGCC_VERS%%/etc
+arduino/tools-builder/avrdude/%%AVRDUDE_VERS%%/bin
+arduino/tools-builder/avrdude/%%AVRDUDE_VERS%%/etc
+arduino/tools-builder/bossac/%%BOSSAC_VERS%%/bin
+arduino/tools-builder/bossac/%%BOSSAC_VERS%%/etc