aboutsummaryrefslogtreecommitdiff
path: root/devel/arduino
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2011-03-24 00:23:18 +0000
committerWen Heping <wen@FreeBSD.org>2011-03-24 00:23:18 +0000
commit6642e289056d04b3c82e0b2960d64573ca1b2a99 (patch)
tree2a6437508ae00afdaa0df7ca8a5ba25f8df8e419 /devel/arduino
parent71ccd81bf4516ff1884dbd979b2556fc4bf8d34a (diff)
downloadports-6642e289056d04b3c82e0b2960d64573ca1b2a99.tar.gz
ports-6642e289056d04b3c82e0b2960d64573ca1b2a99.zip
Notes
Diffstat (limited to 'devel/arduino')
-rw-r--r--devel/arduino/Makefile3
-rw-r--r--devel/arduino/distinfo1
-rw-r--r--devel/arduino/files/patch-hardware-arduino-bootloaders-atmega8-ATmegaBOOT.c11
-rw-r--r--devel/arduino/files/patch-hardware-arduino-cores-arduino-wiring_private.h11
4 files changed, 25 insertions, 1 deletions
diff --git a/devel/arduino/Makefile b/devel/arduino/Makefile
index f0ee4e93e4b7..81e63fb186e8 100644
--- a/devel/arduino/Makefile
+++ b/devel/arduino/Makefile
@@ -66,6 +66,9 @@ post-extract:
@${RM} ${WRKSRC}/hardware/arduino/boards.txt.bak
post-patch:
+ @${RM} ${WRKSRC}/hardware/arduino/bootloaders/atmega8/*.orig
+ @${RM} ${WRKSRC}/hardware/arduino/cores/arduino/*.orig
+
.if defined(WITHOUT_REFDOCS)
@${RM} -rf ${WRKSRC}/reference
.endif
diff --git a/devel/arduino/distinfo b/devel/arduino/distinfo
index 9426b9136964..05e90542e073 100644
--- a/devel/arduino/distinfo
+++ b/devel/arduino/distinfo
@@ -1,3 +1,2 @@
-MD5 (arduino-0019.tgz) = 23a438802e1f51a0925f9a9d6951b581
SHA256 (arduino-0019.tgz) = be2f0256c42388bbd590188a14f6913cc2ab875e98ff6623db72284e852e9a0e
SIZE (arduino-0019.tgz) = 3440025
diff --git a/devel/arduino/files/patch-hardware-arduino-bootloaders-atmega8-ATmegaBOOT.c b/devel/arduino/files/patch-hardware-arduino-bootloaders-atmega8-ATmegaBOOT.c
new file mode 100644
index 000000000000..ba3a9aec8f0b
--- /dev/null
+++ b/devel/arduino/files/patch-hardware-arduino-bootloaders-atmega8-ATmegaBOOT.c
@@ -0,0 +1,11 @@
+--- hardware/arduino/bootloaders/atmega8/ATmegaBOOT.c.orig 2011-03-21 15:17:03.000000000 +0800
++++ hardware/arduino/bootloaders/atmega8/ATmegaBOOT.c 2011-03-21 15:17:23.000000000 +0800
+@@ -36,7 +36,7 @@
+ #include <avr/pgmspace.h>
+ #include <avr/eeprom.h>
+ #include <avr/interrupt.h>
+-#include <avr/delay.h>
++#include <util/delay.h>
+
+ //#define F_CPU 16000000
+
diff --git a/devel/arduino/files/patch-hardware-arduino-cores-arduino-wiring_private.h b/devel/arduino/files/patch-hardware-arduino-cores-arduino-wiring_private.h
new file mode 100644
index 000000000000..80d41b3f8091
--- /dev/null
+++ b/devel/arduino/files/patch-hardware-arduino-cores-arduino-wiring_private.h
@@ -0,0 +1,11 @@
+--- hardware/arduino/cores/arduino/wiring_private.h.orig 2011-03-21 15:18:00.000000000 +0800
++++ hardware/arduino/cores/arduino/wiring_private.h 2011-03-21 15:18:13.000000000 +0800
+@@ -27,7 +27,7 @@
+
+ #include <avr/io.h>
+ #include <avr/interrupt.h>
+-#include <avr/delay.h>
++#include <util/delay.h>
+ #include <stdio.h>
+ #include <stdarg.h>
+