aboutsummaryrefslogtreecommitdiff
path: root/devel/argp-standalone
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-06-27 06:43:07 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-06-27 06:43:07 +0000
commit1017988e2a789f754f1a831f91144d650718c2f4 (patch)
tree90ce3c5d4fd0a9b6978600b294c8c3f9134ac6cc /devel/argp-standalone
parentf7fdb8279dc5979dc56e01134f8961c55f8643dc (diff)
downloadports-1017988e2a789f754f1a831f91144d650718c2f4.tar.gz
ports-1017988e2a789f754f1a831f91144d650718c2f4.zip
Notes
Diffstat (limited to 'devel/argp-standalone')
-rw-r--r--devel/argp-standalone/Makefile20
1 files changed, 7 insertions, 13 deletions
diff --git a/devel/argp-standalone/Makefile b/devel/argp-standalone/Makefile
index 5bb3269479fb..42187450bbf7 100644
--- a/devel/argp-standalone/Makefile
+++ b/devel/argp-standalone/Makefile
@@ -12,26 +12,20 @@ MASTER_SITE_SUBDIR= sem
MAINTAINER= sem@FreeBSD.org
COMMENT= Standalone version of arguments parsing functions from GLIBC
+USES= libtool
USE_CSTD= gnu89
GNU_CONFIGURE= yes
-USE_AUTOTOOLS= aclocal autoconf automake libtool
+USE_AUTOTOOLS= aclocal autoconf automake libtoolize
AUTOMAKE_ARGS= -c -a
ACLOCAL_ARGS= --automake-acdir=${ACLOCAL_DIR} -I ${LOCALBASE}/share/aclocal
USE_LDCONFIG= yes
+INSTALL_TARGET= install-strip
-PLIST_FILES= lib/libargp.la lib/libargp.a \
- lib/libargp.so lib/libargp.so.0 \
+PLIST_FILES= lib/libargp.a \
+ lib/libargp.so lib/libargp.so.0 lib/libargp.so.0.0.0 \
include/argp.h
-pre-configure:
- @cd ${WRKSRC}; ${SETENV} ${AUTOTOOLS_ENV} ${LIBTOOLIZE} --automake
-
-do-install:
- @cd ${WRKSRC}; \
- ${INSTALL_DATA} argp.h ${STAGEDIR}${PREFIX}/include; \
- ${INSTALL_DATA} .libs/libargp.la ${STAGEDIR}${PREFIX}/lib; \
- ${INSTALL_DATA} .libs/libargp.a ${STAGEDIR}${PREFIX}/lib; \
- ${INSTALL_LIB} .libs/libargp.so.0 ${STAGEDIR}${PREFIX}/lib
- @cd ${STAGEDIR}${PREFIX}/lib && ${LN} -sf libargp.so.0 libargp.so
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/argp.h ${STAGEDIR}${PREFIX}/include
.include <bsd.port.mk>