aboutsummaryrefslogtreecommitdiff
path: root/devel/argtable
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-12-17 02:53:52 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-12-17 02:53:52 +0000
commit2de43035f15923977cf4d71a6790d08418d6139b (patch)
tree8150ac14be160e0eb70a987ee52341f742d7e853 /devel/argtable
parent57b1861029189ab75ce32fe02cc220b1f1d17a83 (diff)
downloadports-2de43035f15923977cf4d71a6790d08418d6139b.tar.gz
ports-2de43035f15923977cf4d71a6790d08418d6139b.zip
Notes
Diffstat (limited to 'devel/argtable')
-rw-r--r--devel/argtable/Makefile28
-rw-r--r--devel/argtable/distinfo1
-rw-r--r--devel/argtable/files/patch-Makefile.in13
-rw-r--r--devel/argtable/pkg-descr11
-rw-r--r--devel/argtable/pkg-plist17
5 files changed, 70 insertions, 0 deletions
diff --git a/devel/argtable/Makefile b/devel/argtable/Makefile
new file mode 100644
index 000000000000..5225bd993f15
--- /dev/null
+++ b/devel/argtable/Makefile
@@ -0,0 +1,28 @@
+# ex:ts=8
+# Ports collection makefile for: argtable
+# Date created: Dec 17, 2003
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= argtable
+PORTVERSION= 2.2
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= An ANSI C library for parsing GNU style command line arguments
+
+LIB_DEPENDS= intl.5:${PORTSDIR}/devel/gettext
+
+USE_GETOPT_LONG= yes
+WRKSRC= ${WRKDIR}/argtable2
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+MAN3= argtable2.3
+
+.include <bsd.port.mk>
diff --git a/devel/argtable/distinfo b/devel/argtable/distinfo
new file mode 100644
index 000000000000..a853a11ee98e
--- /dev/null
+++ b/devel/argtable/distinfo
@@ -0,0 +1 @@
+MD5 (argtable-2.2.tar.gz) = 35b8948c9f4b81bb4b46dbd2b863e1b6
diff --git a/devel/argtable/files/patch-Makefile.in b/devel/argtable/files/patch-Makefile.in
new file mode 100644
index 000000000000..45137ce872bc
--- /dev/null
+++ b/devel/argtable/files/patch-Makefile.in
@@ -0,0 +1,13 @@
+--- Makefile.in.orig Wed Dec 17 10:51:08 2003
++++ Makefile.in Wed Dec 17 10:51:31 2003
+@@ -34,8 +34,8 @@
+ incldir = $(prefix)/include
+ libdir = $(prefix)/lib
+ mandir = $(prefix)/man/man3
+-docdir = $(prefix)/share/doc/argtable-2.x
+-exmdir = $(prefix)/share/doc/argtable-2.x/example
++docdir = $(prefix)/share/doc/argtable
++exmdir = $(prefix)/share/examples/argtable
+
+
+ all:
diff --git a/devel/argtable/pkg-descr b/devel/argtable/pkg-descr
new file mode 100644
index 000000000000..e8d5e65edbe9
--- /dev/null
+++ b/devel/argtable/pkg-descr
@@ -0,0 +1,11 @@
+Parsing a program's command line arguments has always been a distraction from
+the main programming task at hand. The argtable library simplifies the job by
+enabling the programmer to define the command line options directly in the
+source code as a static array of structs and then pass that array to argtable
+library functions which parse the command line accordingly. The values
+extracted from the comand line are deposited directly into user-defined program
+variables where they can be accessed by the main program. Argtable can also
+generate descriptions of the command line syntax from that same array for
+display as on-line help.
+
+WWW: http://argtable.sourceforge.net/
diff --git a/devel/argtable/pkg-plist b/devel/argtable/pkg-plist
new file mode 100644
index 000000000000..4e701952a5a5
--- /dev/null
+++ b/devel/argtable/pkg-plist
@@ -0,0 +1,17 @@
+include/argtable2.h
+lib/libargtable2.a
+%%DOCSDIR%%/argtable2-intro.html
+%%DOCSDIR%%/argtable2-intro.pdf
+%%DOCSDIR%%/argtable2-intro.ps
+%%DOCSDIR%%/argtable2.html
+%%DOCSDIR%%/argtable2.pdf
+%%DOCSDIR%%/argtable2.ps
+@dirrm %%DOCSDIR%%
+%%EXAMPLESDIR%%/Makefile
+%%EXAMPLESDIR%%/echo.c
+%%EXAMPLESDIR%%/ls.c
+%%EXAMPLESDIR%%/mv.c
+%%EXAMPLESDIR%%/myprog.c
+%%EXAMPLESDIR%%/rm.c
+%%EXAMPLESDIR%%/uname.c
+@dirrm %%EXAMPLESDIR%%