aboutsummaryrefslogtreecommitdiff
path: root/devel/arm-elf-binutils
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2002-08-01 14:54:36 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2002-08-01 14:54:36 +0000
commit5b60b6ce9092bfff097b6e20f9272a0a141ef0be (patch)
tree8792a4ac584647eaef979448dd73319ece6b5588 /devel/arm-elf-binutils
parentc6fb0efa2e713c1386633975da3a3b800a450cf5 (diff)
downloadports-5b60b6ce9092bfff097b6e20f9272a0a141ef0be.tar.gz
ports-5b60b6ce9092bfff097b6e20f9272a0a141ef0be.zip
Notes
Diffstat (limited to 'devel/arm-elf-binutils')
-rw-r--r--devel/arm-elf-binutils/Makefile21
-rw-r--r--devel/arm-elf-binutils/distinfo2
-rw-r--r--devel/arm-elf-binutils/pkg-plist27
3 files changed, 39 insertions, 11 deletions
diff --git a/devel/arm-elf-binutils/Makefile b/devel/arm-elf-binutils/Makefile
index bed8c4d450f7..7470b293066a 100644
--- a/devel/arm-elf-binutils/Makefile
+++ b/devel/arm-elf-binutils/Makefile
@@ -15,19 +15,22 @@ PKGNAMEPREFIX= arm-elf-
MAINTAINER= esk@ira.uka.de
-BROKEN= "Distinfo not yet updated"
-
USE_BZIP2= yes
USE_GMAKE= yes
-CONFIGURE_ARGS= --target=arm-elf
USE_LIBTOOL= yes
+CONFIGURE_TARGET= --target=${PKGNAMEPREFIX:S/-$//}
+CONFIGURE_ARGS= --infodir=${PREFIX}/${PKGNAMEPREFIX:S/-$//}/info
LIBTOOLFILES= configure bfd/configure binutils/configure etc/configure \
gas/configure gprof/configure intl/configure ld/configure \
libiberty/configure opcodes/configure
-MAN1= arm-elf-ar.1 arm-elf-nm.1 arm-elf-objdump.1 arm-elf-ranlib.1 \
- arm-elf-size.1 arm-elf-strings.1 arm-elf-strip.1 \
- arm-elf-objcopy.1 arm-elf-addr2line.1 arm-elf-nlmconv.1 \
- arm-elf-c++filt.1 arm-elf-as.1 arm-elf-ld.1
+MAN1= ${PKGNAMEPREFIX}addr2line.1 ${PKGNAMEPREFIX}as.1 \
+ ${PKGNAMEPREFIX}ar.1 ${PKGNAMEPREFIX}c++filt.1 \
+ ${PKGNAMEPREFIX}dlltool.1 ${PKGNAMEPREFIX}ld.1 \
+ ${PKGNAMEPREFIX}nlmconv.1 ${PKGNAMEPREFIX}nm.1 \
+ ${PKGNAMEPREFIX}objcopy.1 ${PKGNAMEPREFIX}objdump.1 \
+ ${PKGNAMEPREFIX}ranlib.1 ${PKGNAMEPREFIX}readelf.1 \
+ ${PKGNAMEPREFIX}size.1 ${PKGNAMEPREFIX}strings.1 \
+ ${PKGNAMEPREFIX}strip.1 ${PKGNAMEPREFIX}windres.1
post-install:
.for F in addr2line c++filt gasp objcopy objdump readelf size strings
@@ -37,7 +40,9 @@ post-install:
cd ${PREFIX}/lib ; ${MV} libbfd.a libiberty.a libopcodes.a \
${PREFIX}/${PKGNAMEPREFIX:S/-$//}/lib
${MKDIR} ${PREFIX}/${PKGNAMEPREFIX:S/-$//}/include
- cd ${PREFIX}/include ; ${MV} ansidecl.h bfd.h bfdlink.h \
+ cd ${PREFIX}/include ; ${MV} ansidecl.h bfd.h bfdlink.h symcat.h \
${PREFIX}/${PKGNAMEPREFIX:S/-$//}/include
+ ${RM} ${PREFIX}/${PKGNAMEPREFIX:S/-$//}/info/*
+ ${RMDIR} ${PREFIX}/${PKGNAMEPREFIX:S/-$//}/info
.include <bsd.port.mk>
diff --git a/devel/arm-elf-binutils/distinfo b/devel/arm-elf-binutils/distinfo
index 83a13f85846a..74e9fc147320 100644
--- a/devel/arm-elf-binutils/distinfo
+++ b/devel/arm-elf-binutils/distinfo
@@ -1 +1 @@
-MD5 (binutils-2.12.tar.bz2) = 9af59ffe6235c5e8c8f4edc57395c040
+MD5 (binutils-2.12.1.tar.bz2) = f67fe2e8065c5683bc34782de131f5d3
diff --git a/devel/arm-elf-binutils/pkg-plist b/devel/arm-elf-binutils/pkg-plist
index 0baa172ad6f6..b5c2003bd6e6 100644
--- a/devel/arm-elf-binutils/pkg-plist
+++ b/devel/arm-elf-binutils/pkg-plist
@@ -16,14 +16,15 @@ arm-elf/bin/strip
arm-elf/include/ansidecl.h
arm-elf/include/bfd.h
arm-elf/include/bfdlink.h
+arm-elf/include/symcat.h
arm-elf/lib/ldscripts/armelf.x
arm-elf/lib/ldscripts/armelf.xbn
+arm-elf/lib/ldscripts/armelf.xc
arm-elf/lib/ldscripts/armelf.xn
arm-elf/lib/ldscripts/armelf.xr
arm-elf/lib/ldscripts/armelf.xs
-arm-elf/lib/ldscripts/armelf.xu
-arm-elf/lib/ldscripts/armelf.xc
arm-elf/lib/ldscripts/armelf.xsc
+arm-elf/lib/ldscripts/armelf.xu
arm-elf/lib/libbfd.a
arm-elf/lib/libiberty.a
arm-elf/lib/libopcodes.a
@@ -41,6 +42,28 @@ bin/arm-elf-readelf
bin/arm-elf-size
bin/arm-elf-strings
bin/arm-elf-strip
+share/locale/da/LC_MESSAGES/opcodes.mo
+share/locale/de/LC_MESSAGES/opcodes.mo
+share/locale/es/LC_MESSAGES/bfd.mo
+share/locale/es/LC_MESSAGES/binutils.mo
+share/locale/es/LC_MESSAGES/gas.mo
+share/locale/es/LC_MESSAGES/ld.mo
+share/locale/es/LC_MESSAGES/opcodes.mo
+share/locale/fr/LC_MESSAGES/bfd.mo
+share/locale/fr/LC_MESSAGES/binutils.mo
+share/locale/fr/LC_MESSAGES/gas.mo
+share/locale/fr/LC_MESSAGES/ld.mo
+share/locale/fr/LC_MESSAGES/opcodes.mo
+share/locale/ja/LC_MESSAGES/bfd.mo
+share/locale/ja/LC_MESSAGES/binutils.mo
+share/locale/sv/LC_MESSAGES/bfd.mo
+share/locale/sv/LC_MESSAGES/ld.mo
+share/locale/sv/LC_MESSAGES/opcodes.mo
+share/locale/tr/LC_MESSAGES/bfd.mo
+share/locale/tr/LC_MESSAGES/binutils.mo
+share/locale/tr/LC_MESSAGES/gas.mo
+share/locale/tr/LC_MESSAGES/ld.mo
+share/locale/tr/LC_MESSAGES/opcodes.mo
@dirrm arm-elf/bin
@dirrm arm-elf/include
@dirrm arm-elf/lib/ldscripts