aboutsummaryrefslogtreecommitdiff
path: root/devel/as31
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2013-08-30 03:37:22 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2013-08-30 03:37:22 +0000
commit880b740272adcc7a0e1c078c2e2a7255ea79d1dc (patch)
treed0754357a1cec08e42caf7b5d4f56a9e6b0c4c06 /devel/as31
parentcdb56e88c788200baecfb0c58c1129f4f247ab99 (diff)
downloadports-880b740272adcc7a0e1c078c2e2a7255ea79d1dc.tar.gz
ports-880b740272adcc7a0e1c078c2e2a7255ea79d1dc.zip
Notes
Diffstat (limited to 'devel/as31')
-rw-r--r--devel/as31/Makefile35
-rw-r--r--devel/as31/files/patch-Makefile24
-rw-r--r--devel/as31/pkg-descr10
3 files changed, 49 insertions, 20 deletions
diff --git a/devel/as31/Makefile b/devel/as31/Makefile
index 525557a006fa..d4a6ada4a709 100644
--- a/devel/as31/Makefile
+++ b/devel/as31/Makefile
@@ -9,28 +9,33 @@ MASTER_SITES= http://www.pjrc.com/tech/8051/tools/
DISTNAME= ${PORTNAME}_beta3
MAINTAINER= ports@FreeBSD.org
-COMMENT= A free 8051 assembler
-
-.ifndef(WITHOUT_X11)
-USE_GNOME= gtk12
-PLIST_SUB+= X11=""
-.else
-ALL_TARGET= as31
-PLIST_SUB+= X11="@comment "
-.endif
-USES= bison
+COMMENT= Free 8051 assembler
+# GNU make(1) allows parallel (-jX) builds to work: we plug a race in
+# "bison" rule (which outputs multiple files) via order prerequisites
+# (see files/patch-Makefile)
+USES= bison gmake
WRKSRC= ${WRKDIR}/${PORTNAME}
-MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}"
MAN1= as31.1
PLIST_FILES= bin/as31 %%X11%%bin/as31_gtk
+OPTIONS_DEFINE= X11
+OPTIONS_SUB= yes
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MX11}
+USE_GNOME= gtk12
+.else
+ALL_TARGET= as31
+.endif
+
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/as31 ${PREFIX}/bin
- @${INSTALL_MAN} ${WRKSRC}/as31.1 ${MANPREFIX}/man/man1
-.ifndef(WITHOUT_X11)
- @${INSTALL} ${WRKSRC}/as31_gtk ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/as31 ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/as31.1 ${MANPREFIX}/man/man1
+.if ${PORT_OPTIONS:MX11}
+ ${INSTALL_PROGRAM} ${WRKSRC}/as31_gtk ${PREFIX}/bin
.endif
.include <bsd.port.mk>
diff --git a/devel/as31/files/patch-Makefile b/devel/as31/files/patch-Makefile
new file mode 100644
index 000000000000..be82cb1bae9c
--- /dev/null
+++ b/devel/as31/files/patch-Makefile
@@ -0,0 +1,24 @@
+--- Makefile.orig Fri Nov 21 14:10:27 2003
++++ Makefile Fri Nov 21 14:10:55 2003
+@@ -20,8 +20,8 @@
+
+
+ #Use this CFLAGS line with gcc on linux
+-CFLAGS=-O3 -Wall
+-CC=gcc
++CFLAGS?=-O3 -Wall
++CC?=gcc
+
+ #Use this CFLAGS line on solaris, etc
+ #CFLAGS=-O
+@@ -44,8 +44,9 @@ as31_gtk: $(OBJ) as31_gtk.o
+ chmod a+rx as31
+ strip as31
+
+-parser.c parser.h: parser.y
++parser.c: parser.y
+ bison -d -o parser.c parser.y
++parser.h: | parser.c
+
+ as31_gtk.o: as31_gtk.c as31.h
+ $(CC) $(CFLAGS) `gtk-config --cflags` -c as31_gtk.c
diff --git a/devel/as31/pkg-descr b/devel/as31/pkg-descr
index 8e729b00f282..986971e4f4bd 100644
--- a/devel/as31/pkg-descr
+++ b/devel/as31/pkg-descr
@@ -1,7 +1,7 @@
-AS31 is a free 8051 assembler originally written by Ken Stauffer.
-Versions of AS31 found here include important bug fixes and added
-features, such as standard intel-hex output format for use with
-PAULMON2 and EPROM programmers. AS31 is a good tool for building
-small 8051-based projects that are written in 100% 8051 assembly language.
+AS31 is a free 8051 assembler originally written by Ken Stauffer. Versions
+of AS31 found here include important bug fixes and added features, such as
+standard intel-hex output format for use with PAULMON2 and EPROM programmers.
+AS31 is a good tool for building small 8051-based projects that are written
+in 100% 8051 assembly language.
WWW: http://www.pjrc.com/tech/8051/