aboutsummaryrefslogtreecommitdiff
path: root/devel/as80
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2001-12-01 15:36:22 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2001-12-01 15:36:22 +0000
commiteb708516802338ff4f62846507f8d0f7ed521e84 (patch)
treec80c435e80867b6d761e17477cd011b14066fb95 /devel/as80
parent84f776a5a5920b4b1d381a809db514cbb4931ee6 (diff)
downloadports-eb708516802338ff4f62846507f8d0f7ed521e84.tar.gz
ports-eb708516802338ff4f62846507f8d0f7ed521e84.zip
Notes
Diffstat (limited to 'devel/as80')
-rw-r--r--devel/as80/Makefile9
-rw-r--r--devel/as80/distinfo2
-rw-r--r--devel/as80/files/patch-README14
-rw-r--r--devel/as80/files/patch-aa11
-rw-r--r--devel/as80/files/patch-ab9
-rw-r--r--devel/as80/files/patch-src_as80.c105
-rw-r--r--devel/as80/files/patch-src_aux.c13
-rw-r--r--devel/as80/files/patch-src_symtbl.c13
-rw-r--r--devel/as80/pkg-comment2
-rw-r--r--devel/as80/pkg-descr19
-rw-r--r--devel/as80/pkg-plist3
11 files changed, 156 insertions, 44 deletions
diff --git a/devel/as80/Makefile b/devel/as80/Makefile
index d6c720e2b319..c6e12870f45a 100644
--- a/devel/as80/Makefile
+++ b/devel/as80/Makefile
@@ -6,20 +6,21 @@
#
PORTNAME= as80
-PORTVERSION= 0.6.2
+PORTVERSION= 0.8
CATEGORIES= devel
MASTER_SITES= http://www.tstrathmann.de/files/
MAINTAINER= greid@FreeBSD.org
WRKSRC= ${WRKDIR}/${PORTNAME}
+BUILD_WRKSRC= ${WRKSRC}/src
+MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}"
+ALL_TARGET= as80
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/as80 ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/asm80 ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/as80 ${PREFIX}/bin
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/as80
- ${INSTALL_DATA} ${WRKSRC}/Manual.txt ${PREFIX}/share/doc/as80
${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/as80
.endif
diff --git a/devel/as80/distinfo b/devel/as80/distinfo
index ad70c44f3833..c20687bdc3ba 100644
--- a/devel/as80/distinfo
+++ b/devel/as80/distinfo
@@ -1 +1 @@
-MD5 (as80-0.6.2.tar.gz) = d031294e7b00db639e5ccc4fcc5de533
+MD5 (as80-0.8.tar.gz) = 6b002716ce22df6410d54edc926dfb00
diff --git a/devel/as80/files/patch-README b/devel/as80/files/patch-README
new file mode 100644
index 000000000000..0089c4e84b9f
--- /dev/null
+++ b/devel/as80/files/patch-README
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- README.orig Sat Dec 1 14:17:47 2001
++++ README Sat Dec 1 14:18:09 2001
+@@ -18,7 +18,7 @@
+ This is version 0.8
+
+
+-usage: asm80 infile [outfile] [-l listfile] [-s symfile]
++usage: as80 infile [outfile] [-l listfile] [-s symfile]
+
+ infile is the assembler's input
+ outfile is the binary output file
diff --git a/devel/as80/files/patch-aa b/devel/as80/files/patch-aa
deleted file mode 100644
index eaf691dbc6b4..000000000000
--- a/devel/as80/files/patch-aa
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.orig Thu Feb 15 10:54:44 2001
-+++ Makefile Thu Feb 15 10:55:00 2001
-@@ -1,6 +1,5 @@
--CC = gcc
--CFLAGS = -Wall -pedantic -ansi -O3 -fomit-frame-pointer
--PREFIX = /usr/local
-+CC? = gcc
-+CFLAGS += -Wall -pedantic -ansi
-
- all: asm80 Manual.txt
-
diff --git a/devel/as80/files/patch-ab b/devel/as80/files/patch-ab
deleted file mode 100644
index f9a6c6619828..000000000000
--- a/devel/as80/files/patch-ab
+++ /dev/null
@@ -1,9 +0,0 @@
---- asm80.c.orig Sun Jan 14 14:08:12 2001
-+++ asm80.c Thu Feb 15 10:55:50 2001
-@@ -23,7 +23,6 @@
- #include <stdio.h>
- #include <string.h>
- #include <stdlib.h>
--#include <malloc.h>
- #include "asm80.h"
-
diff --git a/devel/as80/files/patch-src_as80.c b/devel/as80/files/patch-src_as80.c
new file mode 100644
index 000000000000..b830be9ee7db
--- /dev/null
+++ b/devel/as80/files/patch-src_as80.c
@@ -0,0 +1,105 @@
+
+$FreeBSD$
+
+--- src/as80.c.orig Fri Nov 30 02:34:26 2001
++++ src/as80.c Fri Nov 30 02:36:13 2001
+@@ -26,11 +26,6 @@
+ #include <stdlib.h>
+ #include <ctype.h>
+ #include <errno.h>
+-
+-#if SYSTEM == GNU
+-#include <getopt.h>
+-#endif
+-
+ #include "types.h"
+ #include "symtbl.h"
+ #include "as80.h"
+@@ -218,8 +213,6 @@
+ int
+ init (int argc, char **argv)
+ {
+-/* on a GNU system we can use getopt to parse command line options */
+-#if SYSTEM == GNU
+ int index, c;
+
+ /* no proper command line input */
+@@ -294,78 +287,6 @@
+ break;
+ }
+ }
+-
+-#else
+- /* otherwise we have to do it manually */
+- int arg = 1;
+-
+- puts ("non-GNU system\n");
+-
+- /* no proper command line input */
+- if (argc < 2)
+- {
+- fprintf (stderr,
+- "usage: %s infile [-o outfile] [-l listfile] [-s symfile]\n",
+- argv[0]);
+- return ERR_INIT;
+- }
+-
+- /* parse */
+- while (arg < argc)
+- {
+- if (argv[arg][0] != '-')
+- {
+- iname = argv[arg];
+- if ((IN = fopen (iname, "r")) == NULL)
+- {
+- perror ("couldn't open input file");
+- return ERR_INIT;
+- }
+- arg = 1;
+- break;
+- }
+- arg++;
+- }
+-
+- while ((arg < argc) && (argv[arg][0] == '-'))
+- {
+- if (strcmp (argv[arg], "-o"))
+- {
+- if ((OUT = fopen (argv[++arg], "wb")) == NULL)
+- {
+- perror ("couldn't topen output file");
+- return ERR_INIT;
+- }
+- doout = 1;
+- }
+- else if (strcmp (argv[arg], "-l"))
+- {
+- if ((LST = fopen (optarg, "w")) == NULL)
+- {
+- perror ("couldn't open list file");
+- return ERR_INIT;
+- }
+- dolist = 1;
+- }
+- else if (strcmp (argv[arg], "-s"))
+- {
+- if ((SYM = fopen (optarg, "w")) == NULL)
+- {
+- perror ("couldn't open symbol file");
+- return ERR_INIT;
+- }
+- dosym = 1;
+- }
+- else
+- {
+- fprintf (stderr, "unknown option %s\n", argv[arg]);
+- return ERR_INIT;
+- }
+-
+- arg++;
+- }
+-
+-#endif
+
+ /* open default outputfile */
+ if (doout == 0)
diff --git a/devel/as80/files/patch-src_aux.c b/devel/as80/files/patch-src_aux.c
new file mode 100644
index 000000000000..e7525997bdb6
--- /dev/null
+++ b/devel/as80/files/patch-src_aux.c
@@ -0,0 +1,13 @@
+
+$FreeBSD$
+
+--- src/aux.c.orig Fri Nov 30 02:36:50 2001
++++ src/aux.c Fri Nov 30 02:36:51 2001
+@@ -22,6 +22,7 @@
+
+ #include <stdlib.h>
+ #include <ctype.h>
++#include <string.h>
+ #include "aux.h"
+
+
diff --git a/devel/as80/files/patch-src_symtbl.c b/devel/as80/files/patch-src_symtbl.c
new file mode 100644
index 000000000000..0282de852473
--- /dev/null
+++ b/devel/as80/files/patch-src_symtbl.c
@@ -0,0 +1,13 @@
+
+$FreeBSD$
+
+--- src/symtbl.c.orig Fri Nov 30 02:35:55 2001
++++ src/symtbl.c Fri Nov 30 02:36:08 2001
+@@ -22,6 +22,7 @@
+
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
+ #include "types.h"
+ #include "symtbl.h"
+
diff --git a/devel/as80/pkg-comment b/devel/as80/pkg-comment
index da9f85a6a693..d1240b72d8a1 100644
--- a/devel/as80/pkg-comment
+++ b/devel/as80/pkg-comment
@@ -1 +1 @@
-A lightweight 8080/8085 assembler for UN*X systems
+A lightweight 8080/8085 assembler
diff --git a/devel/as80/pkg-descr b/devel/as80/pkg-descr
index f156ab13e442..0e8494baaf46 100644
--- a/devel/as80/pkg-descr
+++ b/devel/as80/pkg-descr
@@ -1,17 +1,4 @@
-As80 is a lightweight 8080/8085 assembler for UN*X systems. It was
-developed on a Debian GNU/Linux System and should well work on other
-UN*Xes. As80 is not invoked directly but through a wrapper shell
-script (asm) that handles some basic conversion (upper to lower etc.). So
-be sure to use this instead of directly running as80 and getting lots of
-(if you are lucky, meaningful) error messages.
+As80 is a table-driven assembler for the 8080/8085 line of
+microprocessors from Intel. It uses cpp for macros and includes.
-Although As80 is still in a somewhat early phase of development, it
-won't take much to come to one level with professional assemblers. The
-use of the C preprocessor instead of implementing some of the
-functionality (.EQU comes to mind) makes it easy to write assembler
-source programs in a more flexible way. At least, that's what I think.
-You are of course welcome to improve and/or add as you like, but be
-sure to always obey the license terms.
-
-- George Reid
-greid@ukug.uk.freebsd.org
+WWW: http://www.tstrathmann.de/as80.html
diff --git a/devel/as80/pkg-plist b/devel/as80/pkg-plist
index 5cdb3775970c..b1e01f59e6cd 100644
--- a/devel/as80/pkg-plist
+++ b/devel/as80/pkg-plist
@@ -1,5 +1,4 @@
+@comment $FreeBSD$
bin/as80
-bin/asm80
-share/doc/as80/Manual.txt
share/doc/as80/README
@dirrm share/doc/as80