aboutsummaryrefslogtreecommitdiff
path: root/devel/asmutils
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2006-02-21 14:45:40 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2006-02-21 14:45:40 +0000
commita58aa858eb38227bc02dc30254259270e3aa9286 (patch)
treeb97290ddf676bd8b087515bda52e7ed4da87be8b /devel/asmutils
parent08e6551ef20a5b91057e6674ff9fee0b99485e07 (diff)
- Update to 0.18, first release in >3 years! [1]
- Reorganize Makefile - Kill pkg-plist - Axe out implied USE_REINPLACE Triggered into by: fenner's distfile survey [1]
Notes
Notes: svn path=/head/; revision=156586
Diffstat (limited to 'devel/asmutils')
-rw-r--r--devel/asmutils/Makefile62
-rw-r--r--devel/asmutils/distinfo6
-rw-r--r--devel/asmutils/files/patch-MCONFIG15
-rw-r--r--devel/asmutils/pkg-plist60
4 files changed, 51 insertions, 92 deletions
diff --git a/devel/asmutils/Makefile b/devel/asmutils/Makefile
index 242778b336a0..6a1579fc92d5 100644
--- a/devel/asmutils/Makefile
+++ b/devel/asmutils/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= asmutils
-PORTVERSION= 0.17
+PORTVERSION= 0.18
CATEGORIES= devel
MASTER_SITES= http://asm.sourceforge.net/asmutils/
@@ -18,27 +18,38 @@ BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
ONLY_FOR_ARCHS= i386
USE_GMAKE= yes
-USE_REINPLACE= yes
INSTALLS_SHLIB= yes
LDCONFIG_DIRS= ${PREFIX}/lib/asmutils
# This will play merry hell with portlint
-BINARIES= asmutils basename cat chmod chown chroot cp cpuinfo date \
- dd dirname echo env execve extname factor grep head \
- hexdump hostname httpd id init kill ln ls lzss md5sum \
- mkdir more mv nc ping pwd rc6crypt renice report rm rmdsum \
- sh sleep strings sync tee true uname wc yes
+BINS= bonus/asmutils basename cal cat chmod chown chroot cmp cp \
+ cpuinfo cut date dc dd deflate dirname du echo env bonus/execve \
+ extname factor fromdos ftpd getty grep head hexdump host hostname \
+ httpd id idea init kill kldload less ln ls lzss m_inetd md5 \
+ md5sum mkdir mknod mount mv nc netstat nice nm nohup od \
+ paste ping pop3d proxy pwd rc6crypt readelf readkey readlink \
+ reboot renice bonus/report rm rmdsum rot13 scan scons sh sha1sum \
+ sleep strings sync tail tar tee telnet telnetd test touch tr \
+ true uname uuencode watch wc wget which whoami write yes
-PORTDOCS= Asmutils-HOWTO.html acknowledgements.html endorsements.html \
- history.html index.html s-contrib.html s-debug.html \
- s-include.html s-layout.html s-optimize.html
+LINKS= arch cpuspeed domainname false halt inflate kldstat kldunload \
+ mkfifo more poweroff regs rmdir size sln todos umount usleep
+
+LIBS= libc.so.0 libcrypto.so.0 libm.so.0
+
+DOCS= Asmutils-HOWTO.html acknowledgements.html endorsements.html \
+ history.html s-contrib.html s-debug.html s-include.html \
+ s-layout.html s-optimize.html sha1sum.html sha1sum_toc.html
+
+PLIST_FILES= ${BINS:S/^/bin\/asmutils\//:S/bonus\///} \
+ ${LINKS:S/^/bin\/asmutils\//} ${LIBS:S/^/lib\/asmutils\//}
+PLIST_DIRS= bin/asmutils lib/asmutils
+PORTDOCS= *
post-patch:
@${REINPLACE_CMD} -e 's,%%KERNEL%%,${OSREL:S/.//g},g' ${WRKSRC}/MCONFIG
- @${REINPLACE_CMD} -e 's,m386,march=i386,' ${WRKSRC}/lib/Makefile
- @${REINPLACE_CMD} -E 's,(^all:[[:space:]]+)check[[:space:]]*,\1,' \
- ${WRKSRC}/lib/Makefile ${WRKSRC}/src/Makefile
+ @${REINPLACE_CMD} -e 's,^static ,,' ${WRKSRC}/lib/libm.c
# Stripping binaries will break install
STRIP= #
@@ -46,25 +57,38 @@ STRIP= #
do-install:
@${MKDIR} ${PREFIX}/bin/asmutils
@${MKDIR} ${PREFIX}/lib/asmutils
-.for B in ${BINARIES}
+.for B in ${BINS}
${INSTALL_PROGRAM} ${WRKSRC}/src/${B} ${PREFIX}/bin/asmutils
.endfor
+.for L in ${LIBS}
+ ${INSTALL_PROGRAM} ${WRKSRC}/lib/${L} ${PREFIX}/lib/asmutils
+.endfor
(cd ${PREFIX}/bin/asmutils && \
${LN} -sf uname arch && \
${LN} -sf cpuinfo cpuspeed && \
${LN} -sf hostname domainname && \
${LN} -sf true false && \
+ ${LN} -sf reboot halt && \
+ ${LN} -sf deflate inflate && \
+ ${LN} -sf kldload kldstat && \
+ ${LN} -sf kldload kldunload && \
+ ${LN} -sf mknod mkfifo && \
+ ${LN} -sf less more && \
+ ${LN} -sf reboot poweroff && \
${LN} -sf execve regs && \
${LN} -sf mkdir rmdir && \
- ${LN} -sf ln sln)
-.for L in c crypto m
- ${INSTALL_PROGRAM} ${WRKSRC}/lib/lib${L}.so.0 ${PREFIX}/lib/asmutils
-.endfor
+ ${LN} -sf nm size && \
+ ${LN} -sf ln sln && \
+ ${LN} -sf fromdos todos && \
+ ${LN} -sf mount umount && \
+ ${LN} -sf sleep usleep)
+
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
-.for D in ${PORTDOCS}
+.for D in ${DOCS}
${INSTALL_DATA} ${WRKSRC}/doc/${D} ${DOCSDIR}
.endfor
+ cd ${DOCSDIR} && ${LN} -sf Asmutils-HOWTO.html index.html
.endif
.include <bsd.port.mk>
diff --git a/devel/asmutils/distinfo b/devel/asmutils/distinfo
index 82377ed165c5..0e3381bf8a99 100644
--- a/devel/asmutils/distinfo
+++ b/devel/asmutils/distinfo
@@ -1,3 +1,3 @@
-MD5 (asmutils-0.17.tar.gz) = 9027cff8f8f50cf4fa9b0e62fc4a8854
-SHA256 (asmutils-0.17.tar.gz) = 6e51ee22a800244cac3d62ce0bab2de9c90b88648f87add6e6f5597ee746615a
-SIZE (asmutils-0.17.tar.gz) = 332675
+MD5 (asmutils-0.18.tar.gz) = a11c8fea347026449ecd2e5807e77d64
+SHA256 (asmutils-0.18.tar.gz) = 905e58521c9c85ae64a243ff8a05503ddaed3d808a99aa6db8737d0bfb16d38a
+SIZE (asmutils-0.18.tar.gz) = 361157
diff --git a/devel/asmutils/files/patch-MCONFIG b/devel/asmutils/files/patch-MCONFIG
index 25ea1fdd8883..4dbe0c311963 100644
--- a/devel/asmutils/files/patch-MCONFIG
+++ b/devel/asmutils/files/patch-MCONFIG
@@ -1,6 +1,6 @@
--- MCONFIG.orig Fri Mar 15 01:42:46 2002
+++ MCONFIG Sun Feb 8 01:06:18 2004
-@@ -13,11 +13,11 @@
+@@ -13,7 +13,7 @@
# Target operating system. Valid values are:
# LINUX FREEBSD OPENBSD NETBSD SOLARIS UNIXWARE BEOS ATHEOS
@@ -9,17 +9,12 @@
# Kernel version of target OS (1.2 = 12, 2.4 = 24, 3.6 = 36, etc)
+@@ -25,7 +25,7 @@
+ # in executable even if it is not present in object file.
+ # So, if your ld always adds .bss - you can just forget about it.
+
-KERNEL = 24
+KERNEL = %%KERNEL%%
# Optimization method (SIZE/SPEED)
-@@ -93,7 +93,7 @@
-
- ASVER := $(shell $(AS) -r | cut -d ' ' -f 3)
- #LDVER := $(shell $(LD) -v | cut -d ' ' -f 4)
--CORRECT_ASVER = 0.98
-+CORRECT_ASVER = 0.98.38
-
- #
- # avoid using asmutils during the build process if PATH has '.'
diff --git a/devel/asmutils/pkg-plist b/devel/asmutils/pkg-plist
deleted file mode 100644
index 867ee55073f6..000000000000
--- a/devel/asmutils/pkg-plist
+++ /dev/null
@@ -1,60 +0,0 @@
-bin/asmutils/arch
-bin/asmutils/asmutils
-bin/asmutils/basename
-bin/asmutils/cat
-bin/asmutils/chmod
-bin/asmutils/chown
-bin/asmutils/chroot
-bin/asmutils/cp
-bin/asmutils/cpuinfo
-bin/asmutils/cpuspeed
-bin/asmutils/date
-bin/asmutils/dd
-bin/asmutils/dirname
-bin/asmutils/domainname
-bin/asmutils/echo
-bin/asmutils/env
-bin/asmutils/execve
-bin/asmutils/extname
-bin/asmutils/factor
-bin/asmutils/false
-bin/asmutils/grep
-bin/asmutils/head
-bin/asmutils/hexdump
-bin/asmutils/hostname
-bin/asmutils/httpd
-bin/asmutils/id
-bin/asmutils/init
-bin/asmutils/kill
-bin/asmutils/ln
-bin/asmutils/ls
-bin/asmutils/lzss
-bin/asmutils/md5sum
-bin/asmutils/mkdir
-bin/asmutils/more
-bin/asmutils/mv
-bin/asmutils/nc
-bin/asmutils/ping
-bin/asmutils/pwd
-bin/asmutils/rc6crypt
-bin/asmutils/regs
-bin/asmutils/renice
-bin/asmutils/report
-bin/asmutils/rm
-bin/asmutils/rmdir
-bin/asmutils/rmdsum
-bin/asmutils/sh
-bin/asmutils/sleep
-bin/asmutils/sln
-bin/asmutils/strings
-bin/asmutils/sync
-bin/asmutils/tee
-bin/asmutils/true
-bin/asmutils/uname
-bin/asmutils/wc
-bin/asmutils/yes
-lib/asmutils/libc.so.0
-lib/asmutils/libcrypto.so.0
-lib/asmutils/libm.so.0
-@dirrm lib/asmutils
-@dirrm bin/asmutils