aboutsummaryrefslogtreecommitdiff
path: root/devel/asmx
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2008-10-28 21:22:30 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2008-10-28 21:22:30 +0000
commite384ec9fcd59204111eeb35defcd577221c60918 (patch)
tree56540cda53de15e9fa0197f80e49fe68812d03fa /devel/asmx
parentec0468f1db3b891a8d533ae040d6fb2357821aa9 (diff)
downloadports-e384ec9fcd59204111eeb35defcd577221c60918.tar.gz
ports-e384ec9fcd59204111eeb35defcd577221c60918.zip
Notes
Diffstat (limited to 'devel/asmx')
-rw-r--r--devel/asmx/Makefile101
-rw-r--r--devel/asmx/distinfo3
-rw-r--r--devel/asmx/files/Makefile34
-rw-r--r--devel/asmx/pkg-descr20
4 files changed, 158 insertions, 0 deletions
diff --git a/devel/asmx/Makefile b/devel/asmx/Makefile
new file mode 100644
index 000000000000..b8824e71b1eb
--- /dev/null
+++ b/devel/asmx/Makefile
@@ -0,0 +1,101 @@
+# New ports collection makefile for: asmx
+# Date created: 28 October 2008
+# Whom: elbarto
+#
+# $FreeBSD$
+#
+
+PORTNAME= asmx
+PORTVERSION= 1.8.2
+CATEGORIES= devel
+MASTER_SITES= http://xi6.com/files/ \
+ http://distfiles.arcadebsd.org/
+
+MAINTAINER= elbarto@ArcadeBSD.org
+COMMENT= Multi-CPU macro assembler for many major 8-bit and 16-bit CPUs
+
+WRKSRC= ${WRKDIR}
+USE_ZIP= yes
+ALL_TARGET=
+
+PORTDOCS= README.txt
+
+OPTIONS= 1802 "RCA 1802" On \
+ 6502 "MOS Technology 6502, 65C02 and 6502" On \
+ 6809 "Motorola 6809" On \
+ 68HC11 "Motorola 6800/6801/68HC11 and Hitachi 6303" On \
+ 68HC16 "Motorola 68HC16" On \
+ 68000 "Motorola 68000/68010" On \
+ 8051 "Intel 8051" On \
+ 8085 "Intel 8080 and 8085" On \
+ F8 "Fairchild F8" On \
+ Z80 "Zilog Z-80 and Nintendo Gameboy Z-80 variant" On
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_1802)
+ALL_TARGET+= asmx-1802
+PLIST_FILES+= bin/asmx-1802
+.endif
+
+.if defined(WITH_6502)
+ALL_TARGET+= asmx-6502
+PLIST_FILES+= bin/asmx-6502
+.endif
+
+.if defined(WITH_6809)
+ALL_TARGET+= asmx-6809
+PLIST_FILES+= bin/asmx-6809
+.endif
+
+.if defined(WITH_68HC11)
+ALL_TARGET+= asmx-68hc11
+PLIST_FILES+= bin/asmx-68hc11
+.endif
+
+.if defined(WITH_68HC16)
+ALL_TARGET+= asmx-68hc16
+PLIST_FILES+= bin/asmx-68hc16
+.endif
+
+.if defined(WITH_68000)
+ALL_TARGET+= asmx-68k
+PLIST_FILES+= bin/asmx-68k
+.endif
+
+.if defined(WITH_8051)
+ALL_TARGET+= asmx-8051
+PLIST_FILES+= bin/asmx-8051
+.endif
+
+.if defined(WITH_8085)
+ALL_TARGET+= asmx-8085
+PLIST_FILES+= bin/asmx-8085
+.endif
+
+.if defined(WITH_F8)
+ALL_TARGET+= asmx-f8
+PLIST_FILES+= bin/asmx-f8
+.endif
+
+.if defined(WITH_Z80)
+ALL_TARGET+= asmx-z80
+PLIST_FILES+= bin/asmx-z80
+.endif
+
+post-extract:
+ ${CP} ${FILESDIR}/Makefile ${WRKSRC}
+
+pre-build:
+ ${ECHO_CMD} ALL_TARGET=${ALL_TARGET}
+
+do-install:
+.for f in ${ALL_TARGET}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${f} ${PREFIX}/bin/
+.endfor
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.txt ${DOCSDIR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/asmx/distinfo b/devel/asmx/distinfo
new file mode 100644
index 000000000000..8d45d621490e
--- /dev/null
+++ b/devel/asmx/distinfo
@@ -0,0 +1,3 @@
+MD5 (asmx-1.8.2.zip) = 6aa68350e362596d171451da7f262025
+SHA256 (asmx-1.8.2.zip) = 16bc2fb7580664d76d0b6ed7cefc46cc406c059f4667fac4c62e3a976e57222b
+SIZE (asmx-1.8.2.zip) = 106964
diff --git a/devel/asmx/files/Makefile b/devel/asmx/files/Makefile
new file mode 100644
index 000000000000..8585a6464b0e
--- /dev/null
+++ b/devel/asmx/files/Makefile
@@ -0,0 +1,34 @@
+# $FreeBSD$
+
+all:
+ @echo "You have to select an options"
+
+asmx-1802:
+ ${CC} asm1802.c -o asmx-1802
+
+asmx-6502:
+ ${CC} asm6502.c -o asmx-6502
+
+asmx-6809:
+ ${CC} asm6809.c -o asmx-6809
+
+asmx-68hc11:
+ ${CC} asm68hc11.c -o asmx-68hc11
+
+asmx-68hc16:
+ ${CC} asm68hc16.c -o asmx-68hc16
+
+asmx-68k:
+ ${CC} asm68k.c -o asmx-68k
+
+asmx-8051:
+ ${CC} asm8051.c -o asmx-8051
+
+asmx-8085:
+ ${CC} asm8085.c -o asmx-8085
+
+asmx-f8:
+ ${CC} asmf8.c -o asmx-f8
+
+asmx-z80:
+ ${CC} asmz80.c -o asmx-z80
diff --git a/devel/asmx/pkg-descr b/devel/asmx/pkg-descr
new file mode 100644
index 000000000000..7654de5d251a
--- /dev/null
+++ b/devel/asmx/pkg-descr
@@ -0,0 +1,20 @@
+This is a multi-CPU macro assembler for many major 8-bit and 16-bit CPUs
+which can assemble code for multiple CPUs in the same source file.
+
+Current CPUs supported:
+
+ * RCA 1802
+ * MOS Technology 6502, 65C02 and 6502 with undocumented instructions
+ * WDC 65816 (lacks some addressing mode support)
+ * Motorola 6809
+ * Motorola 6800/6801/68HC11 and Hitachi 6303
+ * Motorola 6805/68HSC08
+ * Motorola 68HC16
+ * Motorola 68000/68010
+ * Intel 8051
+ * Intel 8080, 8085, and 8085 with undocumented instructions
+ * Fairchild F8
+ * Atari Jaguar "Tom" and "Jerry" coprocessors
+ * Zilog Z-80 and Nintendo Gameboy Z-80 variant
+
+WWW: http://xi6.com/projects/asmx/