aboutsummaryrefslogtreecommitdiff
path: root/devel/astah-community/Makefile
diff options
context:
space:
mode:
authorTAKATSU Tomonari <tota@FreeBSD.org>2011-05-09 13:01:54 +0000
committerTAKATSU Tomonari <tota@FreeBSD.org>2011-05-09 13:01:54 +0000
commit716d90a1205ef1072b38c2df3ea97b795eea3d0a (patch)
treecfbf273edce23a5fe64acbdd0ed3e1a76b3919ae /devel/astah-community/Makefile
parent3f4d76137417be85ec848c656441dbc3f98a6617 (diff)
downloadports-716d90a1205ef1072b38c2df3ea97b795eea3d0a.tar.gz
ports-716d90a1205ef1072b38c2df3ea97b795eea3d0a.zip
Notes
Diffstat (limited to 'devel/astah-community/Makefile')
-rw-r--r--devel/astah-community/Makefile60
1 files changed, 26 insertions, 34 deletions
diff --git a/devel/astah-community/Makefile b/devel/astah-community/Makefile
index dfeea6042b7d..34310a6abb86 100644
--- a/devel/astah-community/Makefile
+++ b/devel/astah-community/Makefile
@@ -5,74 +5,66 @@
# $FreeBSD$
#
-PORTNAME= jude-community
-PORTVERSION= 5.5.2
+PORTNAME= astah
+PORTVERSION= 6.4
CATEGORIES= devel java
-MASTER_SITES= # you have to register yourself as a member to download
-DISTNAME= ${PORTNAME}-${PORTVERSION:S!.!_!g}
+MASTER_SITES= #
+PKGNAMESUFFIX= -community
+DISTNAME= ${PORTNAME}${PKGNAMESUFFIX}-${PORTVERSION:S!.!_!g}
-MAINTAINER= sarumaru@jp.FreeBSD.org
+MAINTAINER= tota@FreeBSD.org
COMMENT= A Java/UML Object-Oriented Design Tool
USE_ZIP= yes
.include <bsd.port.pre.mk>
-# In case you are going to use JDK1.5 in Japanese environment, make sure
-# you have prepared following command to avoid from font problem:
-# ln -s ${LOCALBASE}/lib/X11/fonts/TrueType \
-# ${LOCALBASE}/diablo-jdk1.5.0/jre/lib/fonts/fallback
-JAVA_VERSION= 1.5+
+JAVA_VERSION= 1.6+
USE_JAVA= yes
-JAVA_OS= native
+JAVA_OS= linux
NO_BUILD= yes
-.include "${PORTSDIR}/Mk/bsd.java.mk"
-
-RESTRICTED= See http://jude.change-vision.com/jude-web/notes/ProductLicenseAgreement.html
-WRKSRC= ${WRKDIR}/${PORTNAME:S!-!_!}
+RESTRICTED= See http://astah.change-vision.com/en/product/astah-eula.html
+WRKSRC= ${WRKDIR}/${PORTNAME}${PKGNAMESUFFIX:S!-!_!}
REINPLACE_ARGS= -i ""
-.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
-DOWNLOAD_URL= http://jude.change-vision.com/jude-web/download/index.html
+.if !exists(${DISTDIR}/${DISTFILES})
+DOWNLOAD_URL= http://members.change-vision.com/files/${PORTNAME}${PKGNAMESUFFIX:S!-!_!}/${PORTVERSION:S!.!_!}/${DISTFILES}
IGNORE= needs you to fetch manually the distribution file\
from ${DOWNLOAD_URL}, \
then place it in ${DISTDIR} and run make again
.endif
-PLIST_FILES= bin/jude
+DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}${PKGNAMESUFFIX}
+DATADIR= ${PREFIX}/share/${PORTNAME}${PKGNAMESUFFIX}
+
+PLIST_FILES= bin/astah
.if !defined(NOPORTDATA)
-PORTDATA= ${PORTNAME}.jar jude-api.jar jude-gui_en.properties_org \
- jude.ico jude-doc.ico Welcome.jude Welcome_ja.jude \
- template \
- mozilla \
- tools.jar
+PORTDATA= astah-community.jar astah-api.jar astah-gui_en.properties_org \
+ astah.ico astah-doc.ico Welcome.asta Welcome_ja.asta \
+ template
.endif
.if !defined(NOPORTDOCS)
PORTDOCS= ReleaseNote-e.html ReleaseNote.html \
ProductInformation.txt \
- README-e.txt README.txt \
API_sample_program_license_agreement-e.txt \
API_sample_program_license_agreement.txt
.endif
post-patch:
- ${REINPLACE_CMD} -e "s!%%JAVA_HOME%%!${JAVA_HOME}!; \
- s!%%DATADIR%%!${DATADIR}!" ${WRKSRC}/jude
+ ${REINPLACE_CMD} -e "s!%%JAVA_HOME%%!${JAVA_HOME}!g; \
+ s!%%DATADIR%%!${DATADIR}!" ${WRKSRC}/astah
.if !defined(NOPORTDOCS)
- ${REINPLACE_CMD} 's/png\\/png\//' ${WRKSRC}/api/*/doc/JudeAPI_reference.html
+ ${REINPLACE_CMD} 's/png\\/png\//' ${WRKSRC}/api/*/doc/astahAPI_reference.html
.endif
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/jude ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/astah ${PREFIX}/bin
.if !defined(NOPORTDATA)
${MKDIR} ${DATADIR}
- (cd ${WRKSRC} && ${COPYTREE_SHARE} "${PORTDATA:Nmozilla:Ntools.jar}" ${DATADIR})
- ${INSTALL_SCRIPT} ${FILESDIR}/mozilla ${DATADIR}
- # ExportHTML needs lib/tools.jar of JDK1.5/1.6
- ${LN} -s ${JAVA_HOME}/lib/tools.jar ${DATADIR}
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} "${PORTDATA}" ${DATADIR})
.endif
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
@@ -81,9 +73,9 @@ do-install:
.endfor
${MKDIR} ${DOCSDIR}/api
(cd ${WRKSRC}/api && ${COPYTREE_SHARE} \* ${DOCSDIR}/api)
- @ cd ${PREFIX} && ${FIND} share/doc/${PORTNAME}/api -type f -print | \
+ @ cd ${PREFIX} && ${FIND} share/doc/${PORTNAME}${PKGNAMESUFFIX}/api -type f -print | \
${SORT} -r >> ${TMPPLIST}
- @ cd ${PREFIX} && ${FIND} share/doc/${PORTNAME}/api -type d -print | \
+ @ cd ${PREFIX} && ${FIND} share/doc/${PORTNAME}${PKGNAMESUFFIX}/api -type d -print | \
${SORT} -r | ${SED} -e 's#^#@dirrm #' >> ${TMPPLIST}
.endif