aboutsummaryrefslogtreecommitdiff
path: root/devel/astah-community
diff options
context:
space:
mode:
authorTAKATSU Tomonari <tota@FreeBSD.org>2013-03-16 02:54:51 +0000
committerTAKATSU Tomonari <tota@FreeBSD.org>2013-03-16 02:54:51 +0000
commit4820fa4509fa68704bce01f9c75fd9e1db08d655 (patch)
tree5cbbfc0c55fa91bd5169e216e158df83535e64a3 /devel/astah-community
parent04927443ba49a5b93e8dc1f475676265ca2b6357 (diff)
downloadports-4820fa4509fa68704bce01f9c75fd9e1db08d655.tar.gz
ports-4820fa4509fa68704bce01f9c75fd9e1db08d655.zip
Notes
Diffstat (limited to 'devel/astah-community')
-rw-r--r--devel/astah-community/Makefile65
-rw-r--r--devel/astah-community/distinfo4
-rw-r--r--devel/astah-community/files/patch-astah11
-rw-r--r--devel/astah-community/files/patch-astah-command.sh11
4 files changed, 45 insertions, 46 deletions
diff --git a/devel/astah-community/Makefile b/devel/astah-community/Makefile
index 20edcc48c516..fa8296b53b95 100644
--- a/devel/astah-community/Makefile
+++ b/devel/astah-community/Makefile
@@ -2,56 +2,53 @@
# $FreeBSD$
PORTNAME= astah
-PORTVERSION= 6.6.4
+PORTVERSION= 6.7.0
CATEGORIES= devel java
MASTER_SITES= #
PKGNAMESUFFIX= -community
DISTNAME= ${PORTNAME}${PKGNAMESUFFIX}-${PORTVERSION:S!.!_!g}-${REVISION}
MAINTAINER= tota@FreeBSD.org
-COMMENT= A Java/UML Object-Oriented Design Tool
+COMMENT= Java/UML Object-Oriented Design Tool
+
+RESTRICTED= See http://astah.net/faq/community/enduser-license-agreement
USE_ZIP= yes
-REVISION= 41775
+USE_JAVA= yes
+JAVA_VERSION= 1.7+
+REVISION= 43495
-.include <bsd.port.pre.mk>
+WRKSRC= ${WRKDIR}/${PORTNAME}${PKGNAMESUFFIX:S!-!_!}
-JAVA_VERSION= 1.6+
+PORTDOCS= API_sample_program_license_agreement.txt \
+ API_sample_program_license_agreement_ja.txt \
+ CommandRunner.html CommandRunner_ja.html \
+ ProductInformation.txt \
+ api
+PORTEXAMPLES= astah-key.properties_org Sample.asta
+PORTDATA= astah-community.jar astah-api.jar astah-gui_en.properties_org \
+ astah.ico astah-doc.ico Welcome.asta Welcome_ja.asta \
+ lib template
-USE_JAVA= yes
-JAVA_OS= native
NO_BUILD= yes
-RESTRICTED= See http://astah.net/faq/community/enduser-license-agreement
-WRKSRC= ${WRKDIR}/${PORTNAME}${PKGNAMESUFFIX:S!-!_!}
-REINPLACE_ARGS= -i ""
-
-.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
-DOWNLOAD_URL= http://members.change-vision.com/files/${PORTNAME}${PKGNAMESUFFIX:S!-!_!}/${PORTVERSION:S!.!_!}/${DISTFILES}
-IGNORE= needs you to fetch manually the distribution file\
- from ${DOWNLOAD_URL}, \
- then place it in ${DISTDIR} and run make again
-.endif
+PLIST_FILES= bin/astah bin/astah-command.sh
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}${PKGNAMESUFFIX}
EXAMPLESDIR= ${PREFIX}/share/examples/${PORTNAME}${PKGNAMESUFFIX}
DATADIR= ${JAVASHAREDIR}/${PORTNAME}${PKGNAMESUFFIX}
-PLIST_FILES= bin/astah bin/astah-command.sh
-PORTDATA= astah-community.jar astah-api.jar astah-gui_en.properties_org \
- astah.ico astah-doc.ico Welcome.asta Welcome_ja.asta \
- lib template
+REINPLACE_ARGS= -i ""
-.if !defined(NOPORTDOCS)
-PORTDOCS= API_sample_program_license_agreement.txt \
- API_sample_program_license_agreement_ja.txt \
- CommandRunner.html CommandRunner_ja.html \
- ProductInformation.txt \
- api
-.endif
+OPTIONS_DEFINE= DOCS EXAMPLES
-.if !defined(NOPORTEXAMPLES)
-PORTEXAMPLES= astah-key.properties_org Sample.asta
+.include <bsd.port.pre.mk>
+
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
+DOWNLOAD_URL= http://members.change-vision.com/files/${PORTNAME}${PKGNAMESUFFIX:S!-!_!}/${PORTVERSION:S!.!_!g}/${DISTFILES}
+IGNORE= needs you to fetch manually the distribution file\
+ from ${DOWNLOAD_URL}, \
+ then place it in ${DISTDIR} and run make again
.endif
post-patch:
@@ -60,8 +57,8 @@ post-patch:
s!%%DATADIR%%!${DATADIR}!" \
${WRKSRC}/${script}
.endfor
-.if !defined(NOPORTDOCS)
- ${REINPLACE_CMD} 's/png\\/png\//' ${WRKSRC}/api/*/doc/astahAPI_reference.html
+.if ${PORT_OPTIONS:MDOCS}
+ ${REINPLACE_CMD} 's/png\\/png\//' ${WRKSRC}/api/en/doc/astahAPI_reference.html
.endif
do-install:
@@ -70,7 +67,7 @@ do-install:
.endfor
${MKDIR} ${DATADIR}
(cd ${WRKSRC} && ${COPYTREE_SHARE} "${PORTDATA}" ${DATADIR})
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
.for docfile in ${PORTDOCS:Napi}
${INSTALL_DATA} ${WRKSRC}/${docfile} ${DOCSDIR}
@@ -78,7 +75,7 @@ do-install:
${MKDIR} ${DOCSDIR}/api
(cd ${WRKSRC}/api && ${COPYTREE_SHARE} \* ${DOCSDIR}/api)
.endif
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
${MKDIR} ${EXAMPLESDIR}
.for examplefile in ${PORTEXAMPLES}
${INSTALL_DATA} ${WRKSRC}/${examplefile} ${EXAMPLESDIR}
diff --git a/devel/astah-community/distinfo b/devel/astah-community/distinfo
index b325ae8a62d3..7435ab54df91 100644
--- a/devel/astah-community/distinfo
+++ b/devel/astah-community/distinfo
@@ -1,2 +1,2 @@
-SHA256 (astah-community-6_6_4-41775.zip) = 7f7b4328a145bad9457386b57c7ede22499f1ad360c674c8464ba930db0f9c0a
-SIZE (astah-community-6_6_4-41775.zip) = 22582299
+SHA256 (astah-community-6_7_0-43495.zip) = 00b4637c21e59a5df209218778cf4c46b1fe37c9bb309c3314f96228a08a3b8e
+SIZE (astah-community-6_7_0-43495.zip) = 25814844
diff --git a/devel/astah-community/files/patch-astah b/devel/astah-community/files/patch-astah
index c3c1d350751d..1774fa3c855d 100644
--- a/devel/astah-community/files/patch-astah
+++ b/devel/astah-community/files/patch-astah
@@ -1,6 +1,6 @@
---- astah.orig 2012-10-24 13:26:12.000000000 +0900
-+++ astah 2012-11-02 21:45:00.000000000 +0900
-@@ -3,13 +3,14 @@
+--- astah.orig 2013-03-08 06:02:20.000000000 +0900
++++ astah 2013-03-15 10:47:26.000000000 +0900
+@@ -3,9 +3,10 @@
#Remove "#" from following two lines, if you'd like to use j2sdk.
#JAVA_HOME=/usr/lib/j2sdk1.4/;export JAVA_HOME
#PATH=$JAVA_HOME/bin:$PATH; export PATH
@@ -13,8 +13,9 @@
ASTAH_JAR=astah-community.jar
CLASSPATH=$ASTAH_HOME/$ASTAH_JAR
-
+@@ -13,4 +14,4 @@
JAVA_OPTS="-Xms16m -Xmx384m"
+ #JAVA_OPTS="\$JAVA_OPTS -DrootLevel=DEBUG"
-java $JAVA_OPTS -jar $ASTAH_HOME/$ASTAH_JAR "$1" $2 $3
-+%%JAVA_HOME%%/bin/java $JAVA_OPTS -jar $ASTAH_HOME/$ASTAH_JAR "$1" $2 $3
++%%JAVA_HOME%%/bin/java $JAVA_OPTS -jar $ASTAH_HOME/$ASTAH_JAR "$1" $2 $3
diff --git a/devel/astah-community/files/patch-astah-command.sh b/devel/astah-community/files/patch-astah-command.sh
index 3b19cf0b2da2..ceee7e423459 100644
--- a/devel/astah-community/files/patch-astah-command.sh
+++ b/devel/astah-community/files/patch-astah-command.sh
@@ -1,16 +1,17 @@
---- astah-command.sh.orig 2012-03-19 00:16:44.000000000 +0900
-+++ astah-command.sh 2012-03-25 21:36:30.000000000 +0900
-@@ -22,11 +22,11 @@
+--- astah-command.sh.orig 2013-03-08 06:02:20.000000000 +0900
++++ astah-command.sh 2013-03-15 10:50:23.000000000 +0900
+@@ -22,7 +22,7 @@
#export PATH=$PATH:$JAVA_HOME/bin
#ASTAH_HOME=/usr/lib/astah_community
--ASTAH_HOME=`pwd`
+-ASTAH_HOME=`dirname "$0"`
+ASTAH_HOME=%%DATADIR%%
INITIAL_HEAP_SIZE=64m
MAXIMUM_HEAP_SIZE=1024m
-
+@@ -30,4 +30,4 @@
JAVA_OPTS="-Xms$INITIAL_HEAP_SIZE -Xmx$MAXIMUM_HEAP_SIZE"
+ #JAVA_OPTS="\$JAVA_OPTS -DrootLevel=DEBUG"
-java $JAVA_OPTS -cp "$ASTAH_HOME/astah-community.jar" com.change_vision.jude.cmdline.JudeCommandRunner "$@"
+%%JAVA_HOME%%/bin/java $JAVA_OPTS -cp "$ASTAH_HOME/astah-community.jar" com.change_vision.jude.cmdline.JudeCommandRunner "$@"