aboutsummaryrefslogtreecommitdiff
path: root/devel/astah-community
diff options
context:
space:
mode:
authorTAKATSU Tomonari <tota@FreeBSD.org>2013-12-14 13:28:35 +0000
committerTAKATSU Tomonari <tota@FreeBSD.org>2013-12-14 13:28:35 +0000
commitc58d4a0b0fe48eaa32a664f8ae7f3b45f5d9153e (patch)
tree55c22a1d6669638b0feb4fcf83f03d3ff679ed10 /devel/astah-community
parent3bd33211362c8b029487c53ff883d71c55881367 (diff)
downloadports-c58d4a0b0fe48eaa32a664f8ae7f3b45f5d9153e.tar.gz
ports-c58d4a0b0fe48eaa32a664f8ae7f3b45f5d9153e.zip
Notes
Diffstat (limited to 'devel/astah-community')
-rw-r--r--devel/astah-community/Makefile25
1 files changed, 15 insertions, 10 deletions
diff --git a/devel/astah-community/Makefile b/devel/astah-community/Makefile
index 17cf33e64e94..5c04a99a2f4a 100644
--- a/devel/astah-community/Makefile
+++ b/devel/astah-community/Makefile
@@ -11,7 +11,13 @@ DISTNAME= ${PORTNAME}${PKGNAMESUFFIX}-${PORTVERSION:S!.!_!g}-${REVISION}
MAINTAINER= tota@FreeBSD.org
COMMENT= Java/UML Object-Oriented Design Tool
+LICENSE= EULA
+LICENSE_NAME= End User License Agreement
+LICENSE_TEXT= ${RESTRICTED}
+LICENSE_PERMS= no-dist-mirror no-dist-sell no-pkg-mirror no-pkg-sell no-auto-accept
+
RESTRICTED= See http://astah.net/faq/community/enduser-license-agreement
+LEGAL_TEXT= License restrictions
USE_ZIP= yes
USE_JAVA= yes
@@ -42,7 +48,6 @@ REINPLACE_ARGS= -i ""
OPTIONS_DEFINE= DOCS EXAMPLES
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
@@ -64,22 +69,22 @@ post-patch:
do-install:
.for script in ${PLIST_FILES:S!bin/!!}
- ${INSTALL_SCRIPT} ${WRKSRC}/${script} ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/${script} ${STAGEDIR}${PREFIX}/bin
.endfor
- ${MKDIR} ${DATADIR}
- (cd ${WRKSRC} && ${COPYTREE_SHARE} "${PORTDATA}" ${DATADIR})
+ ${MKDIR} ${STAGEDIR}${DATADIR}
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} "${PORTDATA}" ${STAGEDIR}${DATADIR})
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
.for docfile in ${PORTDOCS:Napi}
- ${INSTALL_DATA} ${WRKSRC}/${docfile} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${docfile} ${STAGEDIR}${DOCSDIR}
.endfor
- ${MKDIR} ${DOCSDIR}/api
- (cd ${WRKSRC}/api && ${COPYTREE_SHARE} \* ${DOCSDIR}/api)
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}/api
+ (cd ${WRKSRC}/api && ${COPYTREE_SHARE} \* ${STAGEDIR}${DOCSDIR}/api)
.endif
.if ${PORT_OPTIONS:MEXAMPLES}
- ${MKDIR} ${EXAMPLESDIR}
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
.for examplefile in ${PORTEXAMPLES}
- ${INSTALL_DATA} ${WRKSRC}/${examplefile} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${examplefile} ${STAGEDIR}${EXAMPLESDIR}
.endfor
.endif