aboutsummaryrefslogtreecommitdiff
path: root/devel/astyle/Makefile
diff options
context:
space:
mode:
authorLars Engels <lme@FreeBSD.org>2016-10-04 21:51:15 +0000
committerLars Engels <lme@FreeBSD.org>2016-10-04 21:51:15 +0000
commit1fb2567105045cc39e7732952d740458b39e4ebd (patch)
treecaa2258f995c71b3e081110ffbdb21723254778c /devel/astyle/Makefile
parentde257c947953a819b342e1f6147e3037e2e152a7 (diff)
Notes
Diffstat (limited to 'devel/astyle/Makefile')
-rw-r--r--devel/astyle/Makefile8
1 files changed, 2 insertions, 6 deletions
diff --git a/devel/astyle/Makefile b/devel/astyle/Makefile
index e2dc125f12c2..d9a636de8d1c 100644
--- a/devel/astyle/Makefile
+++ b/devel/astyle/Makefile
@@ -13,22 +13,18 @@ COMMENT= Source code indenter and formatter for C, C++, C\#, and Java
LICENSE= LGPL3
ALL_TARGET= astyle
-CFLAGS+= -W -Wall -fno-rtti -fno-exceptions
LDFLAGS+= -s
-MAKE_ARGS+= CFLAGS="${CFLAGS}"
USES= compiler gmake iconv
-WRKSRC= ${WRKDIR}/astyle/build/gcc
+WRKSRC= ${WRKDIR}/astyle/build/${COMPILER_TYPE}
OPTIONS_DEFINE= DOCS
pre-patch:
- @${REINPLACE_CMD} -e 's,^CFLAGS,#CFLAGS,; s,g++,${CXX},; \
- s,\(CFLAGSr.*=.*\),\1 -I${LOCALBASE}/include,' \
+ @${REINPLACE_CMD} -e 's,\(CFLAGSr.*=.*\),\1 -I${LOCALBASE}/include,' \
${WRKSRC}/Makefile
do-install:
- ${STRIP_CMD} ${WRKSRC}/bin/astyle
${INSTALL_PROGRAM} ${WRKSRC}/bin/astyle ${STAGEDIR}${PREFIX}/bin
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKDIR}/astyle/doc/* ${STAGEDIR}${DOCSDIR}