aboutsummaryrefslogtreecommitdiff
path: root/devel/astyle
diff options
context:
space:
mode:
authorLars Engels <lme@FreeBSD.org>2014-02-18 21:57:56 +0000
committerLars Engels <lme@FreeBSD.org>2014-02-18 21:57:56 +0000
commitfbbf2b7cc48007daaea6576d1bcf228c216e8d1f (patch)
treec8985dc3e84a360c9af0f1d321e238c86feb31a8 /devel/astyle
parent1237a9027fa185e702d3e27387f663be1d77d4cb (diff)
downloadports-fbbf2b7cc48007daaea6576d1bcf228c216e8d1f.tar.gz
ports-fbbf2b7cc48007daaea6576d1bcf228c216e8d1f.zip
Notes
Diffstat (limited to 'devel/astyle')
-rw-r--r--devel/astyle/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/devel/astyle/Makefile b/devel/astyle/Makefile
index e791638357a2..6c5aa819ff84 100644
--- a/devel/astyle/Makefile
+++ b/devel/astyle/Makefile
@@ -16,17 +16,17 @@ ALL_TARGET= astyle
CFLAGS+= -W -Wall -fno-rtti -fno-exceptions
LDFLAGS+= -s
MAKE_ARGS+= CFLAGS="${CFLAGS}"
-USES= gmake
-USE_GCC= yes
+USES= compiler gmake iconv
WRKSRC= ${WRKDIR}/astyle/build/gcc
pre-patch:
- @${REINPLACE_CMD} -e 's,^CFLAGS,#CFLAGS,; s,g++,${CXX},;' ${WRKSRC}/Makefile
-
-.include <bsd.port.options.mk>
+ @${REINPLACE_CMD} -e 's,^CFLAGS,#CFLAGS,; s,g++,${CXX},; \
+ s,\(CFLAGSr.*=.*\),\1 -I${LOCALBASE}/include,' \
+ ${WRKSRC}/Makefile
do-install:
+ ${STRIP_CMD} ${WRKSRC}/bin/astyle
${INSTALL_PROGRAM} ${WRKSRC}/bin/astyle ${STAGEDIR}${PREFIX}/bin
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKDIR}/astyle/doc/*.html ${STAGEDIR}${DOCSDIR}