aboutsummaryrefslogtreecommitdiff
path: root/devel/aunit/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-01-12 21:57:49 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-01-12 21:57:49 +0000
commitf9506cb4a699a0a50572fbaf53a63afaab3ba9bb (patch)
tree5f1b2001042377eb291bc1fe1b99bb0752960a9e /devel/aunit/Makefile
parentaa6f23e8f9415d921e2c39f3207f881d5dc91310 (diff)
downloadports-f9506cb4a699a0a50572fbaf53a63afaab3ba9bb.tar.gz
ports-f9506cb4a699a0a50572fbaf53a63afaab3ba9bb.zip
Notes
Diffstat (limited to 'devel/aunit/Makefile')
-rw-r--r--devel/aunit/Makefile70
1 files changed, 40 insertions, 30 deletions
diff --git a/devel/aunit/Makefile b/devel/aunit/Makefile
index cc90db7b9086..69d0dc1fb2fb 100644
--- a/devel/aunit/Makefile
+++ b/devel/aunit/Makefile
@@ -1,38 +1,48 @@
-# New ports collection makefile for: AUnit
-# Date created: 20 Jan 2002
-# Whom: Aidan Skinner <aidan@velvet.net>
+# New ports collection makefile for: aunit
+# Date created: 31 Dec 2006
+# Whom: John Merryweather Cooper
#
-# $FreeBSD$
+# $FreeBSD$
#
PORTNAME= aunit
-PORTVERSION= 1.03
-PORTREVISION= 1
+PORTVERSION= 1.05
CATEGORIES= devel
-MASTER_SITES= https://libre2.adacore.com/aunit/
-DISTNAME= ${PORTNAME}-${PORTVERSION}p-src
-EXTRACT_SUFX= .tgz
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= A unit testing framework for the Ada '95 programming language
-
-NO_BUILD= yes
-WRKSRC= ${WRKDIR}/AUnit
-
-pre-install:
- @${FIND} ${WRKSRC} -type d -name CVS -print0 | ${XARGS} -0 ${RM} -rf
-
-do-install:
- @${MKDIR} ${PREFIX}/include/aunit
- ${INSTALL_DATA} ${WRKSRC}/aunit/framework/* ${PREFIX}/include/aunit
- ${INSTALL_DATA} ${WRKSRC}/aunit/text_reporter/* ${PREFIX}/include/aunit
- @${MKDIR} ${DATADIR}/template ${DATADIR}/test
- ${INSTALL_DATA} ${WRKSRC}/template/* ${DATADIR}/template
- ${INSTALL_DATA} ${WRKSRC}/test/* ${DATADIR}/test
- ${INSTALL_DATA} ${WRKSRC}/*.gpr ${DATADIR}
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/AUnit.html ${WRKSRC}/README ${DOCSDIR}
+MASTER_SITES= http://libre.adacore.com/
+EXTRACT_SUFX= -src.tgz
+
+MAINTAINER= john_m_cooper@yahoo.com
+COMMENT= AUnit is an adaption of the Java JUnit unit test framework
+
+BUILD_DEPENDS= gnatmake:${PORTSDIR}/lang/gnat
+RUN_DEPENDS= gnatgcc:${PORTSDIR}/lang/gnat
+
+USE_GMAKE= yes
+
+# Check for GNAT sources.
+.if !exists(${DISTDIR}/${DISTFILE}) && !defined(PACKAGE_BUILDING)
+ECHO_MSG= ${PRINTF}
+IGNORE=Because of licensing and registration restrictions, you must fetch\n \
+ the source distribution manually. Please access\n \
+ http://libre.adacore.com/\ with a web browser, register\n \
+ (It's free!) and log in. Download the source files:\n\n \
+ \t${DISTFILE}\n\n \
+ and place them in ${DISTDIR}\n
+ ${ECHO_MSG} ${IGNORE}
.endif
+WRKSRC= ${WRKDIR}/aunit-${PORTVERSION}-src
+
+pre-build:
+ @${MV} ${WRKSRC}/makefile ${WRKSRC}/Makefile
+
+# install-info is being called directly because aunit.info does not have an
+# entry field
+post-install:
+ @install-info --entry "AUnit" ${DOCSDIR}/aunit.info \
+ ${DOCSDIR}/dir
+
+test:
+ @${CD} ${WRKSRC} && ${GMAKE} test
+
.include <bsd.port.mk>