aboutsummaryrefslogtreecommitdiff
path: root/devel/aunit
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2007-10-24 08:29:00 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2007-10-24 08:29:00 +0000
commit8e8b0b5448ebe237c1d411e99dc2edc24cdcd060 (patch)
tree41abf3354b30403b24fcfad63a5846561e83e476 /devel/aunit
parentb0ea3c0f4f5fd78a9de39d7d2a2c4e1adbf1e50c (diff)
downloadports-8e8b0b5448ebe237c1d411e99dc2edc24cdcd060.tar.gz
ports-8e8b0b5448ebe237c1d411e99dc2edc24cdcd060.zip
Notes
Diffstat (limited to 'devel/aunit')
-rw-r--r--devel/aunit/Makefile25
1 files changed, 13 insertions, 12 deletions
diff --git a/devel/aunit/Makefile b/devel/aunit/Makefile
index da7b1536a5a2..87f655cad64c 100644
--- a/devel/aunit/Makefile
+++ b/devel/aunit/Makefile
@@ -9,7 +9,7 @@ PORTNAME= aunit
PORTVERSION= 1.05
CATEGORIES= devel
MASTER_SITES= http://libre.adacore.com/
-EXTRACT_SUFX= -src.tgz
+DISTFILES= ${PORTNAME}-${PORTVERSION}-src.tgz
MAINTAINER= john_m_cooper@yahoo.com
COMMENT= AUnit is an adaption of the Java JUnit unit test framework
@@ -18,23 +18,24 @@ BUILD_DEPENDS= gnatmake:${PORTSDIR}/lang/gnat
RUN_DEPENDS= gnatgcc:${PORTSDIR}/lang/gnat
USE_GMAKE= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-src
.include <bsd.port.pre.mk>
# Check for GNAT sources.
-.if !exists(${DISTDIR}/${DISTFILE}) && !defined(PACKAGE_BUILDING)
-ECHO_MSG= ${PRINTF}
-IGNORE=Because of licensing and registration restrictions, you must fetch\n \
- the source distribution manually. Please access\n \
- http://libre.adacore.com/\ with a web browser, register\n \
- (It's free!) and log in. Download the source files:\n\n \
- \t${DISTFILE}\n\n \
- and place them in ${DISTDIR}\n
- ${ECHO_MSG} ${IGNORE}
+.if !exists(${DISTDIR}/${DISTFILES}) && !defined(PACKAGE_BUILDING)
+pre-everything::
+ @echo "Because of licensing and registration restrictions, you must"
+ @echo "fetch the source distribution manually. Please access"
+ @echo "http://libre.adacore.com/ with a web browser, register"
+ @echo "(It's free!) and log in. Download the source files:"
+ @echo
+ @echo " ${DISTFILES}"
+ @echo
+ @echo "and place them in ${DISTDIR}"
+ @exit 1
.endif
-WRKSRC= ${WRKDIR}/aunit-${PORTVERSION}-src
-
pre-build:
@${MV} ${WRKSRC}/makefile ${WRKSRC}/Makefile