aboutsummaryrefslogtreecommitdiff
path: root/devel/aunit
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-09-17 08:25:21 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-09-17 08:25:21 +0000
commit9ab4d9592289af6e458d4c4624c7e5d9397ff408 (patch)
tree43f81fd1a1df0cf25f9fff4e66613b18bbf37edc /devel/aunit
parent20f86fef09fc39f8adf55198595f6a04bb379862 (diff)
downloadports-9ab4d9592289af6e458d4c4624c7e5d9397ff408.tar.gz
ports-9ab4d9592289af6e458d4c4624c7e5d9397ff408.zip
Notes
Diffstat (limited to 'devel/aunit')
-rw-r--r--devel/aunit/Makefile28
-rw-r--r--devel/aunit/distinfo1
-rw-r--r--devel/aunit/pkg-comment1
-rw-r--r--devel/aunit/pkg-descr13
-rw-r--r--devel/aunit/pkg-plist23
5 files changed, 66 insertions, 0 deletions
diff --git a/devel/aunit/Makefile b/devel/aunit/Makefile
new file mode 100644
index 000000000000..2ce0b864b63d
--- /dev/null
+++ b/devel/aunit/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: aunit
+# Date created: 20 Jan 2002
+# Whom: Aidan Skinner <aidan@velvet.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= aunit
+PORTVERSION= 1.01
+CATEGORIES= devel
+MASTER_SITES= http://libre.act-europe.fr/aunit/
+
+MAINTAINER= aidan@velvet.net
+
+NO_BUILD= yes
+
+do-install:
+ @${MKDIR} ${PREFIX}/include/aunit
+ ${INSTALL_DATA} ${WRKSRC}/aunit/framework/* ${PREFIX}/include/aunit
+ ${INSTALL_DATA} ${WRKSRC}/aunit/text_reporter/* ${PREFIX}/include/aunit
+
+.if !defined(NOPORTDOCS)
+post-install:
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/AUnit.html ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/aunit/distinfo b/devel/aunit/distinfo
new file mode 100644
index 000000000000..92fde4d100b0
--- /dev/null
+++ b/devel/aunit/distinfo
@@ -0,0 +1 @@
+MD5 (aunit-1.01.tar.gz) = 2ee22dd2862eae1c23205df33f4ee4ff
diff --git a/devel/aunit/pkg-comment b/devel/aunit/pkg-comment
new file mode 100644
index 000000000000..43c3e128fd5b
--- /dev/null
+++ b/devel/aunit/pkg-comment
@@ -0,0 +1 @@
+A unit testing framework for the Ada '95 programming language
diff --git a/devel/aunit/pkg-descr b/devel/aunit/pkg-descr
new file mode 100644
index 000000000000..0830a96cc2be
--- /dev/null
+++ b/devel/aunit/pkg-descr
@@ -0,0 +1,13 @@
+AUnit is a set of Ada packages based on the xUnit family of unit test
+frameworks. It's intended as a developer's tool to facilitate
+confident writing and evolution of Ada software. It is purposely
+lightweight, as one of its main goals is to make it easy to develop
+and run unit tests, rather than to generate artifacts for process
+management. The framework supports easy composition of sets of unit
+tests to provide flexibility in determining what tests to run for a
+given purpose.
+
+WWW: http://libre.act-europe.fr/aunit/
+
+- Aidan
+aidan@velvet.net
diff --git a/devel/aunit/pkg-plist b/devel/aunit/pkg-plist
new file mode 100644
index 000000000000..4af0ff0b95f6
--- /dev/null
+++ b/devel/aunit/pkg-plist
@@ -0,0 +1,23 @@
+include/aunit/aunit-assertions.adb
+include/aunit/aunit-assertions.ads
+include/aunit/aunit-lists.adb
+include/aunit/aunit-lists.ads
+include/aunit/aunit-options.adb
+include/aunit/aunit-options.ads
+include/aunit/aunit-test_cases-registration.adb
+include/aunit/aunit-test_cases-registration.ads
+include/aunit/aunit-test_cases.adb
+include/aunit/aunit-test_cases.ads
+include/aunit/aunit-test_results-text_reporter.adb
+include/aunit/aunit-test_results-text_reporter.ads
+include/aunit/aunit-test_results.adb
+include/aunit/aunit-test_results.ads
+include/aunit/aunit-test_runner.adb
+include/aunit/aunit-test_runner.ads
+include/aunit/aunit-test_suites.adb
+include/aunit/aunit-test_suites.ads
+include/aunit/aunit-tests.ads
+include/aunit/aunit.ads
+@dirrm include/aunit
+%%PORTDOCS%%share/doc/aunit/AUnit.html
+%%PORTDOCS%%@dirrm share/doc/aunit