aboutsummaryrefslogtreecommitdiff
path: root/devel/autoconf/Makefile
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2004-08-03 22:36:52 +0000
committerAde Lovett <ade@FreeBSD.org>2004-08-03 22:36:52 +0000
commite32a8245791aab6e734fe5ecda71641e15c94b45 (patch)
tree4daccf3b91f25a920b92ab009f8f336fb635fb30 /devel/autoconf/Makefile
parent99fb36c32d824e3fb95f9b66463538631d38cdc8 (diff)
downloadports-e32a8245791aab6e734fe5ecda71641e15c94b45.tar.gz
ports-e32a8245791aab6e734fe5ecda71641e15c94b45.zip
Notes
Diffstat (limited to 'devel/autoconf/Makefile')
-rw-r--r--devel/autoconf/Makefile55
1 files changed, 0 insertions, 55 deletions
diff --git a/devel/autoconf/Makefile b/devel/autoconf/Makefile
deleted file mode 100644
index bbcfaaf0760d..000000000000
--- a/devel/autoconf/Makefile
+++ /dev/null
@@ -1,55 +0,0 @@
-# New ports collection makefile for: autoconf
-# Date created: 7 October 1995
-# Whom: torstenb@FreeBSD.org
-#
-# $FreeBSD$
-#
-
-PORTNAME= autoconf
-PORTVERSION= 2.53
-PORTREVISION= 1
-CATEGORIES= devel
-MASTER_SITES= ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= ade/gnu
-
-MAINTAINER= ade@FreeBSD.org
-COMMENT= Automatically configure source code on many Un*x platforms
-
-DEPRECATED= Please use devel/autoconf259 instead
-EXPIRATION_DATE=31st December 2004
-
-BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
- help2man:${PORTSDIR}/misc/help2man
-RUN_DEPENDS= gm4:${PORTSDIR}/devel/m4
-
-LATEST_LINK= autoconf
-USE_BZIP2= yes
-USE_PERL5_RUN= yes
-
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= CONFIG_SHELL=${SH} M4=${LOCALBASE}/bin/gm4
-CONFIGURE_ARGS= --without-lispdir
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-
-GENERIC_TOOLS= config.guess config.sub elisp-comp install-sh mdate-sh \
- missing mkinstalldirs
-
-MAN1= autoconf.1 autoheader.1 autom4te.1 autoreconf.1 autoscan.1 \
- autoupdate.1 config.guess.1 config.sub.1 ifnames.1
-
-.if defined(USE_AUTOCONF) || defined(USE_AUTOCONF_VER)
-pre-everything::
- @${ECHO} ===========================================================
- @${ECHO} "You have 'USE_AUTOCONF' or 'USE_AUTOCONF_VER' variables"
- @${ECHO} "defined either in environment or in make(1) arguments."
- @${ECHO} "Please undefine them and try again."
- @${ECHO} ===========================================================
- @${FALSE}
-.endif # defined(USE_AUTOCONF) || defined(USE_AUTOCONF_VER)
-
-post-install:
-.for FILE in ${GENERIC_TOOLS}
- ${INSTALL_SCRIPT} ${WRKSRC}/config/${FILE} ${PREFIX}/share/autoconf
-.endfor
-
-.include <bsd.port.mk>