aboutsummaryrefslogtreecommitdiff
path: root/devel/autoconf/Makefile
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2010-12-08 19:58:49 +0000
committerAde Lovett <ade@FreeBSD.org>2010-12-08 19:58:49 +0000
commitf584da22ee03bf55f4db7ffa79c61aa8ad827ad6 (patch)
treef7da82208d8de3376467178192bb0f8181f73280 /devel/autoconf/Makefile
parentdeb6a6b36bfd8259bc9c372e4698cb7c7a8233ce (diff)
downloadports-f584da22ee03bf55f4db7ffa79c61aa8ad827ad6.tar.gz
ports-f584da22ee03bf55f4db7ffa79c61aa8ad827ad6.zip
Notes
Diffstat (limited to 'devel/autoconf/Makefile')
-rw-r--r--devel/autoconf/Makefile59
1 files changed, 59 insertions, 0 deletions
diff --git a/devel/autoconf/Makefile b/devel/autoconf/Makefile
new file mode 100644
index 000000000000..b4fdab409601
--- /dev/null
+++ b/devel/autoconf/Makefile
@@ -0,0 +1,59 @@
+# New ports collection makefile for: autoconf
+# Date created: 7th December 2006
+# Whom: ade@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= autoconf
+PORTVERSION= 2.68
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_GNU}
+MASTER_SITE_SUBDIR= autoconf
+DISTNAME= autoconf-${PORTVERSION}
+
+MAINTAINER= autotools@FreeBSD.org
+COMMENT= Automatically configure source code on many Un*x platforms (2.68)
+
+BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
+ help2man:${PORTSDIR}/misc/help2man
+RUN_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
+ autoconf-wrapper:${PORTSDIR}/devel/autoconf-wrapper
+
+BUILD_VERSION= 2.68
+PLIST_SUB= BUILD_VERSION=${BUILD_VERSION}
+LATEST_LINK= autoconf268
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_PERL5= yes
+INFO= autoconf-${BUILD_VERSION}
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV+= CONFIG_SHELL=${SH} M4=${LOCALBASE}/bin/gm4 AWK=${AWK}
+CONFIGURE_ARGS= --program-suffix=-${BUILD_VERSION} --without-lispdir
+
+GENERIC_TOOLS= config.guess config.sub elisp-comp install-sh mdate-sh missing
+GENERIC_LINKS= autoconf autoheader autom4te autoreconf autoscan autoupdate \
+ ifnames
+
+MAN1_PAGES= ${GENERIC_LINKS} config.guess config.sub
+MAN1= ${MAN1_PAGES:S/$/-${BUILD_VERSION}.1/g}
+
+post-patch:
+ @(cd ${WRKSRC}/man && \
+ for file in *.[1x]; do \
+ ${REINPLACE_CMD} -E 's,([^-]auto)(conf|make|reconf|update|header|scan),\1\2-${BUILD_VERSION},g ; \
+ s,(config\.guess|config\.sub|ifnames),\1-${BUILD_VERSION},g' $$file ; \
+ done)
+ @(cd ${WRKSRC}/doc && \
+ ${RM} -f *.info && \
+ ${MV} autoconf.texi autoconf-${BUILD_VERSION}.texi)
+ @${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|@PACKAGE@$$|@PACKAGE@-@VERSION@|'
+
+post-install:
+.for FILE in ${GENERIC_TOOLS}
+ @${INSTALL_SCRIPT} ${WRKSRC}/build-aux/${FILE} ${PREFIX}/share/autoconf-${BUILD_VERSION}
+.endfor
+
+.include <bsd.port.mk>