aboutsummaryrefslogtreecommitdiff
path: root/devel/autogen
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-03-13 05:52:31 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-03-13 05:52:31 +0000
commitb88cdb3738fb272e88b0357efdb312d0826089d3 (patch)
tree3ff5dbc8366f6c3c27a944513f47c411f0dc7265 /devel/autogen
parent90a7b13a966c3c2ecb63bca5474e7e8c8e259d23 (diff)
downloadports-b88cdb3738fb272e88b0357efdb312d0826089d3.tar.gz
ports-b88cdb3738fb272e88b0357efdb312d0826089d3.zip
Notes
Diffstat (limited to 'devel/autogen')
-rw-r--r--devel/autogen/Makefile32
-rw-r--r--devel/autogen/distinfo1
-rw-r--r--devel/autogen/files/patch-agen5::Makefile.in11
-rw-r--r--devel/autogen/files/patch-autoopts::Makefile.in11
-rw-r--r--devel/autogen/files/patch-snprintfv::Makefile.in11
-rw-r--r--devel/autogen/files/patch-snprintfv::snprintfv::Makefile.in11
-rw-r--r--devel/autogen/pkg-comment1
-rw-r--r--devel/autogen/pkg-descr17
-rw-r--r--devel/autogen/pkg-plist30
9 files changed, 125 insertions, 0 deletions
diff --git a/devel/autogen/Makefile b/devel/autogen/Makefile
new file mode 100644
index 000000000000..26b388e891e9
--- /dev/null
+++ b/devel/autogen/Makefile
@@ -0,0 +1,32 @@
+# ex:ts=8
+# New ports collection makefile for: autogen
+# Date created: Mar 11, 2001
+# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= autogen
+PORTVERSION= 5.1.3
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ijliao@FreeBSD.org
+
+BUILD_DEPENDS= guile:${PORTSDIR}/lang/guile
+LIB_DEPENDS= guile.9:${PORTSDIR}/lang/guile
+
+USE_LIBTOOL= yes
+GNU_CONFIGURE= yes
+
+USE_GMAKE= yes
+
+INSTALLS_SHLIB= yes
+
+MAN1= autogen.1 columns.1 getdefs.1
+
+post-install:
+ @${RM} ${PREFIX}/lib/libsnprintfv.la
+
+.include <bsd.port.mk>
diff --git a/devel/autogen/distinfo b/devel/autogen/distinfo
new file mode 100644
index 000000000000..78a469088628
--- /dev/null
+++ b/devel/autogen/distinfo
@@ -0,0 +1 @@
+MD5 (autogen-5.1.3.tar.gz) = 310a687162d558137688579cd4f90b7d
diff --git a/devel/autogen/files/patch-agen5::Makefile.in b/devel/autogen/files/patch-agen5::Makefile.in
new file mode 100644
index 000000000000..9398f8773dc8
--- /dev/null
+++ b/devel/autogen/files/patch-agen5::Makefile.in
@@ -0,0 +1,11 @@
+--- agen5/Makefile.in.orig Mon Mar 12 00:04:41 2001
++++ agen5/Makefile.in Mon Mar 12 00:04:58 2001
+@@ -97,7 +97,7 @@
+ ac_aux_dir = @ac_aux_dir@
+
+ SUBDIRS = test
+-INCLUDES = -I$(top_builddir)/autoopts -I$(top_srcdir)/autoopts -I$(top_builddir)/snprintfv -I$(top_srcdir)/snprintfv -I$(top_builddir) -I$(top_srcdir) -I. -I$(srcdir)
++INCLUDES = -I$(top_builddir)/autoopts -I$(top_srcdir)/autoopts -I$(top_builddir)/snprintfv -I$(top_srcdir)/snprintfv -I$(top_builddir) -I$(top_srcdir) -I. -I$(srcdir) `guile-config compile`
+
+
+ BLOCKOPT = subblock=exparg=arg_name,arg_desc,arg_optional,arg_list
diff --git a/devel/autogen/files/patch-autoopts::Makefile.in b/devel/autogen/files/patch-autoopts::Makefile.in
new file mode 100644
index 000000000000..8e920b487131
--- /dev/null
+++ b/devel/autogen/files/patch-autoopts::Makefile.in
@@ -0,0 +1,11 @@
+--- autoopts/Makefile.in.orig Mon Mar 12 00:03:38 2001
++++ autoopts/Makefile.in Mon Mar 12 00:04:02 2001
+@@ -101,7 +101,7 @@
+
+ MAINTAINERCLEANFILES = Makefile.in
+
+-INCLUDES = -I$(top_srcdir)/snprintfv -I$(top_srcdir) -I$(top_builddir)/snprintfv -I$(top_builddir) -I.
++INCLUDES = -I$(top_srcdir)/snprintfv -I$(top_srcdir) -I$(top_builddir)/snprintfv -I$(top_builddir) -I. `guile-config compile`
+
+
+ pkgdata_DATA = aginfo.tpl agman1.tpl optcode.tpl opthead.tpl options.tpl optlib.tpl optmain.tpl stdoptions.def
diff --git a/devel/autogen/files/patch-snprintfv::Makefile.in b/devel/autogen/files/patch-snprintfv::Makefile.in
new file mode 100644
index 000000000000..c0e083c35f90
--- /dev/null
+++ b/devel/autogen/files/patch-snprintfv::Makefile.in
@@ -0,0 +1,11 @@
+--- snprintfv/Makefile.in.orig Mon Mar 12 01:30:19 2001
++++ snprintfv/Makefile.in Mon Mar 12 01:31:11 2001
+@@ -43,7 +43,7 @@
+ AUTOMAKE = @AUTOMAKE@
+ AUTOHEADER = @AUTOHEADER@
+
+-INSTALL = @INSTALL@
++INSTALL = /usr/bin/install -c -o root -g wheel
+ INSTALL_PROGRAM = @INSTALL_PROGRAM@ $(AM_INSTALL_PROGRAM_FLAGS)
+ INSTALL_DATA = @INSTALL_DATA@
+ INSTALL_SCRIPT = @INSTALL_SCRIPT@
diff --git a/devel/autogen/files/patch-snprintfv::snprintfv::Makefile.in b/devel/autogen/files/patch-snprintfv::snprintfv::Makefile.in
new file mode 100644
index 000000000000..c9fc714338a8
--- /dev/null
+++ b/devel/autogen/files/patch-snprintfv::snprintfv::Makefile.in
@@ -0,0 +1,11 @@
+--- snprintfv/snprintfv/Makefile.in.orig Mon Mar 12 01:31:49 2001
++++ snprintfv/snprintfv/Makefile.in Mon Mar 12 01:31:59 2001
+@@ -43,7 +43,7 @@
+ AUTOMAKE = @AUTOMAKE@
+ AUTOHEADER = @AUTOHEADER@
+
+-INSTALL = @INSTALL@
++INSTALL = /usr/bin/install -c -o root -g wheel
+ INSTALL_PROGRAM = @INSTALL_PROGRAM@ $(AM_INSTALL_PROGRAM_FLAGS)
+ INSTALL_DATA = @INSTALL_DATA@
+ INSTALL_SCRIPT = @INSTALL_SCRIPT@
diff --git a/devel/autogen/pkg-comment b/devel/autogen/pkg-comment
new file mode 100644
index 000000000000..6ef4ebb22d18
--- /dev/null
+++ b/devel/autogen/pkg-comment
@@ -0,0 +1 @@
+Generate files that contain repetitive text with varied substitutions
diff --git a/devel/autogen/pkg-descr b/devel/autogen/pkg-descr
new file mode 100644
index 000000000000..14184f0d286c
--- /dev/null
+++ b/devel/autogen/pkg-descr
@@ -0,0 +1,17 @@
+AutoGen is a tool designed for generating program files that contain
+repetitive text with varied substitutions. Its goal is to simplify the
+maintenance of programs that contain large amounts of repetitious text.
+This is especially valuable if there are several blocks of such text that
+must be kept synchronized.
+
+One common example is the problem of maintaining the code required for
+processing program options. Processing options requires a minimum of four
+different constructs be kept in proper order in different places in your
+program. You need at least:
+
+ 1. The flag character in the flag string,
+ 2. code to process the flag when it is encountered,
+ 3. a global state variable or two, and
+ 4. a line in the usage text.
+
+WWW: http://autogen.sourceforge.net/
diff --git a/devel/autogen/pkg-plist b/devel/autogen/pkg-plist
new file mode 100644
index 000000000000..26c6eb9a2966
--- /dev/null
+++ b/devel/autogen/pkg-plist
@@ -0,0 +1,30 @@
+bin/autogen
+bin/autoopts-config
+bin/columns
+bin/getdefs
+include/options.h
+@unexec install-info --delete %D/info/autogen.info %D/info/dir
+@unexec install-info --delete %D/info/snprintfv.info %D/info/dir
+info/autogen.info
+info/snprintfv.info
+@exec install-info %D/info/autogen.info %D/info/dir
+@exec install-info %D/info/snprintfv.info %D/info/dir
+lib/libguileopts.a
+lib/libguileopts.so
+lib/libguileopts.so.0
+lib/libopts.a
+lib/libopts.so
+lib/libopts.so.9
+lib/libsnprintfv.a
+share/aclocal/autoopts.m4
+share/autogen/aginfo.tpl
+share/autogen/agman1.tpl
+share/autogen/fsm.tpl
+share/autogen/optcode.tpl
+share/autogen/opthead.tpl
+share/autogen/options.tpl
+share/autogen/optlib.tpl
+share/autogen/optmain.tpl
+share/autogen/schemedef.scm
+share/autogen/stdoptions.def
+@dirrm share/autogen