aboutsummaryrefslogtreecommitdiff
path: root/devel/automake/Makefile
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2010-12-08 19:58:49 +0000
committerAde Lovett <ade@FreeBSD.org>2010-12-08 19:58:49 +0000
commitf584da22ee03bf55f4db7ffa79c61aa8ad827ad6 (patch)
treef7da82208d8de3376467178192bb0f8181f73280 /devel/automake/Makefile
parentdeb6a6b36bfd8259bc9c372e4698cb7c7a8233ce (diff)
downloadports-f584da22ee03bf55f4db7ffa79c61aa8ad827ad6.tar.gz
ports-f584da22ee03bf55f4db7ffa79c61aa8ad827ad6.zip
Notes
Diffstat (limited to 'devel/automake/Makefile')
-rw-r--r--devel/automake/Makefile46
1 files changed, 46 insertions, 0 deletions
diff --git a/devel/automake/Makefile b/devel/automake/Makefile
new file mode 100644
index 000000000000..3eaff14b70e2
--- /dev/null
+++ b/devel/automake/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: automake
+# Date created: 5th December 2006
+# Whom: Ade Lovett <ade@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= automake
+PORTVERSION= 1.11.1
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_GNU}
+MASTER_SITE_SUBDIR= automake
+DISTNAME= automake-${PORTVERSION}
+
+MAINTAINER= autotools@FreeBSD.org
+COMMENT= GNU Standards-compliant Makefile generator (1.11)
+
+RUN_DEPENDS= ${AUTOCONF_DEPENDS} \
+ automake-wrapper:${PORTSDIR}/devel/automake-wrapper
+
+USE_AUTOTOOLS= autoconf:env
+BUILD_VERSION= 1.11
+PLIST_SUB= BUILD_VERSION=${BUILD_VERSION}
+LATEST_LINK= automake111
+USE_BZIP2= yes
+USE_PERL5= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --program-suffix=-${BUILD_VERSION}
+CONFIGURE_ENV+= MAKEINFO="makeinfo --no-split"
+INFO= automake-${BUILD_VERSION}
+MAN1= aclocal-${BUILD_VERSION}-${BUILD_VERSION}.1 \
+ aclocal-${BUILD_VERSION}.1 \
+ automake-${BUILD_VERSION}-${BUILD_VERSION}.1 \
+ automake-${BUILD_VERSION}.1
+
+post-patch:
+ @${RM} ${WRKSRC}/doc/*.info
+ @${MV} ${WRKSRC}/doc/automake.texi \
+ ${WRKSRC}/doc/automake-${BUILD_VERSION}.texi
+
+pre-su-install:
+ @${RM} -fr ${PREFIX}/share/automake-${BUILD_VERSION}
+ @${MKDIR} ${PREFIX}/share/automake-${BUILD_VERSION}
+ @${MKDIR} ${PREFIX}/share/aclocal-${BUILD_VERSION}
+
+.include <bsd.port.mk>