aboutsummaryrefslogtreecommitdiff
path: root/devel/avr-binutils
diff options
context:
space:
mode:
authorJoerg Wunsch <joerg@FreeBSD.org>2007-01-04 16:12:12 +0000
committerJoerg Wunsch <joerg@FreeBSD.org>2007-01-04 16:12:12 +0000
commit3d183e1bc1c08382479bf1c0379bc504aa96e6f5 (patch)
tree8ef6923276dcf4545239f094adda3f6f0527a00e /devel/avr-binutils
parenteecc6991763d71efbd0b4a07d0d5afed0579d569 (diff)
Fix a compiler warning in the AVR-COFF generator that appeared with
GCC 4.x, and caused the compilation to fail due to the -Werror option used. Remove an annoying assembler warning in the ATmega256x patch that was frequently triggered by large C switch() statements in GCC, and generally considered to be a regression. The author of that patch agreed that the warning isn't particularly useful anyway for a number of reasons, and recommended to just drop it.
Notes
Notes: svn path=/head/; revision=181423
Diffstat (limited to 'devel/avr-binutils')
-rw-r--r--devel/avr-binutils/Makefile2
-rw-r--r--devel/avr-binutils/files/patch-atmega256x2
-rw-r--r--devel/avr-binutils/files/patch-coff-avr2
3 files changed, 3 insertions, 3 deletions
diff --git a/devel/avr-binutils/Makefile b/devel/avr-binutils/Makefile
index ea83be6985a3..150a2b393372 100644
--- a/devel/avr-binutils/Makefile
+++ b/devel/avr-binutils/Makefile
@@ -7,7 +7,7 @@
PORTNAME= binutils
PORTVERSION= 2.17
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEWARE}
MASTER_SITE_SUBDIR= binutils/releases
diff --git a/devel/avr-binutils/files/patch-atmega256x b/devel/avr-binutils/files/patch-atmega256x
index 5911f2abd24d..ddc6e19c82c3 100644
--- a/devel/avr-binutils/files/patch-atmega256x
+++ b/devel/avr-binutils/files/patch-atmega256x
@@ -1738,7 +1738,7 @@ diff -Nur gas/config/tc-avr.c gas/config/tc-avr.c
+ break;
+
+ default:
-+ as_warn (_("expression dangerous with linker stubs"));
++ break; /* as_warn (_("expression dangerous with linker stubs")); *//* Bjoern agreed. :) */
+ }
+ }
+ return reloc_to_return;
diff --git a/devel/avr-binutils/files/patch-coff-avr b/devel/avr-binutils/files/patch-coff-avr
index 3009a8acd593..dc7759f917f1 100644
--- a/devel/avr-binutils/files/patch-coff-avr
+++ b/devel/avr-binutils/files/patch-coff-avr
@@ -2811,7 +2811,7 @@
+ shash->emitted = FALSE;
+ }
+ else
-+ coff_struct_hash_lookup (&info->structs, name,
++ (void)coff_struct_hash_lookup (&info->structs, name,
+ TRUE, tst->u.ts_struct.tagismalloced);
+
+ return TRUE;