aboutsummaryrefslogtreecommitdiff
path: root/devel/avr-gcc-3
diff options
context:
space:
mode:
authorJoerg Wunsch <joerg@FreeBSD.org>2005-09-12 22:03:43 +0000
committerJoerg Wunsch <joerg@FreeBSD.org>2005-09-12 22:03:43 +0000
commit6e31127d601248e9f7c68ab72de2eb65f938ee7b (patch)
tree776dba2e262a49e3b6a7a47ac3655cf962402feb /devel/avr-gcc-3
parent188adc5323553a1369f598603bf8a07fce4e8f5b (diff)
downloadports-6e31127d601248e9f7c68ab72de2eb65f938ee7b.tar.gz
ports-6e31127d601248e9f7c68ab72de2eb65f938ee7b.zip
Notes
Diffstat (limited to 'devel/avr-gcc-3')
-rw-r--r--devel/avr-gcc-3/Makefile2
-rw-r--r--devel/avr-gcc-3/files/patch-newdevices31
-rw-r--r--devel/avr-gcc-3/pkg-descr10
3 files changed, 25 insertions, 18 deletions
diff --git a/devel/avr-gcc-3/Makefile b/devel/avr-gcc-3/Makefile
index 4b8db5f09c61..8d890d71abfc 100644
--- a/devel/avr-gcc-3/Makefile
+++ b/devel/avr-gcc-3/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gcc
PORTVERSION= 3.4.4
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GCC}
MASTER_SITES+= http://people.freebsd.org/~joerg/:local
diff --git a/devel/avr-gcc-3/files/patch-newdevices b/devel/avr-gcc-3/files/patch-newdevices
index d158204075f8..32388d8b8d85 100644
--- a/devel/avr-gcc-3/files/patch-newdevices
+++ b/devel/avr-gcc-3/files/patch-newdevices
@@ -1,6 +1,6 @@
diff -ur ../gcc-3.4.4.orig/gcc/config/avr/avr.c ./gcc/config/avr/avr.c
--- ../gcc-3.4.4.orig/gcc/config/avr/avr.c Sun Mar 20 22:14:28 2005
-+++ ./gcc/config/avr/avr.c Thu Sep 1 07:02:53 2005
++++ ./gcc/config/avr/avr.c Mon Sep 12 22:54:25 2005
@@ -175,6 +175,12 @@
{ "at90c8534", 2, "__AVR_AT90C8534__" },
{ "at90s8535", 2, "__AVR_AT90S8535__" },
@@ -14,7 +14,7 @@ diff -ur ../gcc-3.4.4.orig/gcc/config/avr/avr.c ./gcc/config/avr/avr.c
/* Classic, > 8K. */
{ "avr3", 3, NULL },
{ "atmega103", 3, "__AVR_ATmega103__" },
-@@ -185,19 +191,37 @@
+@@ -185,19 +191,40 @@
/* Enhanced, <= 8K. */
{ "avr4", 4, NULL },
{ "atmega8", 4, "__AVR_ATmega8__" },
@@ -41,6 +41,7 @@ diff -ur ../gcc-3.4.4.orig/gcc/config/avr/avr.c ./gcc/config/avr/avr.c
+ { "atmega3250", 5, "__AVR_ATmega3250__" },
+ { "atmega329", 5, "__AVR_ATmega329__" },
+ { "atmega3290", 5, "__AVR_ATmega3290__" },
++ { "atmega640", 5, "__AVR_ATmega640__" },
{ "atmega64", 5, "__AVR_ATmega64__" },
+ { "atmega644", 5, "__AVR_ATmega644__" },
+ { "atmega645", 5, "__AVR_ATmega645__" },
@@ -48,14 +49,16 @@ diff -ur ../gcc-3.4.4.orig/gcc/config/avr/avr.c ./gcc/config/avr/avr.c
+ { "atmega649", 5, "__AVR_ATmega649__" },
+ { "atmega6490", 5, "__AVR_ATmega6490__" },
{ "atmega128", 5, "__AVR_ATmega128__" },
++ { "atmega1280",5, "__AVR_ATmega1280__" },
++ { "atmega1281",5, "__AVR_ATmega1281__" },
+ { "at90can128", 5, "__AVR_AT90CAN128__" },
{ "at94k", 5, "__AVR_AT94K__" },
/* Assembler only. */
{ "avr1", 1, NULL },
diff -ur ../gcc-3.4.4.orig/gcc/config/avr/avr.h ./gcc/config/avr/avr.h
--- ../gcc-3.4.4.orig/gcc/config/avr/avr.h Tue Mar 9 03:59:55 2004
-+++ ./gcc/config/avr/avr.h Thu Sep 1 07:03:20 2005
-@@ -2351,12 +2351,12 @@
++++ ./gcc/config/avr/avr.h Mon Sep 12 22:59:20 2005
+@@ -2351,12 +2351,13 @@
Do not define this macro if it does not need to do anything. */
#define LINK_SPEC " %{!mmcu*:-m avr2}\
@@ -68,12 +71,13 @@ diff -ur ../gcc-3.4.4.orig/gcc/config/avr/avr.h ./gcc/config/avr/avr.h
-%{mmcu=atmega16*|mmcu=atmega32*|mmcu=atmega64|mmcu=atmega128|mmcu=at94k:-m avr5}\
-%{mmcu=atmega64|mmcu=atmega128|mmcu=atmega162|mmcu=atmega169: -Tdata 0x800100} "
+%{mmcu=atmega8*|mmcu=atmega48|mmcu=at90pwm*:-m avr4}\
-+%{mmcu=atmega16*|mmcu=atmega32*|mmcu=atmega64*|mmcu=atmega128|mmcu=at90can128|mmcu=at94k:-m avr5}\
-+%{mmcu=atmega324|mmcu=atmega325|mmcu=atmega3250|mmcu=atmega329|mmcu=atmega3290|mmcu=atmega48|mmcu=atmega88|mmcu=atmega64|mmcu=atmega644|mmcu=atmega645|mmcu=atmega6450|mmcu=atmega649|mmcu=atmega6490|mmcu=atmega128|mmcu=at90can128|mmcu=atmega162|mmcu=atmega164|mmcu=atmega165|mmcu=atmega168|mmcu=atmega169|mmcu=at90pwm*: -Tdata 0x800100} "
++%{mmcu=atmega16*|mmcu=atmega32*|mmcu=atmega64*|mmcu=atmega128*|mmcu=at90can128|mmcu=at94k:-m avr5}\
++%{mmcu=atmega324|mmcu=atmega325|mmcu=atmega3250|mmcu=atmega329|mmcu=atmega3290|mmcu=atmega48|mmcu=atmega88|mmcu=atmega64|mmcu=atmega644|mmcu=atmega645|mmcu=atmega6450|mmcu=atmega649|mmcu=atmega6490|mmcu=atmega128|mmcu=at90can128|mmcu=atmega162|mmcu=atmega164|mmcu=atmega165|mmcu=atmega168|mmcu=atmega169|mmcu=at90pwm*: -Tdata 0x800100}\
++%{mmcu=atmega640|mmcu=atmega1280|mmcu=atmega1281: -Tdata 0x800200} "
/* A C string constant that tells the GCC driver program options to
pass to the linker. It can also specify how to translate options
-@@ -2365,7 +2365,7 @@
+@@ -2365,7 +2366,7 @@
Do not define this macro if it does not need to do anything. */
#define LIB_SPEC \
@@ -82,7 +86,7 @@ diff -ur ../gcc-3.4.4.orig/gcc/config/avr/avr.h ./gcc/config/avr/avr.h
/* Another C string constant used much like `LINK_SPEC'. The
difference between the two is that `LIB_SPEC' is used at the end
of the command given to the linker.
-@@ -2377,7 +2377,7 @@
+@@ -2377,7 +2378,7 @@
/* No libstdc++ for now. Empty string doesn't work. */
#define LIBGCC_SPEC \
@@ -91,7 +95,7 @@ diff -ur ../gcc-3.4.4.orig/gcc/config/avr/avr.h ./gcc/config/avr/avr.h
/* Another C string constant that tells the GCC driver program how
and when to place a reference to `libgcc.a' into the linker
command line. This constant is placed both before and after the
-@@ -2421,23 +2421,46 @@
+@@ -2421,23 +2422,49 @@
%{mmcu=at90c8534:crtc8534.o%s} \
%{mmcu=at90s8535:crts8535.o%s} \
%{mmcu=at86rf401:crt86401.o%s} \
@@ -128,20 +132,23 @@ diff -ur ../gcc-3.4.4.orig/gcc/config/avr/avr.h ./gcc/config/avr/avr.h
+%{mmcu=atmega329:crtm329.o%s} \
+%{mmcu=atmega3290:crtm3290.o%s} \
%{mmcu=atmega64:crtm64.o%s} \
++%{mmcu=atmega640:crtm640.o%s} \
+%{mmcu=atmega644:crtm644.o%s} \
+%{mmcu=atmega645:crtm645.o%s} \
+%{mmcu=atmega6450:crtm6450.o%s} \
+%{mmcu=atmega649:crtm649.o%s} \
+%{mmcu=atmega6490:crtm6490.o%s} \
%{mmcu=atmega128:crtm128.o%s} \
++%{mmcu=atmega1280:crtm1280.o%s} \
++%{mmcu=atmega1281:crtm1281.o%s} \
+%{mmcu=at90can128:crtcan128.o%s} \
%{mmcu=at94k:crtat94k.o%s}"
#define EXTRA_SPECS {"crt_binutils", CRT_BINUTILS_SPECS},
diff -ur ../gcc-3.4.4.orig/gcc/config/avr/t-avr ./gcc/config/avr/t-avr
--- ../gcc-3.4.4.orig/gcc/config/avr/t-avr Mon Apr 25 06:17:34 2005
-+++ ./gcc/config/avr/t-avr Thu Sep 1 07:03:38 2005
-@@ -46,13 +46,23 @@
++++ ./gcc/config/avr/t-avr Mon Sep 12 23:00:12 2005
+@@ -46,13 +46,25 @@
mmcu?avr3=mmcu?at43usb320 mmcu?avr3=mmcu?at43usb355 \
mmcu?avr3=mmcu?at76c711 \
mmcu?avr4=mmcu?atmega8515 mmcu?avr4=mmcu?atmega8535 \
@@ -162,10 +169,12 @@ diff -ur ../gcc-3.4.4.orig/gcc/config/avr/t-avr ./gcc/config/avr/t-avr
+ mmcu?avr5=mmcu?atmega325 mmcu?avr5=mmcu?atmega3250 \
+ mmcu?avr5=mmcu?atmega329 mmcu?avr5=mmcu?atmega3290 \
+ mmcu?avr5=mmcu?atmega32 \
++ mmcu?avr5=mmcu?atmega640 \
+ mmcu?avr5=mmcu?atmega644 mmcu?avr5=mmcu?atmega645 \
+ mmcu?avr5=mmcu?atmega6450 mmcu?avr5=mmcu?atmega649 \
+ mmcu?avr5=mmcu?atmega6490 mmcu?avr5=mmcu?atmega64 \
+ mmcu?avr5=mmcu?atmega128 \
++ mmcu?avr5=mmcu?atmega1280 mmcu?avr5=mmcu?atmega1281 \
+ mmcu?avr5=mmcu?at94k mmcu?avr5=mmcu?at90can128
MULTILIB_EXCEPTIONS =
diff --git a/devel/avr-gcc-3/pkg-descr b/devel/avr-gcc-3/pkg-descr
index 5a9dce22f6ba..e9c7a58fd051 100644
--- a/devel/avr-gcc-3/pkg-descr
+++ b/devel/avr-gcc-3/pkg-descr
@@ -11,14 +11,12 @@ Locally hack added: recognizes 0bXXX binary constants
Locally added support for the following AVR devices:
- ATtiny13/ATtiny2313
- ATtiny25/ATtiny45/ATtiny85
- ATmega48/ATmega88/ATmega168
- AT90PWM2/AT90PWM3
- ATmega164/ATmega324/ATmega644
- ATmega165
+ ATtiny13/ATtiny2313 ATtiny25/ATtiny45/ATtiny85
+ ATmega48/ATmega88/ATmega168 AT90PWM2/AT90PWM3
+ ATmega164/ATmega324/ATmega644 ATmega165
ATmega325/ATmega3250/ATmega645/ATmega6450
ATmega329/ATmega3290/ATmega649/ATmega6490
+ ATmega640/ATmega1280/ATmega1281
AT90CAN128
WWW: http://gcc.gnu.org/