aboutsummaryrefslogtreecommitdiff
path: root/devel/avr-gcc
diff options
context:
space:
mode:
authorJoerg Wunsch <joerg@FreeBSD.org>2003-01-08 22:44:41 +0000
committerJoerg Wunsch <joerg@FreeBSD.org>2003-01-08 22:44:41 +0000
commit4310ca870e2e478c83384e513f8747cdc846e343 (patch)
tree617093b4cdab180706b517ff769ec86c2f70ce49 /devel/avr-gcc
parent14d85a7cb5b218fcca3010e8a0e81e5807864181 (diff)
downloadports-4310ca870e2e478c83384e513f8747cdc846e343.tar.gz
ports-4310ca870e2e478c83384e513f8747cdc846e343.zip
Notes
Diffstat (limited to 'devel/avr-gcc')
-rw-r--r--devel/avr-gcc/Makefile4
-rw-r--r--devel/avr-gcc/distinfo4
-rw-r--r--devel/avr-gcc/files/patch-ab43
-rw-r--r--devel/avr-gcc/pkg-plist1
4 files changed, 41 insertions, 11 deletions
diff --git a/devel/avr-gcc/Makefile b/devel/avr-gcc/Makefile
index ee56be96ca1e..97a2fe2f0747 100644
--- a/devel/avr-gcc/Makefile
+++ b/devel/avr-gcc/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gcc
-PORTVERSION= 3.3.2002.10.01
+PORTVERSION= 3.3.2003.01.08
CATEGORIES= devel
#MASTER_SITES= ${MASTER_SITE_GNU}
#MASTER_SITE_SUBDIR= ${PORTNAME}/${PORTNAME}-${PORTVERSION}
@@ -38,7 +38,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --target=avr
-MAN_AUX= gcc-man.2002.10.01.gz
+MAN_AUX= gcc-man.2003.01.08.gz
MAKE_FLAGS= LANGUAGES="c c++"
# get rid of that silly -mcpu=pentiumpro -current is so fond of. :-(
diff --git a/devel/avr-gcc/distinfo b/devel/avr-gcc/distinfo
index 31c07a4701af..92b2f0e04f44 100644
--- a/devel/avr-gcc/distinfo
+++ b/devel/avr-gcc/distinfo
@@ -1,2 +1,2 @@
-MD5 (gcc-core+g++-3.3.2002.10.01.tar.bz2) = 6ccdbd6133a4884d07ba9a86f6ec7ffb
-MD5 (gcc-man.2002.10.01.gz) = 5840b17b749722425acc3f371b9688d9
+MD5 (gcc-core+g++-3.3.2003.01.08.tar.bz2) = 964aacb5e6c22b4b188c41d884ad42f4
+MD5 (gcc-man.2003.01.08.gz) = a0bf787b86b46ae1bb2840779b36c820
diff --git a/devel/avr-gcc/files/patch-ab b/devel/avr-gcc/files/patch-ab
index 307e0574744f..c340404fa7fe 100644
--- a/devel/avr-gcc/files/patch-ab
+++ b/devel/avr-gcc/files/patch-ab
@@ -1,6 +1,6 @@
---- Makefile.in.orig Tue Oct 1 21:56:45 2002
-+++ Makefile.in Wed Oct 2 13:19:05 2002
-@@ -753,74 +753,19 @@
+--- Makefile.in.orig Wed Jan 8 21:17:05 2003
++++ Makefile.in Wed Jan 8 23:13:49 2003
+@@ -745,79 +745,19 @@
# This is a list of the targets for all of the modules which are compiled
# using $(TARGET_FLAGS_TO_PASS).
@@ -19,7 +19,8 @@
- all-target-libjava \
- all-target-zlib \
- all-target-boehm-gc \
-- all-target-qthreads
+- all-target-qthreads \
+- all-target-rda
+ALL_TARGET_MODULES =
# This is a list of the configure targets for all of the modules which
@@ -39,7 +40,8 @@
- configure-target-libjava \
- configure-target-zlib \
- configure-target-boehm-gc \
-- configure-target-qthreads
+- configure-target-qthreads \
+- configure-target-rda
+CONFIGURE_TARGET_MODULES =
# This is a list of the check targets for all of the modules which are
@@ -56,7 +58,8 @@
- check-target-libjava \
- check-target-zlib \
- check-target-boehm-gc \
-- check-target-qthreads
+- check-target-qthreads \
+- check-target-rda
+CHECK_TARGET_MODULES =
# This is a list of the install targets for all of the modules which are
@@ -71,11 +74,37 @@
- install-target-libgloss \
- install-target-libiberty \
- install-target-gperf \
+- install-target-libffi \
- install-target-libjava \
- install-target-zlib \
- install-target-boehm-gc \
-- install-target-qthreads
+- install-target-qthreads \
+- install-target-rda
+INSTALL_TARGET_MODULES =
# This is a list of the targets for which we can do a clean-{target}.
CLEAN_MODULES = \
+@@ -883,22 +823,7 @@
+ clean-zlib
+
+ # All of the target modules that can be cleaned
+-CLEAN_TARGET_MODULES = \
+- clean-target-libstdc++-v3 \
+- clean-target-newlib \
+- clean-target-libf2c \
+- clean-target-libobjc \
+- clean-target-winsup \
+- clean-target-libgloss \
+- clean-target-libiberty \
+- clean-target-gperf \
+- clean-target-examples \
+- clean-target-libffi \
+- clean-target-libjava \
+- clean-target-zlib \
+- clean-target-boehm-gc \
+- clean-target-qthreads \
+- clean-target-rda
++CLEAN_TARGET_MODULES =
+
+ # All of the x11 modules that can be cleaned
+ CLEAN_X11_MODULES = \
diff --git a/devel/avr-gcc/pkg-plist b/devel/avr-gcc/pkg-plist
index 9809a55d62dd..90519a540061 100644
--- a/devel/avr-gcc/pkg-plist
+++ b/devel/avr-gcc/pkg-plist
@@ -42,6 +42,7 @@ info/gcc.info-20
info/gcc.info-21
info/gcc.info-22
info/gcc.info-23
+info/gcc.info-24
info/gccint.info
info/gccint.info-1
info/gccint.info-2