aboutsummaryrefslogtreecommitdiff
path: root/devel/avr-gcc
diff options
context:
space:
mode:
authorJoerg Wunsch <joerg@FreeBSD.org>2006-10-10 10:24:51 +0000
committerJoerg Wunsch <joerg@FreeBSD.org>2006-10-10 10:24:51 +0000
commit60ba18f36c9463b2833e1c2b422d08568e4133d5 (patch)
tree6ce512a6353dd3b864b1ec64f54bf62966286044 /devel/avr-gcc
parent2e18ce935ca68e68546d27dbaeb2b3130a233fd4 (diff)
downloadports-60ba18f36c9463b2833e1c2b422d08568e4133d5.tar.gz
ports-60ba18f36c9463b2833e1c2b422d08568e4133d5.zip
Notes
Diffstat (limited to 'devel/avr-gcc')
-rw-r--r--devel/avr-gcc/Makefile1
-rw-r--r--devel/avr-gcc/files/patch-bug2567213
2 files changed, 14 insertions, 0 deletions
diff --git a/devel/avr-gcc/Makefile b/devel/avr-gcc/Makefile
index cea0fd0b1f7e..94ccaefa6a34 100644
--- a/devel/avr-gcc/Makefile
+++ b/devel/avr-gcc/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gcc
PORTVERSION= 4.1.1
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GCC}
MASTER_SITES+= http://people.freebsd.org/~joerg/:local
diff --git a/devel/avr-gcc/files/patch-bug25672 b/devel/avr-gcc/files/patch-bug25672
new file mode 100644
index 000000000000..09fa118994db
--- /dev/null
+++ b/devel/avr-gcc/files/patch-bug25672
@@ -0,0 +1,13 @@
+http://gcc.gnu.org/bugzilla/show_bug.cgi?id=25672
+
+--- Makefile.in.orig Thu Dec 15 19:02:02 2005
++++ Makefile.in Thu Apr 27 03:58:59 2006
+@@ -329,7 +329,7 @@
+ # CFLAGS will be just -g. We want to ensure that TARGET libraries
+ # (which we know are built with gcc) are built with optimizations so
+ # prepend -O2 when setting CFLAGS_FOR_TARGET.
+-CFLAGS_FOR_TARGET = -O2 $(CFLAGS) $(SYSROOT_CFLAGS_FOR_TARGET)
++CFLAGS_FOR_TARGET = -O2 $(filter-out -march=% -mcpu=%,$(CFLAGS)) $(SYSROOT_CFLAGS_FOR_TARGET)
+ SYSROOT_CFLAGS_FOR_TARGET = @SYSROOT_CFLAGS_FOR_TARGET@
+ CXXFLAGS_FOR_TARGET = $(CXXFLAGS) $(SYSROOT_CFLAGS_FOR_TARGET)
+ LIBCFLAGS_FOR_TARGET = $(CFLAGS_FOR_TARGET)