aboutsummaryrefslogtreecommitdiff
path: root/devel/avr-gcc
diff options
context:
space:
mode:
authorJoerg Wunsch <joerg@FreeBSD.org>2006-03-19 22:38:09 +0000
committerJoerg Wunsch <joerg@FreeBSD.org>2006-03-19 22:38:09 +0000
commit0a21728cdf0ecc6c31cddf6b6db80bd0779c584d (patch)
treeacaf378867be081c5f53831dbc2b6b95d5efa5db /devel/avr-gcc
parente42af1347c89fd7e810f0e74c6bcf6ce77dad3a9 (diff)
downloadports-0a21728cdf0ecc6c31cddf6b6db80bd0779c584d.tar.gz
ports-0a21728cdf0ecc6c31cddf6b6db80bd0779c584d.zip
Notes
Diffstat (limited to 'devel/avr-gcc')
-rw-r--r--devel/avr-gcc/Makefile11
-rw-r--r--devel/avr-gcc/distinfo12
-rw-r--r--devel/avr-gcc/files/patch-newdevices41
-rw-r--r--devel/avr-gcc/pkg-descr4
-rw-r--r--devel/avr-gcc/pkg-plist100
5 files changed, 91 insertions, 77 deletions
diff --git a/devel/avr-gcc/Makefile b/devel/avr-gcc/Makefile
index a8fe28365e52..812ec5d30aeb 100644
--- a/devel/avr-gcc/Makefile
+++ b/devel/avr-gcc/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gcc
-PORTVERSION= 3.4.5
-PORTREVISION= 2
+PORTVERSION= 3.4.6
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GCC}
MASTER_SITES+= http://people.freebsd.org/~joerg/:local
@@ -35,6 +34,8 @@ USE_GMAKE= yes
USE_BISON= yes
GNU_CONFIGURE= yes
+CONFLICTS= avr-gcc-devel-4*
+
CONFIGURE_ARGS= --target=avr --disable-nls
MAKE_FLAGS= LANGUAGES="c c++"
@@ -45,7 +46,7 @@ MAN1= avr-cpp.1 avr-gcc.1 avr-g++.1 avr-gcov.1
MAN7= fsf-funding.7 gfdl.7 gpl.7
INFO= cpp gcc gccint cppinternals gccinstall
-# As files/patch-binary-constants updates the documentation, we need to
+# As ${FILESDIR}/patch-binary-constants updates the documentation, we need to
# recreate it.
pre-build:
cd ${WRKSRC}/gcc &&\
@@ -54,8 +55,8 @@ pre-build:
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500600
-BROKEN= "System's Pod::Man too old to generate the documentation."
-IGNORE= "you need a newer version of Perl to build the documentation"
+BROKEN= System's Pod::Man too old to generate the documentation.
+IGNORE= you need a newer version of Perl to build the documentation
.endif
.include <bsd.port.post.mk>
diff --git a/devel/avr-gcc/distinfo b/devel/avr-gcc/distinfo
index 70ded7d9faf2..bcc1be13d96a 100644
--- a/devel/avr-gcc/distinfo
+++ b/devel/avr-gcc/distinfo
@@ -1,6 +1,6 @@
-MD5 (gcc-core-3.4.5.tar.bz2) = 0114ba67f9aabad91d96797d0b6017c4
-SHA256 (gcc-core-3.4.5.tar.bz2) = 8a2824b12a1cae8b68de3be0a8fd2da14918462e6afa27c3578ccfc8ab10d0fc
-SIZE (gcc-core-3.4.5.tar.bz2) = 13397308
-MD5 (gcc-g++-3.4.5.tar.bz2) = 8d51a3255e680f35ef744af0bf595595
-SHA256 (gcc-g++-3.4.5.tar.bz2) = 7d6bd45ebf1e004146f6ff959a7dd92e049d8e9e7fc132d111690d23011af93b
-SIZE (gcc-g++-3.4.5.tar.bz2) = 2510819
+MD5 (gcc-core-3.4.6.tar.bz2) = 5324ace5145b12afd9ca867af7ec084d
+SHA256 (gcc-core-3.4.6.tar.bz2) = 3aab171d86e5a6c14cb9de35467a0472a7d5ef1d5b79a1df72ca533f8e82a133
+SIZE (gcc-core-3.4.6.tar.bz2) = 13366790
+MD5 (gcc-g++-3.4.6.tar.bz2) = ef81fd74bc9fd964120af47243a1360f
+SHA256 (gcc-g++-3.4.6.tar.bz2) = f186937402752d25317adf2832b0b1d316334e158ae380471ab62509e4ea90b1
+SIZE (gcc-g++-3.4.6.tar.bz2) = 2511332
diff --git a/devel/avr-gcc/files/patch-newdevices b/devel/avr-gcc/files/patch-newdevices
index b034533fb235..5ddb6a0c6c2d 100644
--- a/devel/avr-gcc/files/patch-newdevices
+++ b/devel/avr-gcc/files/patch-newdevices
@@ -1,6 +1,6 @@
-diff -ur ../gcc-3.4.5.orig/gcc/config/avr/avr.c ./gcc/config/avr/avr.c
---- ../gcc-3.4.5.orig/gcc/config/avr/avr.c Wed Jan 4 22:38:40 2006
-+++ ./gcc/config/avr/avr.c Wed Jan 4 22:44:07 2006
+diff -ur ../gcc-3.4.6.orig/gcc/config/avr/avr.c ./gcc/config/avr/avr.c
+--- ../gcc-3.4.6.orig/gcc/config/avr/avr.c Sun Mar 20 22:14:28 2005
++++ ./gcc/config/avr/avr.c Sun Mar 19 23:06:42 2006
@@ -175,6 +175,18 @@
{ "at90c8534", 2, "__AVR_AT90C8534__" },
{ "at90s8535", 2, "__AVR_AT90S8535__" },
@@ -20,7 +20,7 @@ diff -ur ../gcc-3.4.5.orig/gcc/config/avr/avr.c ./gcc/config/avr/avr.c
/* Classic, > 8K. */
{ "avr3", 3, NULL },
{ "atmega103", 3, "__AVR_ATmega103__" },
-@@ -185,19 +197,42 @@
+@@ -185,19 +197,47 @@
/* Enhanced, <= 8K. */
{ "avr4", 4, NULL },
{ "atmega8", 4, "__AVR_ATmega8__" },
@@ -47,6 +47,7 @@ diff -ur ../gcc-3.4.5.orig/gcc/config/avr/avr.c ./gcc/config/avr/avr.c
+ { "atmega3250", 5, "__AVR_ATmega3250__" },
+ { "atmega329", 5, "__AVR_ATmega329__" },
+ { "atmega3290", 5, "__AVR_ATmega3290__" },
++ { "atmega406", 5, "__AVR_ATmega406__" },
+ { "atmega640", 5, "__AVR_ATmega640__" },
{ "atmega64", 5, "__AVR_ATmega64__" },
+ { "atmega644", 5, "__AVR_ATmega644__" },
@@ -60,12 +61,16 @@ diff -ur ../gcc-3.4.5.orig/gcc/config/avr/avr.c ./gcc/config/avr/avr.c
+ { "at90can32", 5, "__AVR_AT90CAN32__" },
+ { "at90can64", 5, "__AVR_AT90CAN64__" },
+ { "at90can128", 5, "__AVR_AT90CAN128__" },
++ { "at90usb646", 5, "__AVR_AT90USB646__" },
++ { "at90usb647", 5, "__AVR_AT90USB647__" },
++ { "at90usb1286", 5, "__AVR_AT90USB1286__" },
++ { "at90usb1287", 5, "__AVR_AT90USB1287__" },
{ "at94k", 5, "__AVR_AT94K__" },
/* Assembler only. */
{ "avr1", 1, NULL },
-diff -ur ../gcc-3.4.5.orig/gcc/config/avr/avr.h ./gcc/config/avr/avr.h
---- ../gcc-3.4.5.orig/gcc/config/avr/avr.h Wed Jan 4 22:38:36 2006
-+++ ./gcc/config/avr/avr.h Wed Jan 4 22:45:00 2006
+diff -ur ../gcc-3.4.6.orig/gcc/config/avr/avr.h ./gcc/config/avr/avr.h
+--- ../gcc-3.4.6.orig/gcc/config/avr/avr.h Tue Mar 9 04:00:15 2004
++++ ./gcc/config/avr/avr.h Sun Mar 19 23:08:23 2006
@@ -2351,12 +2351,13 @@
Do not define this macro if it does not need to do anything. */
@@ -79,8 +84,8 @@ diff -ur ../gcc-3.4.5.orig/gcc/config/avr/avr.h ./gcc/config/avr/avr.h
-%{mmcu=atmega16*|mmcu=atmega32*|mmcu=atmega64|mmcu=atmega128|mmcu=at94k:-m avr5}\
-%{mmcu=atmega64|mmcu=atmega128|mmcu=atmega162|mmcu=atmega169: -Tdata 0x800100} "
+%{mmcu=atmega8*|mmcu=atmega48|mmcu=at90pwm*:-m avr4}\
-+%{mmcu=atmega16*|mmcu=atmega32*|mmcu=atmega64*|mmcu=atmega128*|mmcu=at90can*|mmcu=at94k:-m avr5}\
-+%{mmcu=atmega324|mmcu=atmega325|mmcu=atmega3250|mmcu=atmega329|mmcu=atmega3290|mmcu=atmega48|mmcu=atmega88|mmcu=atmega64|mmcu=atmega644|mmcu=atmega645|mmcu=atmega6450|mmcu=atmega649|mmcu=atmega6490|mmcu=atmega128|mmcu=at90can*|mmcu=atmega162|mmcu=atmega164|mmcu=atmega165|mmcu=atmega168|mmcu=atmega169|mmcu=at90pwm*: -Tdata 0x800100}\
++%{mmcu=atmega16*|mmcu=atmega32*|mmcu=atmega406|mmcu=atmega64*|mmcu=atmega128*|mmcu=at90can*|mmcu=at90usb*|mmcu=at94k:-m avr5}\
++%{mmcu=atmega324|mmcu=atmega325|mmcu=atmega3250|mmcu=atmega329|mmcu=atmega3290|mmcu=atmega406|mmcu=atmega48|mmcu=atmega88|mmcu=atmega64|mmcu=atmega644|mmcu=atmega645|mmcu=atmega6450|mmcu=atmega649|mmcu=atmega6490|mmcu=atmega128|mmcu=at90can*|mmcu=atmega162|mmcu=atmega164|mmcu=atmega165|mmcu=atmega168|mmcu=atmega169|mmcu=at90pwm*|mmcu=at90usb*: -Tdata 0x800100}\
+%{mmcu=atmega640|mmcu=atmega1280|mmcu=atmega1281: -Tdata 0x800200} "
/* A C string constant that tells the GCC driver program options to
@@ -103,7 +108,7 @@ diff -ur ../gcc-3.4.5.orig/gcc/config/avr/avr.h ./gcc/config/avr/avr.h
/* Another C string constant that tells the GCC driver program how
and when to place a reference to `libgcc.a' into the linker
command line. This constant is placed both before and after the
-@@ -2421,23 +2422,57 @@
+@@ -2421,23 +2422,62 @@
%{mmcu=at90c8534:crtc8534.o%s} \
%{mmcu=at90s8535:crts8535.o%s} \
%{mmcu=at86rf401:crt86401.o%s} \
@@ -145,6 +150,7 @@ diff -ur ../gcc-3.4.5.orig/gcc/config/avr/avr.h ./gcc/config/avr/avr.h
+%{mmcu=atmega3250:crtm3250.o%s} \
+%{mmcu=atmega329:crtm329.o%s} \
+%{mmcu=atmega3290:crtm3290.o%s} \
++%{mmcu=atmega406:crtm406.o%s} \
%{mmcu=atmega64:crtm64.o%s} \
+%{mmcu=atmega640:crtm640.o%s} \
+%{mmcu=atmega644:crtm644.o%s} \
@@ -158,13 +164,17 @@ diff -ur ../gcc-3.4.5.orig/gcc/config/avr/avr.h ./gcc/config/avr/avr.h
+%{mmcu=at90can32:crtcan32.o%s} \
+%{mmcu=at90can64:crtcan64.o%s} \
+%{mmcu=at90can128:crtcan128.o%s} \
++%{mmcu=at90usb646:crtusb646.o%s} \
++%{mmcu=at90usb647:crtusb647.o%s} \
++%{mmcu=at90usb1286:crtusb1286.o%s} \
++%{mmcu=at90usb1287:crtusb1287.o%s} \
%{mmcu=at94k:crtat94k.o%s}"
#define EXTRA_SPECS {"crt_binutils", CRT_BINUTILS_SPECS},
-diff -ur ../gcc-3.4.5.orig/gcc/config/avr/t-avr ./gcc/config/avr/t-avr
---- ../gcc-3.4.5.orig/gcc/config/avr/t-avr Mon Apr 25 06:17:34 2005
-+++ ./gcc/config/avr/t-avr Wed Jan 4 22:43:26 2006
-@@ -46,12 +46,27 @@
+diff -ur ../gcc-3.4.6.orig/gcc/config/avr/t-avr ./gcc/config/avr/t-avr
+--- ../gcc-3.4.6.orig/gcc/config/avr/t-avr Mon Apr 25 06:17:34 2005
++++ ./gcc/config/avr/t-avr Sun Mar 19 23:08:56 2006
+@@ -46,12 +46,30 @@
mmcu?avr3=mmcu?at43usb320 mmcu?avr3=mmcu?at43usb355 \
mmcu?avr3=mmcu?at76c711 \
mmcu?avr4=mmcu?atmega8515 mmcu?avr4=mmcu?atmega8535 \
@@ -184,6 +194,7 @@ diff -ur ../gcc-3.4.5.orig/gcc/config/avr/t-avr ./gcc/config/avr/t-avr
+ mmcu?avr5=mmcu?atmega325 mmcu?avr5=mmcu?atmega3250 \
+ mmcu?avr5=mmcu?atmega329 mmcu?avr5=mmcu?atmega3290 \
+ mmcu?avr5=mmcu?atmega32 \
++ mmcu?avr5=mmcu?atmega406 \
+ mmcu?avr5=mmcu?atmega640 \
+ mmcu?avr5=mmcu?atmega644 mmcu?avr5=mmcu?atmega645 \
+ mmcu?avr5=mmcu?atmega6450 mmcu?avr5=mmcu?atmega649 \
@@ -193,6 +204,8 @@ diff -ur ../gcc-3.4.5.orig/gcc/config/avr/t-avr ./gcc/config/avr/t-avr
+ mmcu?avr5=mmcu?at90can32 \
+ mmcu?avr5=mmcu?at90can64 \
+ mmcu?avr5=mmcu?at90can128 \
++ mmcu?avr5=mmcu?at90usb646 mmcu?avr5=mmcu?at90usb647 \
++ mmcu?avr5=mmcu?at90usb1286 mmcu?avr5=mmcu?at90usb1287 \
mmcu?avr5=mmcu?at94k
MULTILIB_EXCEPTIONS =
diff --git a/devel/avr-gcc/pkg-descr b/devel/avr-gcc/pkg-descr
index bfa484c5cf92..a5ab3f8f1a97 100644
--- a/devel/avr-gcc/pkg-descr
+++ b/devel/avr-gcc/pkg-descr
@@ -13,12 +13,12 @@ Locally added support for the following AVR devices:
ATtiny13/ATtiny2313 ATtiny24/ATtiny44/ATtiny84
ATtiny25/ATtiny45/ATtiny85 ATtiny261/ATtiny461/ATtiny861
- ATmega48/ATmega88/ATmega168
+ ATmega48/ATmega88/ATmega168 ATmega406
ATmega164/ATmega324/ATmega644 ATmega165
ATmega325/ATmega3250/ATmega645/ATmega6450
ATmega329/ATmega3290/ATmega649/ATmega6490
ATmega640/ATmega1280/ATmega1281 AT90PWM2/AT90PWM3
- AT90CAN32/64/128
+ AT90CAN32/64/128 AT90USB646/647/1286/1287
WWW: http://gcc.gnu.org/
WWW: http://www.nongnu.org/avr-libc/
diff --git a/devel/avr-gcc/pkg-plist b/devel/avr-gcc/pkg-plist
index eee22c9b0e7a..b9cdd5edfc3b 100644
--- a/devel/avr-gcc/pkg-plist
+++ b/devel/avr-gcc/pkg-plist
@@ -5,58 +5,58 @@ bin/avr-c++
bin/avr-cpp
bin/avr-g++
bin/avr-gcc
-bin/avr-gcc-3.4.5
+bin/avr-gcc-3.4.6
bin/avr-gccbug
-lib/gcc/avr/3.4.5/avr3/libgcc.a
-lib/gcc/avr/3.4.5/avr3/libgcov.a
-lib/gcc/avr/3.4.5/avr4/libgcc.a
-lib/gcc/avr/3.4.5/avr4/libgcov.a
-lib/gcc/avr/3.4.5/avr5/libgcc.a
-lib/gcc/avr/3.4.5/avr5/libgcov.a
-lib/gcc/avr/3.4.5/include/README
-lib/gcc/avr/3.4.5/include/fixed
-lib/gcc/avr/3.4.5/include/float.h
-lib/gcc/avr/3.4.5/include/iso646.h
-lib/gcc/avr/3.4.5/include/limits.h
-lib/gcc/avr/3.4.5/include/stdarg.h
-lib/gcc/avr/3.4.5/include/stdbool.h
-lib/gcc/avr/3.4.5/include/stddef.h
-lib/gcc/avr/3.4.5/include/syslimits.h
-lib/gcc/avr/3.4.5/include/unwind.h
-lib/gcc/avr/3.4.5/include/varargs.h
-lib/gcc/avr/3.4.5/install-tools/gsyslimits.h
-lib/gcc/avr/3.4.5/install-tools/include/README
-lib/gcc/avr/3.4.5/install-tools/include/float.h
-lib/gcc/avr/3.4.5/install-tools/include/iso646.h
-lib/gcc/avr/3.4.5/install-tools/include/limits.h
-lib/gcc/avr/3.4.5/install-tools/include/stdarg.h
-lib/gcc/avr/3.4.5/install-tools/include/stdbool.h
-lib/gcc/avr/3.4.5/install-tools/include/stddef.h
-lib/gcc/avr/3.4.5/install-tools/include/unwind.h
-lib/gcc/avr/3.4.5/install-tools/include/varargs.h
-lib/gcc/avr/3.4.5/install-tools/mkheaders.conf
-lib/gcc/avr/3.4.5/libgcc.a
-lib/gcc/avr/3.4.5/libgcov.a
-lib/gcc/avr/3.4.5/specs
-libexec/gcc/avr/3.4.5/cc1
-libexec/gcc/avr/3.4.5/cc1plus
-libexec/gcc/avr/3.4.5/collect2
-libexec/gcc/avr/3.4.5/install-tools/fix-header
-libexec/gcc/avr/3.4.5/install-tools/fixinc.sh
-libexec/gcc/avr/3.4.5/install-tools/fixincl
-libexec/gcc/avr/3.4.5/install-tools/fixproto
-libexec/gcc/avr/3.4.5/install-tools/mkheaders
-libexec/gcc/avr/3.4.5/install-tools/mkinstalldirs
-@dirrm lib/gcc/avr/3.4.5/avr3
-@dirrm lib/gcc/avr/3.4.5/avr4
-@dirrm lib/gcc/avr/3.4.5/avr5
-@dirrm lib/gcc/avr/3.4.5/include
-@dirrm lib/gcc/avr/3.4.5/install-tools/include
-@dirrm lib/gcc/avr/3.4.5/install-tools
-@dirrm lib/gcc/avr/3.4.5
+lib/gcc/avr/3.4.6/avr3/libgcc.a
+lib/gcc/avr/3.4.6/avr3/libgcov.a
+lib/gcc/avr/3.4.6/avr4/libgcc.a
+lib/gcc/avr/3.4.6/avr4/libgcov.a
+lib/gcc/avr/3.4.6/avr5/libgcc.a
+lib/gcc/avr/3.4.6/avr5/libgcov.a
+lib/gcc/avr/3.4.6/include/README
+lib/gcc/avr/3.4.6/include/fixed
+lib/gcc/avr/3.4.6/include/float.h
+lib/gcc/avr/3.4.6/include/iso646.h
+lib/gcc/avr/3.4.6/include/limits.h
+lib/gcc/avr/3.4.6/include/stdarg.h
+lib/gcc/avr/3.4.6/include/stdbool.h
+lib/gcc/avr/3.4.6/include/stddef.h
+lib/gcc/avr/3.4.6/include/syslimits.h
+lib/gcc/avr/3.4.6/include/unwind.h
+lib/gcc/avr/3.4.6/include/varargs.h
+lib/gcc/avr/3.4.6/install-tools/gsyslimits.h
+lib/gcc/avr/3.4.6/install-tools/include/README
+lib/gcc/avr/3.4.6/install-tools/include/float.h
+lib/gcc/avr/3.4.6/install-tools/include/iso646.h
+lib/gcc/avr/3.4.6/install-tools/include/limits.h
+lib/gcc/avr/3.4.6/install-tools/include/stdarg.h
+lib/gcc/avr/3.4.6/install-tools/include/stdbool.h
+lib/gcc/avr/3.4.6/install-tools/include/stddef.h
+lib/gcc/avr/3.4.6/install-tools/include/unwind.h
+lib/gcc/avr/3.4.6/install-tools/include/varargs.h
+lib/gcc/avr/3.4.6/install-tools/mkheaders.conf
+lib/gcc/avr/3.4.6/libgcc.a
+lib/gcc/avr/3.4.6/libgcov.a
+lib/gcc/avr/3.4.6/specs
+libexec/gcc/avr/3.4.6/cc1
+libexec/gcc/avr/3.4.6/cc1plus
+libexec/gcc/avr/3.4.6/collect2
+libexec/gcc/avr/3.4.6/install-tools/fix-header
+libexec/gcc/avr/3.4.6/install-tools/fixinc.sh
+libexec/gcc/avr/3.4.6/install-tools/fixincl
+libexec/gcc/avr/3.4.6/install-tools/fixproto
+libexec/gcc/avr/3.4.6/install-tools/mkheaders
+libexec/gcc/avr/3.4.6/install-tools/mkinstalldirs
+@dirrm lib/gcc/avr/3.4.6/avr3
+@dirrm lib/gcc/avr/3.4.6/avr4
+@dirrm lib/gcc/avr/3.4.6/avr5
+@dirrm lib/gcc/avr/3.4.6/include
+@dirrm lib/gcc/avr/3.4.6/install-tools/include
+@dirrm lib/gcc/avr/3.4.6/install-tools
+@dirrm lib/gcc/avr/3.4.6
@dirrm lib/gcc/avr
@dirrm lib/gcc
-@dirrm libexec/gcc/avr/3.4.5/install-tools
-@dirrm libexec/gcc/avr/3.4.5
+@dirrm libexec/gcc/avr/3.4.6/install-tools
+@dirrm libexec/gcc/avr/3.4.6
@dirrm libexec/gcc/avr
@dirrm libexec/gcc