aboutsummaryrefslogtreecommitdiff
path: root/devel/avr-gdb
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2013-10-18 09:59:43 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2013-10-18 09:59:43 +0000
commitb9288bf1d09edbc42b90637cffa77dc23c5c51bc (patch)
tree74989dc8b8d35f0472dc2b23b83070d17a77148e /devel/avr-gdb
parented59bfb4d20c0176281c5bec8f9958eadbb27030 (diff)
Notes
Diffstat (limited to 'devel/avr-gdb')
-rw-r--r--devel/avr-gdb/Makefile2
-rw-r--r--devel/avr-gdb/files/patch-bfd-bfdio.c11
-rw-r--r--devel/avr-gdb/files/patch-bfd-elflink.c11
3 files changed, 23 insertions, 1 deletions
diff --git a/devel/avr-gdb/Makefile b/devel/avr-gdb/Makefile
index 2c402370c896..b9b76bfc1f22 100644
--- a/devel/avr-gdb/Makefile
+++ b/devel/avr-gdb/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gdb
PORTVERSION= 7.3.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= gdb
diff --git a/devel/avr-gdb/files/patch-bfd-bfdio.c b/devel/avr-gdb/files/patch-bfd-bfdio.c
new file mode 100644
index 000000000000..ee72b11fb6a6
--- /dev/null
+++ b/devel/avr-gdb/files/patch-bfd-bfdio.c
@@ -0,0 +1,11 @@
+--- bfd/bfdio.c.orig
++++ bfd/bfdio.c
+@@ -577,7 +577,7 @@
+ {
+ struct bfd_in_memory *bim = (struct bfd_in_memory *) abfd->iostream;
+
+- memset (statbuf, 0, sizeof (statbuf));
++ memset (statbuf, 0, sizeof (*statbuf));
+ statbuf->st_size = bim->size;
+
+ return 0;
diff --git a/devel/avr-gdb/files/patch-bfd-elflink.c b/devel/avr-gdb/files/patch-bfd-elflink.c
new file mode 100644
index 000000000000..b888ff54b159
--- /dev/null
+++ b/devel/avr-gdb/files/patch-bfd-elflink.c
@@ -0,0 +1,11 @@
+--- bfd/elflink.c.orig
++++ bfd/elflink.c
+@@ -12456,7 +12456,7 @@
+ abfd, sec);
+ else if (sec->size != 0)
+ {
+- bfd_byte *sec_contents, *l_sec_contents;
++ bfd_byte *sec_contents = NULL, *l_sec_contents = NULL;
+
+ if (!bfd_malloc_and_get_section (abfd, sec, &sec_contents))
+ (*_bfd_error_handler)