aboutsummaryrefslogtreecommitdiff
path: root/devel/avr-libc/Makefile
diff options
context:
space:
mode:
authorJoerg Wunsch <joerg@FreeBSD.org>2005-11-19 22:14:27 +0000
committerJoerg Wunsch <joerg@FreeBSD.org>2005-11-19 22:14:27 +0000
commit76be43e6d2d544b8cc4d29e71342a3b51f65c371 (patch)
treebfc4ce834de8f3a45149b141b39ade113528c811 /devel/avr-libc/Makefile
parent6a53d41a22c833387b5ef4f7823f4ece318d06e5 (diff)
downloadports-76be43e6d2d544b8cc4d29e71342a3b51f65c371.tar.gz
ports-76be43e6d2d544b8cc4d29e71342a3b51f65c371.zip
Notes
Diffstat (limited to 'devel/avr-libc/Makefile')
-rw-r--r--devel/avr-libc/Makefile40
1 files changed, 5 insertions, 35 deletions
diff --git a/devel/avr-libc/Makefile b/devel/avr-libc/Makefile
index 83a0ff3a1aad..a0fff4400497 100644
--- a/devel/avr-libc/Makefile
+++ b/devel/avr-libc/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= avr-libc
-PORTVERSION= 1.2.6
+PORTVERSION= 1.4.0
PORTEPOCH= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
@@ -32,11 +32,12 @@ USE_BZIP2= yes
USE_GMAKE= yes
HAS_CONFIGURE= yes
CONFIGURE_ENV= CC=avr-gcc PREFIX=${PREFIX}
-CONFIGURE_SCRIPT= doconf
.if !defined(NOPORTDOCS)
-CONFIGURE_ARGS= --enable-doc --disable-versioned-doc
+CONFIGURE_ARGS= --build=`./config.guess` --host=avr \
+ --enable-doc --disable-versioned-doc
PLIST_DOC= ${PKGDIR}/pkg-plist.doc
.else
+CONFIGURE_ARGS= --build=`./config.guess` --host=avr
PLIST_DOC=
.endif
# Work around the braind***ness introduced by <bsd.cpu.mk> in freebsd-5.
@@ -51,18 +52,9 @@ DEMOFILES= Makefile demo.c
DEMOFILES+= demo.bin demo.hex demo.pdf demo.srec
.endif
-.if defined(MAINTAINER_DEBUG)
-ECHO_EXTRA_RM= ${ECHO_CMD} "Removing " $${to_be_rm_ed} "..."
-.else
-ECHO_EXTRA_RM= ${ECHO_CMD} "Removing extraneous man page files..."
-.endif
-
-do-build:
- (cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ./domake MAKE=${GMAKE})
-
do-install:
${RM} -f ${TMPPLIST}; ${CAT} ${PLIST_DOC} ${PLIST} > ${TMPPLIST}
- (cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ./domake MAKE=${GMAKE} install)
+ (cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${GMAKE} install)
${MKDIR} ${PREFIX}/share/doc/avr-libc
${MKDIR} ${PREFIX}/share/doc/avr-libc/examples
${MKDIR} ${PREFIX}/share/doc/avr-libc/examples/demo
@@ -71,12 +63,6 @@ do-install:
${WRKDIR}/${DISTNAME}/LICENSE \
${WRKDIR}/${DISTNAME}/AUTHORS \
${PREFIX}/share/doc/avr-libc
- @for f in avr-recv.c io.c prg printf.h progmem.c \
- send_byte.s signal.c;\
- do \
- ${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/doc/examples/$$f \
- ${PREFIX}/share/doc/avr-libc/examples; \
- done
@for f in ${DEMOFILES};\
do \
${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/doc/examples/demo/$$f \
@@ -87,21 +73,5 @@ do-install:
${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/doc/examples/twitest/$$f \
${PREFIX}/share/doc/avr-libc/examples/twitest; \
done
-.if !defined(NOPORTDOCS)
- @( \
- tmpname=$${TMPDIR:-/tmp}/avr-libc-inst.$$$$ ; \
- cd ${PREFIX}/share/doc/avr-libc/man/man3 ; \
- ${GREP} '^share/doc/.*man3/' ${PLIST_DOC} | \
- ${SED} -e 's,.*/,,' | \
- ${SORT} > $${tmpname}.1 ; \
- ${LS} -1 | \
- ${SED} -e 's,.*/,,' | \
- ${SORT} > $${tmpname}.2 ; \
- to_be_rm_ed=$$(${COMM} -13 $${tmpname}.1 $${tmpname}.2) ; \
- ${RM} -f $${tmpname}.1 $${tmpname}.2 ; \
- ${ECHO_EXTRA_RM} ; \
- ${RM} -f $${to_be_rm_ed} \
- )
-.endif
.include <bsd.port.mk>