aboutsummaryrefslogtreecommitdiff
path: root/devel/avr-libc
diff options
context:
space:
mode:
authorJoerg Wunsch <joerg@FreeBSD.org>2006-09-28 22:13:24 +0000
committerJoerg Wunsch <joerg@FreeBSD.org>2006-09-28 22:13:24 +0000
commit593747c381b194ced56adcce6903a003b97ef527 (patch)
treef64859a18dbb34092fe72f03f29bdf69a3bcf71a /devel/avr-libc
parent4e9cb2caae1b305dbf07fad6ba38dab41246fce1 (diff)
downloadports-593747c381b194ced56adcce6903a003b97ef527.tar.gz
ports-593747c381b194ced56adcce6903a003b97ef527.zip
Notes
Diffstat (limited to 'devel/avr-libc')
-rw-r--r--devel/avr-libc/Makefile1
-rw-r--r--devel/avr-libc/files/patch-binutils2.1728
2 files changed, 29 insertions, 0 deletions
diff --git a/devel/avr-libc/Makefile b/devel/avr-libc/Makefile
index d87db810463c..347904c918a1 100644
--- a/devel/avr-libc/Makefile
+++ b/devel/avr-libc/Makefile
@@ -8,6 +8,7 @@
PORTNAME= avr-libc
PORTVERSION= 1.4.4
PORTEPOCH= 1
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/devel/avr-libc/files/patch-binutils2.17 b/devel/avr-libc/files/patch-binutils2.17
new file mode 100644
index 000000000000..52f20cb47148
--- /dev/null
+++ b/devel/avr-libc/files/patch-binutils2.17
@@ -0,0 +1,28 @@
+Index: doc/examples/demo/Makefile
+===================================================================
+RCS file: /home/cvs/avr-libc/avr-libc/doc/examples/demo/Makefile,v
+retrieving revision 1.10
+retrieving revision 1.11
+diff -u -u -r1.10 -r1.11
+--- doc/examples/demo/Makefile 19 Apr 2006 20:09:20 -0000 1.10
++++ doc/examples/demo/Makefile 28 Aug 2006 05:23:27 -0000 1.11
+@@ -108,13 +108,16 @@
+ esrec: $(PRG)_eeprom.srec
+
+ %_eeprom.hex: %.elf
+- $(OBJCOPY) -j .eeprom --change-section-lma .eeprom=0 -O ihex $< $@
++ $(OBJCOPY) -j .eeprom --change-section-lma .eeprom=0 -O ihex $< $@ \
++ || { echo empty $@ not generated; exit 0; }
+
+ %_eeprom.srec: %.elf
+- $(OBJCOPY) -j .eeprom --change-section-lma .eeprom=0 -O srec $< $@
++ $(OBJCOPY) -j .eeprom --change-section-lma .eeprom=0 -O srec $< $@ \
++ || { echo empty $@ not generated; exit 0; }
+
+ %_eeprom.bin: %.elf
+- $(OBJCOPY) -j .eeprom --change-section-lma .eeprom=0 -O binary $< $@
++ $(OBJCOPY) -j .eeprom --change-section-lma .eeprom=0 -O binary $< $@ \
++ || { echo empty $@ not generated; exit 0; }
+
+ # Every thing below here is used by avr-libc's build system and can be ignored
+ # by the casual user.