aboutsummaryrefslogtreecommitdiff
path: root/devel/avro/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-01-21 08:14:58 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-01-21 08:14:58 +0000
commit65458c0d836336fff6d1802a413332341d2c5309 (patch)
treea93a6a933b2334292f1a8f6560c0381bf63cb3f9 /devel/avro/Makefile
parentadbfec9ca54194a6cfb817597e635780abd23008 (diff)
downloadports-65458c0d836336fff6d1802a413332341d2c5309.tar.gz
ports-65458c0d836336fff6d1802a413332341d2c5309.zip
Notes
Diffstat (limited to 'devel/avro/Makefile')
-rw-r--r--devel/avro/Makefile21
1 files changed, 5 insertions, 16 deletions
diff --git a/devel/avro/Makefile b/devel/avro/Makefile
index a2679cecb826..aaad1aa156e8 100644
--- a/devel/avro/Makefile
+++ b/devel/avro/Makefile
@@ -12,6 +12,8 @@ MAINTAINER= vg@FreeBSD.org
COMMENT= Data serialization system
NO_BUILD= yes
+NO_MTREE= yes
+NO_INSTALL= yes
OPTIONS_DEFINE= C CPP PYTHON
C_DESC= Install ANSI C library
@@ -20,21 +22,8 @@ PYTHON_DESC= Install Python library
OPTIONS_DEFAULT=C CPP PYTHON
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MC}
-LIB_DEPENDS+= avro:${PORTSDIR}/devel/avro-c
-.endif
-
-.if ${PORT_OPTIONS:MCPP}
-LIB_DEPENDS+= avrocpp:${PORTSDIR}/devel/avro-cpp
-.endif
-
-.if ${PORT_OPTIONS:MPYTHON}
-BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}avro:${PORTSDIR}/devel/py-avro
-.endif
-
-do-install: # empty
+MC_LIB_DEPENDS= libavro.so:${PORTSDIR}/devel/avro-c
+CPP_LIB_DEPENDS= libavrocpp.so:${PORTSDIR}/devel/avro-cpp
+PYTHON_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}avro:${PORTSDIR}/devel/py-avro
.include <bsd.port.mk>