aboutsummaryrefslogtreecommitdiff
path: root/devel/avro
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2013-02-01 13:30:16 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2013-02-01 13:30:16 +0000
commit109b5aab9ccc944882dba02e996fe6eefeafad0e (patch)
tree6693d939bda665b828fab7e0ddccdd7973aebae1 /devel/avro
parentc0646a89ddba29f3a026292f7c8d658a1adb44a4 (diff)
downloadports-109b5aab9ccc944882dba02e996fe6eefeafad0e.tar.gz
ports-109b5aab9ccc944882dba02e996fe6eefeafad0e.zip
Notes
Diffstat (limited to 'devel/avro')
-rw-r--r--devel/avro/Makefile39
-rw-r--r--devel/avro/pkg-descr13
2 files changed, 52 insertions, 0 deletions
diff --git a/devel/avro/Makefile b/devel/avro/Makefile
new file mode 100644
index 000000000000..387f488035ac
--- /dev/null
+++ b/devel/avro/Makefile
@@ -0,0 +1,39 @@
+# Created by: Gvozdikov Veniamin <g.veniamin@googlemail.com>
+# $FreeBSD$
+
+PORTNAME= avro
+PORTVERSION= 1.7.3
+CATEGORIES= devel
+MASTER_SITES= # none
+DISTFILES= # none
+EXTRACT_ONLY= # none
+
+MAINTAINER= g.veniamin@googlemail.com
+COMMENT= Data serialization system
+
+NO_BUILD= yes
+
+OPTIONS_DEFINE= C CPP PYTHON
+C_DESC= Install ANSI C library
+CPP_DESC= Install C++ library
+PYTHON_DESC= Install Python library
+
+OPTIONS_DEFAULT=C CPP PYTHON
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MC}
+LIB_DEPENDS+= avro:${PORTSDIR}/devel/avro-c
+.endif
+
+.if ${PORT_OPTIONS:MCPP}
+LIB_DEPENDS+= avrocpp:${PORTSDIR}/devel/avro-cpp
+.endif
+
+.if ${PORT_OPTIONS:MPYTHON}
+BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}avro:${PORTSDIR}/devel/py-avro
+.endif
+
+do-install: # empty
+
+.include <bsd.port.mk>
diff --git a/devel/avro/pkg-descr b/devel/avro/pkg-descr
new file mode 100644
index 000000000000..fcbe3110c019
--- /dev/null
+++ b/devel/avro/pkg-descr
@@ -0,0 +1,13 @@
+Avro is a data serialization system.
+
+Avro provides:
+* Rich data structures.
+* A compact, fast, binary data format.
+* A container file, to store persistent data.
+* Remote procedure call (RPC).
+* Simple integration with dynamic languages. Code generation is not
+required to read or write data files nor to use or implement RPC
+protocols. Code generation as an optional optimization, only worth
+implementing for statically typed languages.
+
+WWW: http://avro.apache.org/