aboutsummaryrefslogtreecommitdiff
path: root/devel/awscli/Makefile
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2013-09-06 16:25:17 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2013-09-06 16:25:17 +0000
commitfe982d33133116fc879ae92e25f75661b8de130c (patch)
treefe1404cdb890fa25cc9542115ad5723618a0a9d7 /devel/awscli/Makefile
parent105458b76d64bae3f58af03d339650a01f51afa2 (diff)
Notes
Diffstat (limited to 'devel/awscli/Makefile')
-rw-r--r--devel/awscli/Makefile23
1 files changed, 15 insertions, 8 deletions
diff --git a/devel/awscli/Makefile b/devel/awscli/Makefile
index aab6d68081ca..c8a1ee5ecd52 100644
--- a/devel/awscli/Makefile
+++ b/devel/awscli/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= awscli
-PORTVERSION= 0.5.1
+PORTVERSION= 1.0.0
CATEGORIES= devel
MASTER_SITES= CHEESESHOP
MASTER_SITE_SUBDIR=source/a/awscli
@@ -11,14 +11,21 @@ MAINTAINER= alexey@renatasystems.org
COMMENT= Universal Command Line Interface for Amazon Web Services
LICENSE= AL2
-LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}botocore>=0.5.0:${PORTSDIR}/devel/py-botocore \
- ${PYTHON_PKGNAMEPREFIX}six>=1.1.0:${PORTSDIR}/devel/py-six \
- ${PYTHON_PKGNAMEPREFIX}sphinx>=1.1.3:${PORTSDIR}/textproc/py-sphinx \
- ${PYTHON_PKGNAMEPREFIX}tox>=1.4:${PORTSDIR}/devel/py-tox
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}bcdoc>=0.9.0:${PORTSDIR}/devel/py-bcdoc \
+ ${PYTHON_PKGNAMEPREFIX}botocore>=0.16:${PORTSDIR}/devel/py-botocore \
+ ${PYTHON_PKGNAMEPREFIX}colorama>=0.2.5:${PORTSDIR}/devel/py-colorama \
+ ${PYTHON_PKGNAMEPREFIX}docutils>=0.10:${PORTSDIR}/textproc/py-docutils \
+ ${PYTHON_PKGNAMEPREFIX}rsa>=3.1.1:${PORTSDIR}/security/py-rsa \
+ ${PYTHON_PKGNAMEPREFIX}six>=1.1.0:${PORTSDIR}/devel/py-six
-USE_PYTHON= 2.6+
+USE_PYTHON= yes
USE_PYDISTUTILS=easy_install
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 270
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}argparse>0:${PORTSDIR}/devel/py-argparse
+.endif
+
+.include <bsd.port.post.mk>