aboutsummaryrefslogtreecommitdiff
path: root/devel/bcc/scripts
diff options
context:
space:
mode:
authorJoerg Wunsch <joerg@FreeBSD.org>1995-03-26 18:08:54 +0000
committerJoerg Wunsch <joerg@FreeBSD.org>1995-03-26 18:08:54 +0000
commitb7e5135427a367cd295ea5c906fe73e03739bd8c (patch)
tree415f56ef122a21da430192d1bad2f6077c27f3b7 /devel/bcc/scripts
parent97a7300b6b87b7ecfcb84343389eb45cc41ccb5b (diff)
Notes
Diffstat (limited to 'devel/bcc/scripts')
-rw-r--r--devel/bcc/scripts/configure49
1 files changed, 49 insertions, 0 deletions
diff --git a/devel/bcc/scripts/configure b/devel/bcc/scripts/configure
new file mode 100644
index 000000000000..8e3c5cfaa798
--- /dev/null
+++ b/devel/bcc/scripts/configure
@@ -0,0 +1,49 @@
+#!/bin/sh
+#
+# $Id$
+#
+# Author: Jörg Wunsch <joerg@FreeBSD.org>
+# Date of creation: Mar 26, 1995
+#
+
+# we don't need Bruce's symlink, since bmake knows about .PATH
+
+rm -f ${WRKSRC}/as/typeconv.o
+
+# since we like the ease of BSD's fancy .include <> files, we wish to
+# have an own directory for the compiler driver
+
+mv ${WRKSRC}/bcc ${WRKSRC}/bcc-cc1
+mkdir ${WRKSRC}/bcc
+cp -p ${FILESDIR}/Makefile.bcc ${WRKSRC}/bcc/Makefile
+
+# i wrote some man pages after Bruce's bcc.doc
+cp -p ${FILESDIR}/ld86.1 ${WRKSRC}/ld/
+cp -p ${FILESDIR}/as86.1 ${WRKSRC}/as/
+cp -p ${FILESDIR}/bcc.1 ${WRKSRC}/bcc/
+cp -p ${FILESDIR}/bcc-cc1.1 ${WRKSRC}/bcc-cc1/
+
+# create a Makefile.inc to pass the local prefix down to
+# the build stage:
+
+cat > ${WRKSRC}/Makefile.inc <<*EOF*
+#
+# Makefile.inc
+#
+# This file has been created by the "configure" script; DO NOT EDIT.
+#
+# Edit the port's Makefile \${PREFIX} variable should you wish to
+# override this, and reconfigure.
+#
+
+LOCALPREFIX = ${PREFIX}
+*EOF*
+
+# a simple Makefile to make all the subdirs
+
+cat > ${WRKSRC}/Makefile <<*EOF*
+
+SUBDIR = ld as bcc-cc1 bcc
+
+.include <bsd.subdir.mk>
+*EOF*