aboutsummaryrefslogtreecommitdiff
path: root/devel/beautifyphp/Makefile
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2005-09-13 06:49:45 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2005-09-13 06:49:45 +0000
commitc31d0a7d13c327324f69cc98ffe33f0e3a5ccd6e (patch)
treecfba7e917114652619bc051a513647dde9ac0ccd /devel/beautifyphp/Makefile
parent520417df28a4c553170e8c143b63300bc7293e5b (diff)
downloadports-c31d0a7d13c327324f69cc98ffe33f0e3a5ccd6e.tar.gz
ports-c31d0a7d13c327324f69cc98ffe33f0e3a5ccd6e.zip
Notes
Diffstat (limited to 'devel/beautifyphp/Makefile')
-rw-r--r--devel/beautifyphp/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/devel/beautifyphp/Makefile b/devel/beautifyphp/Makefile
new file mode 100644
index 000000000000..31cec47bae6f
--- /dev/null
+++ b/devel/beautifyphp/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: beautifyphp
+# Date created: 03 August 2005
+# Whom: Yen-Ming Lee <leeym@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= beautifyphp
+PORTVERSION= 0.5.0
+CATEGORIES= devel www pear
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= beautify_php_${PORTVERSION}
+
+MAINTAINER= leeym@FreeBSD.org
+COMMENT= PEAR beautifier for PHP4
+
+RUN_DEPENDS= ${LOCALBASE}/share/pear/System.php:${PORTSDIR}/devel/pear-PEAR
+
+USE_REINPLACE= yes
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+PLIST_FILES= bin/beautify_php share/${PORTNAME}/beautify_php.php \
+ share/pear/beautify_php.class.inc
+PLIST_DIRS= share/${PORTNAME}
+
+post-patch:
+ @${REINPLACE_CMD} 's,/usr/bin/php,${LOCALBASE}/bin/php,g' ${WRKSRC}/beautify_php
+ @${FIND} ${WRKSRC} -name "*.bak" -or -name "*.orig" -delete
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/beautify_php ${PREFIX}/bin
+ @${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/beautify_php.php ${DATADIR}
+ @${MKDIR} ${PREFIX}/share/pear
+ ${INSTALL_DATA} ${WRKSRC}/beautify_php.class.inc ${PREFIX}/share/pear
+
+.include <bsd.port.mk>