aboutsummaryrefslogtreecommitdiff
path: root/devel/beautifyphp
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2005-09-13 06:49:45 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2005-09-13 06:49:45 +0000
commitc31d0a7d13c327324f69cc98ffe33f0e3a5ccd6e (patch)
treecfba7e917114652619bc051a513647dde9ac0ccd /devel/beautifyphp
parent520417df28a4c553170e8c143b63300bc7293e5b (diff)
downloadports-c31d0a7d13c327324f69cc98ffe33f0e3a5ccd6e.tar.gz
ports-c31d0a7d13c327324f69cc98ffe33f0e3a5ccd6e.zip
Notes
Diffstat (limited to 'devel/beautifyphp')
-rw-r--r--devel/beautifyphp/Makefile39
-rw-r--r--devel/beautifyphp/distinfo2
-rw-r--r--devel/beautifyphp/files/patch-beautify_php10
-rw-r--r--devel/beautifyphp/pkg-descr24
4 files changed, 75 insertions, 0 deletions
diff --git a/devel/beautifyphp/Makefile b/devel/beautifyphp/Makefile
new file mode 100644
index 000000000000..31cec47bae6f
--- /dev/null
+++ b/devel/beautifyphp/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: beautifyphp
+# Date created: 03 August 2005
+# Whom: Yen-Ming Lee <leeym@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= beautifyphp
+PORTVERSION= 0.5.0
+CATEGORIES= devel www pear
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= beautify_php_${PORTVERSION}
+
+MAINTAINER= leeym@FreeBSD.org
+COMMENT= PEAR beautifier for PHP4
+
+RUN_DEPENDS= ${LOCALBASE}/share/pear/System.php:${PORTSDIR}/devel/pear-PEAR
+
+USE_REINPLACE= yes
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+PLIST_FILES= bin/beautify_php share/${PORTNAME}/beautify_php.php \
+ share/pear/beautify_php.class.inc
+PLIST_DIRS= share/${PORTNAME}
+
+post-patch:
+ @${REINPLACE_CMD} 's,/usr/bin/php,${LOCALBASE}/bin/php,g' ${WRKSRC}/beautify_php
+ @${FIND} ${WRKSRC} -name "*.bak" -or -name "*.orig" -delete
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/beautify_php ${PREFIX}/bin
+ @${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/beautify_php.php ${DATADIR}
+ @${MKDIR} ${PREFIX}/share/pear
+ ${INSTALL_DATA} ${WRKSRC}/beautify_php.class.inc ${PREFIX}/share/pear
+
+.include <bsd.port.mk>
diff --git a/devel/beautifyphp/distinfo b/devel/beautifyphp/distinfo
new file mode 100644
index 000000000000..8c454ed1f55f
--- /dev/null
+++ b/devel/beautifyphp/distinfo
@@ -0,0 +1,2 @@
+MD5 (beautify_php_0.5.0.tar.gz) = 44b59836e3020b4f8fe2d8358c9e89fd
+SIZE (beautify_php_0.5.0.tar.gz) = 30759
diff --git a/devel/beautifyphp/files/patch-beautify_php b/devel/beautifyphp/files/patch-beautify_php
new file mode 100644
index 000000000000..ad10aabbcd88
--- /dev/null
+++ b/devel/beautifyphp/files/patch-beautify_php
@@ -0,0 +1,10 @@
+--- beautify_php.orig Thu Aug 4 02:28:56 2005
++++ beautify_php Thu Aug 4 02:29:09 2005
+@@ -3,6 +3,7 @@
+ /**
+ * Console script to use Beautify PHP from the command line
+ */
++ ini_set('include_path', '/usr/local/share/pear:/usr/local/share/pear/bootstrap');
+ /**
+ * Require PEAR Class
+ */
diff --git a/devel/beautifyphp/pkg-descr b/devel/beautifyphp/pkg-descr
new file mode 100644
index 000000000000..e88849f5f6c3
--- /dev/null
+++ b/devel/beautifyphp/pkg-descr
@@ -0,0 +1,24 @@
+Beautify PHP
+WWW: http://www.bierkandt.org/beautify/index.php
+
+What it does:
+This program tries to reformat and beautify PHP source code files automatically.
+The program is Open Source and distributed under the terms of GNU GPL.
+It is written in PHP and has a web frontend.
+
+Who needs it:
+- people, who get PHP code from other coders and are slightly confused
+- people, who can't read their own PHP code anymore
+- people, who want to share their PHP code
+
+Basic features:
+- automatic indentation of PHP source code according to given number of spaces
+- automatic newlines, if required
+- includes settings for braces according to C or PEAR style
+- can make use of PHPs integrated code highlight option
+- can limit number of chars per line. This will break the code at a space and
+ outputs the rest on the next line with an additional indent. (I used this to
+ reformat my code to put it in a LATEX document. This PHP code normally can't
+ be executed anymore, it is only useful for printout.)
+- turn off and on beautifying by inserting "// NO_BEAUTIFY" or "// BEAUTIFY"
+ in source code