aboutsummaryrefslogtreecommitdiff
path: root/devel/bennugd-modules
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
commit2b74a89bc8342f0b9b737c37d87737caf7b0ea1e (patch)
treec04604583d8be53b3ed7f10975be828c731f87cb /devel/bennugd-modules
parent24315159daa0089f08acea4ba1b130fb6721ad5c (diff)
downloadports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.tar.gz
ports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.zip
Notes
Diffstat (limited to 'devel/bennugd-modules')
-rw-r--r--devel/bennugd-modules/Makefile6
-rw-r--r--devel/bennugd-modules/files/patch-mod_map-file_png.c37
2 files changed, 40 insertions, 3 deletions
diff --git a/devel/bennugd-modules/Makefile b/devel/bennugd-modules/Makefile
index 29f45b9bb0a4..4374d735e1e2 100644
--- a/devel/bennugd-modules/Makefile
+++ b/devel/bennugd-modules/Makefile
@@ -7,7 +7,7 @@
PORTNAME= modules
PORTVERSION= r20091106
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= devel games
MASTER_SITES= http://mirror.amdmi3.ru/distfiles/
PKGNAMEPREFIX= bennugd-
@@ -18,11 +18,11 @@ COMMENT= High level open source game development suite, modules
BUILD_DEPENDS= ${LOCALBASE}/lib/libbgdrtm.so:${PORTSDIR}/devel/bennugd-core
RUN_DEPENDS= ${LOCALBASE}/lib/libbgdrtm.so:${PORTSDIR}/devel/bennugd-core
-LIB_DEPENDS= png.6:${PORTSDIR}/graphics/png
+LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
USE_SDL= sdl mixer
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
+CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libpng15
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
CONFIGURE_ARGS= --libdir="${PREFIX}/lib/bennugd"
MAKE_JOBS_SAFE= yes
diff --git a/devel/bennugd-modules/files/patch-mod_map-file_png.c b/devel/bennugd-modules/files/patch-mod_map-file_png.c
new file mode 100644
index 000000000000..5479d7cbdd10
--- /dev/null
+++ b/devel/bennugd-modules/files/patch-mod_map-file_png.c
@@ -0,0 +1,37 @@
+--- mod_map/file_png.c.orig 2009-07-22 04:02:45.000000000 +0200
++++ mod_map/file_png.c 2012-05-27 11:54:18.000000000 +0200
+@@ -24,6 +24,7 @@
+ /* --------------------------------------------------------------------------- */
+
+ #include <png.h>
++#include <pngpriv.h>
+
+ #include "mod_map.h"
+
+@@ -89,7 +90,7 @@
+
+ /* Rutina de error */
+
+- if ( setjmp( png_ptr->jmpbuf ) )
++ if ( setjmp( png_jmpbuf(png_ptr) ) )
+ {
+ png_destroy_read_struct( &png_ptr, &info_ptr, &end_info ) ;
+ file_close( png ) ;
+@@ -286,7 +287,7 @@
+
+ /* Fin */
+
+- if ( !setjmp( png_ptr->jmpbuf ) ) png_read_end( png_ptr, 0 ) ;
++ if ( !setjmp( png_jmpbuf(png_ptr) ) ) png_read_end( png_ptr, 0 ) ;
+
+ bitmap->modified = 1 ;
+
+@@ -356,7 +357,7 @@
+
+ /* Error handling... */
+
+- if ( setjmp( png_ptr->jmpbuf ) )
++ if ( setjmp( png_jmpbuf(png_ptr) ) )
+ {
+ png_destroy_write_struct( &png_ptr, NULL ) ;
+ free( rowpointers ) ;