aboutsummaryrefslogtreecommitdiff
path: root/devel/bicyclerepair/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-04-29 02:54:24 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-04-29 02:54:24 +0000
commit74c295684b98b2de25374476f0effd133a87a272 (patch)
treedfa07dbeecd36c10e53f02aee7a8c10f4f8b8339 /devel/bicyclerepair/Makefile
parent9eccd986c640e8bce06aa543d253c74e2445ff3f (diff)
Notes
Diffstat (limited to 'devel/bicyclerepair/Makefile')
-rw-r--r--devel/bicyclerepair/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/devel/bicyclerepair/Makefile b/devel/bicyclerepair/Makefile
new file mode 100644
index 000000000000..cb46a5046cd1
--- /dev/null
+++ b/devel/bicyclerepair/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: cuecat
+# Date created: 18 October 2000
+# Whom: mwm@mired.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= bicyclerepair
+PORTVERSION= 0.7.1
+CATEGORIES= devel python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR=${PORTNAME}
+
+MAINTAINER= mwm@mired.org
+COMMENT= A python refactoring tool
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+USE_PYTHON_PREFIX=yes
+
+DOCDIR= ${PYTHONBASE}/share/bicyclerepairman
+
+PYVERSION= ${PYTHON_VERSION:S/^python//}
+.if defined(PYTHON_VERSION) && ${PYVERSION:S/.//} < 22
+.undef NO_IGNORE
+BROKEN= This port requires python 2.2 or later
+.endif # defined(PYVERSION) && ${PYVERSION:S/.//} < 22
+
+post-install:
+ @${RM} ${PYTHONBASE}/bin/bikeemacs.bat
+ @${MKDIR} ${DOCDIR}
+ ${INSTALL_DATA} ${WRKSRC}/ide-integration/bike.el ${DOCDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.emacs ${DOCDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.idle ${DOCDIR}
+ @${ECHO} "================================================================"
+ @${ECHO} "* See" ${DOCDIR} "for instructions on configuring IDLE"
+ @${ECHO} "* and emacs to use Bicycle Repair Man."
+ @${ECHO} "================================================================"
+
+.include <bsd.port.mk>