aboutsummaryrefslogtreecommitdiff
path: root/devel/bin86
diff options
context:
space:
mode:
authorShaun Amott <shaun@FreeBSD.org>2008-11-14 18:50:29 +0000
committerShaun Amott <shaun@FreeBSD.org>2008-11-14 18:50:29 +0000
commit77f7bf224847cc6bdfc70031daba4744084f695a (patch)
tree9eaa96d394336e1280f1cfb5a07305dd12fed197 /devel/bin86
parent4da406c0b1f0f6af10f1edc598d4b6fab752308c (diff)
downloadports-77f7bf224847cc6bdfc70031daba4744084f695a.tar.gz
ports-77f7bf224847cc6bdfc70031daba4744084f695a.zip
Notes
Diffstat (limited to 'devel/bin86')
-rw-r--r--devel/bin86/Makefile2
-rw-r--r--devel/bin86/files/patch-ld_ld_c8
-rw-r--r--devel/bin86/files/patch-ld_x86_aout_h12
3 files changed, 18 insertions, 4 deletions
diff --git a/devel/bin86/Makefile b/devel/bin86/Makefile
index eaafa7f277ab..3959d7ab1d15 100644
--- a/devel/bin86/Makefile
+++ b/devel/bin86/Makefile
@@ -19,7 +19,7 @@ CONFLICTS= bcc-[0-9]* dev86-[0-9]*
PORTDOCS= ChangeLog README README-0.4
MAN1= as86.1 ld86.1
-ONLY_FOR_ARCHS= i386
+ONLY_FOR_ARCHS= i386 amd64
PLIST_FILES+= ${BINS:C/..\//bin\//g}
diff --git a/devel/bin86/files/patch-ld_ld_c b/devel/bin86/files/patch-ld_ld_c
index 0ca2fd413825..ea085687bf08 100644
--- a/devel/bin86/files/patch-ld_ld_c
+++ b/devel/bin86/files/patch-ld_ld_c
@@ -1,9 +1,11 @@
---- ld/ld.c.orig Wed Dec 30 12:20:50 1998
-+++ ld/ld.c Thu Oct 19 17:04:00 2000
-@@ -2,6 +2,7 @@
+--- ld/ld.c.orig 2004-01-21 16:17:09.000000000 -0500
++++ ld/ld.c 2008-07-14 14:56:28.000000000 -0500
+@@ -2,6 +2,9 @@
/* Copyright (C) 1994 Bruce Evans */
++#include <errno.h>
++
+#undef BUGCOMPAT
#include "syshead.h"
#include "const.h"
diff --git a/devel/bin86/files/patch-ld_x86_aout_h b/devel/bin86/files/patch-ld_x86_aout_h
new file mode 100644
index 000000000000..ebc414ea786e
--- /dev/null
+++ b/devel/bin86/files/patch-ld_x86_aout_h
@@ -0,0 +1,12 @@
+--- ld/x86_aout.h.orig 2008-07-14 15:03:10.000000000 -0500
++++ ld/x86_aout.h 2008-07-14 15:04:55.000000000 -0500
+@@ -12,6 +12,9 @@
+ #if defined(i386) || defined(__BCC__) || defined(MSDOS)
+ typedef long Long;
+ #define __OUT_OK 1
++#elif __amd64__
++typedef int Long;
++#define __OUT_OK 1
+ #else
+ typedef char Long[4];
+ #endif