aboutsummaryrefslogtreecommitdiff
path: root/devel/binutils
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2009-07-08 19:55:29 +0000
committerMartin Matuska <mm@FreeBSD.org>2009-07-08 19:55:29 +0000
commit386396310c0f0f046cb70c8e85e7fe6751c401c3 (patch)
tree85bc5ab1f073cb9a71a03ca2ebeab6f1a8632980 /devel/binutils
parent163af6a3e3b3763615612350b228b85db23c147a (diff)
downloadports-386396310c0f0f046cb70c8e85e7fe6751c401c3.tar.gz
ports-386396310c0f0f046cb70c8e85e7fe6751c401c3.zip
Notes
Diffstat (limited to 'devel/binutils')
-rw-r--r--devel/binutils/Makefile77
-rw-r--r--devel/binutils/distinfo3
-rw-r--r--devel/binutils/pkg-descr15
-rw-r--r--devel/binutils/pkg-plist93
4 files changed, 188 insertions, 0 deletions
diff --git a/devel/binutils/Makefile b/devel/binutils/Makefile
new file mode 100644
index 000000000000..8d4372dfcd25
--- /dev/null
+++ b/devel/binutils/Makefile
@@ -0,0 +1,77 @@
+# New ports collection makefile for: binutils
+# Date created: 9 July 2009
+# Whom: Martin Matuska <mm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= binutils
+PORTVERSION= 2.19.1
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEWARE}
+MASTER_SITE_SUBDIR= binutils/releases
+
+MAINTAINER= mm@FreeBSD.org
+COMMENT= GNU binary tools
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libgmp.so:${PORTSDIR}/math/libgmp4 \
+ ${LOCALBASE}/lib/libmpfr.so:${PORTSDIR}/math/mpfr
+
+CFLAGS+= -I${LOCALBASE}/include
+CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS+= --with-system-zlib \
+ --with-gmp=${LOCALBASE} \
+ --with-mpfr=${LOCALBASE}
+
+MAN1= addr2line.1 \
+ ar.1 \
+ as.1 \
+ c++filt.1 \
+ gprof.1 \
+ dlltool.1 \
+ ld.1 \
+ nlmconv.1 \
+ nm.1 \
+ objcopy.1 \
+ objdump.1 \
+ ranlib.1 \
+ readelf.1 \
+ size.1 \
+ strings.1 \
+ strip.1 \
+ windmc.1 \
+ windres.1
+
+INFO= as \
+ binutils \
+ standards \
+ gprof \
+ bfd \
+ configure \
+ ld
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment"
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64"
+ARCH= x86_64
+.endif
+
+post-install:
+ @${FIND} -ds ${PREFIX}/${CONFIGURE_TARGET} ! -type d | \
+ ${SED} -e 's,^${PREFIX}/,,' >> ${TMPPLIST}
+ @${FIND} -ds ${PREFIX}/${CONFIGURE_TARGET} -type d | \
+ ${SED} -e 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
+
+.include <bsd.port.post.mk>
diff --git a/devel/binutils/distinfo b/devel/binutils/distinfo
new file mode 100644
index 000000000000..14cb77acb514
--- /dev/null
+++ b/devel/binutils/distinfo
@@ -0,0 +1,3 @@
+MD5 (binutils-2.19.1.tar.bz2) = 09a8c5821a2dfdbb20665bc0bd680791
+SHA256 (binutils-2.19.1.tar.bz2) = 3e8225b4d7ace0a2039de752e11fd6922d3b89a7259a292c347391c4788739f6
+SIZE (binutils-2.19.1.tar.bz2) = 16245771
diff --git a/devel/binutils/pkg-descr b/devel/binutils/pkg-descr
new file mode 100644
index 000000000000..90c282e9ccbf
--- /dev/null
+++ b/devel/binutils/pkg-descr
@@ -0,0 +1,15 @@
+The GNU Binutils are a collection of binary tools. The main ones are:
+
+* ld - the GNU linker.
+* as - the GNU assembler.
+
+Most of these programs use BFD, the Binary File Descriptor library, to do
+low-level manipulation. Many of them also use the opcodes library to assemble
+and disassemble machine instructions.
+
+This port may be used as a replacement for the system binutils and support
+features from the latest versions of GCC.
+
+For cross-compilation, see the devel/cross-binutils port.
+
+WWW: http://sources.redhat.com/binutils/
diff --git a/devel/binutils/pkg-plist b/devel/binutils/pkg-plist
new file mode 100644
index 000000000000..6dd9f57718f5
--- /dev/null
+++ b/devel/binutils/pkg-plist
@@ -0,0 +1,93 @@
+bin/addr2line
+bin/ar
+bin/as
+bin/c++filt
+bin/gprof
+bin/ld
+bin/nm
+bin/objcopy
+bin/objdump
+bin/ranlib
+bin/readelf
+bin/size
+bin/strings
+bin/strip
+include/ansidecl.h
+include/bfd.h
+include/bfdlink.h
+include/dis-asm.h
+include/symcat.h
+lib/libbfd.a
+lib/libbfd.la
+lib/libiberty.a
+lib/libopcodes.a
+lib/libopcodes.la
+%%NLS%%share/locale/da/LC_MESSAGES/bfd.mo
+%%NLS%%share/locale/da/LC_MESSAGES/binutils.mo
+%%NLS%%share/locale/da/LC_MESSAGES/gprof.mo
+%%NLS%%share/locale/da/LC_MESSAGES/ld.mo
+%%NLS%%share/locale/da/LC_MESSAGES/opcodes.mo
+%%NLS%%share/locale/de/LC_MESSAGES/gprof.mo
+%%NLS%%share/locale/de/LC_MESSAGES/opcodes.mo
+%%NLS%%share/locale/es/LC_MESSAGES/bfd.mo
+%%NLS%%share/locale/es/LC_MESSAGES/binutils.mo
+%%NLS%%share/locale/es/LC_MESSAGES/gas.mo
+%%NLS%%share/locale/es/LC_MESSAGES/gprof.mo
+%%NLS%%share/locale/es/LC_MESSAGES/ld.mo
+%%NLS%%share/locale/es/LC_MESSAGES/opcodes.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/bfd.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/binutils.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/gprof.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/ld.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/opcodes.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/bfd.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/binutils.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/gas.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/gprof.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/ld.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/opcodes.mo
+%%NLS%%share/locale/ga/LC_MESSAGES/gprof.mo
+%%NLS%%share/locale/ga/LC_MESSAGES/ld.mo
+%%NLS%%share/locale/ga/LC_MESSAGES/opcodes.mo
+%%NLS%%share/locale/id/LC_MESSAGES/gprof.mo
+%%NLS%%share/locale/id/LC_MESSAGES/opcodes.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/bfd.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/binutils.mo
+%%NLS%%share/locale/ms/LC_MESSAGES/gprof.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/gprof.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/opcodes.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/gprof.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/opcodes.mo
+%%NLS%%share/locale/ro/LC_MESSAGES/bfd.mo
+%%NLS%%share/locale/ro/LC_MESSAGES/binutils.mo
+%%NLS%%share/locale/ro/LC_MESSAGES/gprof.mo
+%%NLS%%share/locale/ro/LC_MESSAGES/opcodes.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/binutils.mo
+%%NLS%%share/locale/rw/LC_MESSAGES/bfd.mo
+%%NLS%%share/locale/rw/LC_MESSAGES/binutils.mo
+%%NLS%%share/locale/rw/LC_MESSAGES/gas.mo
+%%NLS%%share/locale/rw/LC_MESSAGES/gprof.mo
+%%NLS%%share/locale/sk/LC_MESSAGES/binutils.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/bfd.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/binutils.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/gprof.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/ld.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/opcodes.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/bfd.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/binutils.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/gas.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/gprof.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/ld.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/opcodes.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/binutils.mo
+%%NLS%%share/locale/vi/LC_MESSAGES/bfd.mo
+%%NLS%%share/locale/vi/LC_MESSAGES/binutils.mo
+%%NLS%%share/locale/vi/LC_MESSAGES/gprof.mo
+%%NLS%%share/locale/vi/LC_MESSAGES/ld.mo
+%%NLS%%share/locale/vi/LC_MESSAGES/opcodes.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/bfd.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/binutils.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/ld.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/opcodes.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/binutils.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/ld.mo