aboutsummaryrefslogtreecommitdiff
path: root/devel/bison
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2007-10-17 10:13:01 +0000
committerAde Lovett <ade@FreeBSD.org>2007-10-17 10:13:01 +0000
commitdbd39ca660cafa3d1f2acebf05c86bf17a035ff8 (patch)
tree5d14b5c3a50461b8a6096fcc383dc2181cb624b7 /devel/bison
parent74313458803db4f95050b550b038051b82c96b67 (diff)
downloadports-dbd39ca660cafa3d1f2acebf05c86bf17a035ff8.tar.gz
ports-dbd39ca660cafa3d1f2acebf05c86bf17a035ff8.zip
Notes
Diffstat (limited to 'devel/bison')
-rw-r--r--devel/bison/Makefile31
-rw-r--r--devel/bison/distinfo6
-rw-r--r--devel/bison/pkg-plist57
3 files changed, 78 insertions, 16 deletions
diff --git a/devel/bison/Makefile b/devel/bison/Makefile
index 3e1ab006463a..892388d48c68 100644
--- a/devel/bison/Makefile
+++ b/devel/bison/Makefile
@@ -6,9 +6,8 @@
#
PORTNAME= bison
-PORTVERSION= 1.75
-PORTREVISION= 2
-PORTEPOCH= 1
+PORTVERSION= 2.3
+PORTREVISION= 3
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -19,20 +18,18 @@ COMMENT= A parser generator from FSF, (mostly) compatible with Yacc
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
RUN_DEPENDS= gm4:${PORTSDIR}/devel/m4
-CONFLICTS= bison-1.8[0-9]* bison-2.[0-9]*
-
USE_BZIP2= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib" \
- MAKEINFO="makeinfo --no-split"
+ LDFLAGS="-L${LOCALBASE}/lib"
MAN1= bison.1
INFO= bison
+CONFIGURE_ARGS+=--disable-yacc
.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+= --disable-nls
+CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.else
USE_GETTEXT= yes
@@ -43,7 +40,23 @@ PLIST_SUB+= NLS=""
.error You have `USE_BISON' variable defined either in environment or in make(1) arguments. Please undefine and try again.
.endif
+.include <bsd.port.pre.mk>
+
post-extract:
@${RM} -f ${WRKSRC}/doc/bison.info*
-.include <bsd.port.mk>
+#
+# Requires texinfo 4.8 or above
+#
+.if ${OSVERSION} < 601000
+ @${REINPLACE_CMD} "/^@headitem/d" ${WRKSRC}/doc/bison.texinfo
+.endif
+
+.if !defined(NOPORTDOCS)
+post-install:
+ ${MKDIR} ${EXAMPLESDIR}/calc++
+ ${INSTALL_DATA} ${WRKSRC}/examples/calc++/*.[chly]* \
+ ${EXAMPLESDIR}/calc++
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/bison/distinfo b/devel/bison/distinfo
index 609880e11758..3278ac334b57 100644
--- a/devel/bison/distinfo
+++ b/devel/bison/distinfo
@@ -1,3 +1,3 @@
-MD5 (bison-1.75.tar.bz2) = dd88fe42e35d554c00af430a9342456a
-SHA256 (bison-1.75.tar.bz2) = dcdf92c9d847798366f31633e8a58ffd4b4e60c94a36bdc343eef81275e0182a
-SIZE (bison-1.75.tar.bz2) = 773106
+MD5 (bison-2.3.tar.bz2) = c18640c6ec31a169d351e3117ecce3ec
+SHA256 (bison-2.3.tar.bz2) = b10d7e9e354be72aee4e4911cf19dd27b5c527d4e7200857365b5fcdeea0dffb
+SIZE (bison-2.3.tar.bz2) = 1080319
diff --git a/devel/bison/pkg-plist b/devel/bison/pkg-plist
index f1d3f5a225f8..87d19fca0dd0 100644
--- a/devel/bison/pkg-plist
+++ b/devel/bison/pkg-plist
@@ -1,23 +1,72 @@
-@comment $FreeBSD$
bin/bison
+share/aclocal/bison-i18n.m4
+%%DATADIR%%/README
+%%DATADIR%%/c++.m4
%%DATADIR%%/c.m4
%%DATADIR%%/glr.c
+%%DATADIR%%/glr.cc
%%DATADIR%%/lalr1.cc
+%%DATADIR%%/location.cc
%%DATADIR%%/m4sugar/m4sugar.m4
-%%DATADIR%%/m4sugar/version.m4
%%DATADIR%%/yacc.c
+%%PORTDOCS%%%%EXAMPLESDIR%%/calc++/calc++-driver.cc
+%%PORTDOCS%%%%EXAMPLESDIR%%/calc++/calc++-driver.hh
+%%PORTDOCS%%%%EXAMPLESDIR%%/calc++/calc++-parser.cc
+%%PORTDOCS%%%%EXAMPLESDIR%%/calc++/calc++-parser.hh
+%%PORTDOCS%%%%EXAMPLESDIR%%/calc++/calc++-parser.yy
+%%PORTDOCS%%%%EXAMPLESDIR%%/calc++/calc++-scanner.cc
+%%PORTDOCS%%%%EXAMPLESDIR%%/calc++/calc++-scanner.ll
+%%PORTDOCS%%%%EXAMPLESDIR%%/calc++/calc++.cc
+%%PORTDOCS%%%%EXAMPLESDIR%%/calc++/location.hh
+%%PORTDOCS%%%%EXAMPLESDIR%%/calc++/position.hh
+%%PORTDOCS%%%%EXAMPLESDIR%%/calc++/stack.hh
+%%NLS%%share/locale/da/LC_MESSAGES/bison-runtime.mo
+%%NLS%%share/locale/da/LC_MESSAGES/bison.mo
+%%NLS%%share/locale/de/LC_MESSAGES/bison-runtime.mo
%%NLS%%share/locale/de/LC_MESSAGES/bison.mo
+%%NLS%%share/locale/es/LC_MESSAGES/bison-runtime.mo
%%NLS%%share/locale/es/LC_MESSAGES/bison.mo
+%%NLS%%share/locale/et/LC_MESSAGES/bison-runtime.mo
%%NLS%%share/locale/et/LC_MESSAGES/bison.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/bison-runtime.mo
%%NLS%%share/locale/fr/LC_MESSAGES/bison.mo
+%%NLS%%share/locale/ga/LC_MESSAGES/bison-runtime.mo
+%%NLS%%share/locale/ga/LC_MESSAGES/bison.mo
+%%NLS%%share/locale/hr/LC_MESSAGES/bison-runtime.mo
%%NLS%%share/locale/hr/LC_MESSAGES/bison.mo
+%%NLS%%share/locale/id/LC_MESSAGES/bison-runtime.mo
%%NLS%%share/locale/id/LC_MESSAGES/bison.mo
+%%NLS%%share/locale/it/LC_MESSAGES/bison-runtime.mo
%%NLS%%share/locale/it/LC_MESSAGES/bison.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/bison-runtime.mo
%%NLS%%share/locale/ja/LC_MESSAGES/bison.mo
+%%NLS%%share/locale/ms/LC_MESSAGES/bison-runtime.mo
+%%NLS%%share/locale/ms/LC_MESSAGES/bison.mo
+%%NLS%%share/locale/nb/LC_MESSAGES/bison-runtime.mo
+%%NLS%%share/locale/nb/LC_MESSAGES/bison.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/bison-runtime.mo
%%NLS%%share/locale/nl/LC_MESSAGES/bison.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/bison-runtime.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/bison.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/bison-runtime.mo
%%NLS%%share/locale/pt_BR/LC_MESSAGES/bison.mo
+%%NLS%%share/locale/ro/LC_MESSAGES/bison-runtime.mo
+%%NLS%%share/locale/ro/LC_MESSAGES/bison.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/bison-runtime.mo
%%NLS%%share/locale/ru/LC_MESSAGES/bison.mo
+%%NLS%%share/locale/rw/LC_MESSAGES/bison-runtime.mo
+%%NLS%%share/locale/rw/LC_MESSAGES/bison.mo
+%%NLS%%share/locale/sl/LC_MESSAGES/bison-runtime.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/bison-runtime.mo
%%NLS%%share/locale/sv/LC_MESSAGES/bison.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/bison-runtime.mo
%%NLS%%share/locale/tr/LC_MESSAGES/bison.mo
-@dirrm %%DATADIR%%/m4sugar
-@dirrm %%DATADIR%%
+%%NLS%%share/locale/vi/LC_MESSAGES/bison-runtime.mo
+%%NLS%%share/locale/vi/LC_MESSAGES/bison.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/bison-runtime.mo
+%%NLS%%@dirrmtry share/locale/rw/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/rw
+%%PORTDOCS%%@dirrmtry %%EXAMPLESDIR%%/calc++
+%%PORTDOCS%%@dirrmtry %%EXAMPLESDIR%%
+@dirrmtry %%DATADIR%%/m4sugar
+@dirrmtry %%DATADIR%%