aboutsummaryrefslogtreecommitdiff
path: root/devel/bisoncpp
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2011-11-15 21:18:34 +0000
committerGabor Pali <pgj@FreeBSD.org>2011-11-15 21:18:34 +0000
commit8306981b7a7d109e4d59662a88044a4dd885bb35 (patch)
tree7d9e1005f9f7af0045decccc786de08debc69917 /devel/bisoncpp
parent4f8962ecd295b77cd8b0a3b5ee1dc7a1ca47d0ed (diff)
downloadports-8306981b7a7d109e4d59662a88044a4dd885bb35.tar.gz
ports-8306981b7a7d109e4d59662a88044a4dd885bb35.zip
Notes
Diffstat (limited to 'devel/bisoncpp')
-rw-r--r--devel/bisoncpp/Makefile11
-rw-r--r--devel/bisoncpp/distinfo4
-rw-r--r--devel/bisoncpp/files/patch-icmake-install4
-rw-r--r--devel/bisoncpp/files/patch-icmake-library16
4 files changed, 17 insertions, 18 deletions
diff --git a/devel/bisoncpp/Makefile b/devel/bisoncpp/Makefile
index 57d1b9a8fb37..5e9fcbea6c9c 100644
--- a/devel/bisoncpp/Makefile
+++ b/devel/bisoncpp/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= bisoncpp
-PORTVERSION= 2.9.1
+PORTVERSION= 2.09.03
CATEGORIES= devel
MASTER_SITES= SF/${PORTNAME}/bisonc%2B%2B/${PORTVERSION}
DISTNAME= bisonc++_${PORTVERSION}
@@ -15,10 +15,11 @@ EXTRACT_SUFX= .orig.tar.gz
MAINTAINER= pgj@FreeBSD.org
COMMENT= LALR(1) parser generator that generates C++ classes
+LICENSE= GPLv3
+
BUILD_DEPENDS= icmake:${PORTSDIR}/devel/icmake \
yodl>=3.0:${PORTSDIR}/textproc/yodl \
- libbobcat>=2.09:${PORTSDIR}/devel/libbobcat \
- g++45:${PORTSDIR}/lang/gcc45
+ libbobcat>=2.18:${PORTSDIR}/devel/libbobcat
.if !defined(NO_INSTALL_MANPAGES)
MANCOMPRESSED= yes
@@ -32,12 +33,14 @@ PLIST_SUB+= PORTVERSION="${PORTVERSION}"
WRKSRC= ${WRKDIR}/bisonc++-${PORTVERSION}
+USE_GCC= 4.6
+
post-patch:
@${REINPLACE_CMD} 's|"/usr"|"${PREFIX}"| ; \
s|"/share/bisonc++"|"/share/${PORTNAME}-${PORTVERSION}"| ; \
s|"/share/doc/bisonc++"|"/share/doc/${PORTNAME}-${PORTVERSION}"| ; \
s|"/share/man/man1"|"/man/man1"| ; \
- s|"g++-4.5"|"g++45"|' \
+ s|"g++"|"g++46"|' \
${WRKSRC}/INSTALL.im
@${REINPLACE_CMD} 's|#!/usr/bin/icmake|#!${LOCALBASE}/bin/icmake|' \
${WRKSRC}/build \
diff --git a/devel/bisoncpp/distinfo b/devel/bisoncpp/distinfo
index 4012d69e3118..93ef579e3012 100644
--- a/devel/bisoncpp/distinfo
+++ b/devel/bisoncpp/distinfo
@@ -1,2 +1,2 @@
-SHA256 (bisonc++_2.9.1.orig.tar.gz) = 74ce64bbdd816477a2f6428e079eba522f533b229ba9b0dc68691a918ce40665
-SIZE (bisonc++_2.9.1.orig.tar.gz) = 634437
+SHA256 (bisonc++_2.09.03.orig.tar.gz) = f0d303085ddbc1948002950fa5d9c017fe81a0c4e77376ecd06446b7005edd9a
+SIZE (bisonc++_2.09.03.orig.tar.gz) = 628683
diff --git a/devel/bisoncpp/files/patch-icmake-install b/devel/bisoncpp/files/patch-icmake-install
index c03b033c522c..4868b4d6f15f 100644
--- a/devel/bisoncpp/files/patch-icmake-install
+++ b/devel/bisoncpp/files/patch-icmake-install
@@ -1,5 +1,5 @@
---- icmake/install.orig 2009-07-07 16:12:30.000000000 +0200
-+++ icmake/install 2009-11-02 13:23:44.000000000 +0100
+--- icmake/install.orig 2010-03-08 20:11:17.000000000 +0100
++++ icmake/install 2011-11-15 14:32:41.000000000 +0100
@@ -12,10 +12,6 @@
printf(" installing the skeleton files\n");
md(where + SKEL);
diff --git a/devel/bisoncpp/files/patch-icmake-library b/devel/bisoncpp/files/patch-icmake-library
index af2f43f9ab53..c955c23e987e 100644
--- a/devel/bisoncpp/files/patch-icmake-library
+++ b/devel/bisoncpp/files/patch-icmake-library
@@ -1,20 +1,16 @@
---- icmake/library.orig 2007-11-13 14:48:17.000000000 +0100
-+++ icmake/library 2009-03-06 10:26:55.000000000 +0100
-@@ -120,6 +120,7 @@
+--- icmake/library.orig 2011-06-24 21:19:38.000000000 +0200
++++ icmake/library 2011-11-14 20:54:40.000000000 +0100
+@@ -151,11 +151,13 @@
int idx;
string compiler;
string file;
+ string objDir;
- compiler = COMPILER;
-
-@@ -128,8 +129,9 @@
- #endif
-
- compiler += " -c -o " + srcDir + "/o/" + (string)prefix;
-+ objDir = srcDir + "/o";
+ compiler = COMPILER + " -Wall --std=c++0x -c -o " +
+ srcDir + "/o/" + (string)prefix;
- md(srcDir + "/o");
++ objDir = srcDir + "/o";
+ md(objDir);
for (idx = sizeof(cfiles); idx--; )