aboutsummaryrefslogtreecommitdiff
path: root/devel/bisoncpp
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-04-06 05:49:34 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-04-06 05:49:34 +0000
commit32e4bb8eac7a7fbe4b4a4d7b888ac75dc4e881d1 (patch)
tree057ddd0e03386ad848ce61c37a58cd33ae60f81c /devel/bisoncpp
parent13b0fe353c284686c2a6d6b5c627c261ef1d9f66 (diff)
downloadports-32e4bb8eac7a7fbe4b4a4d7b888ac75dc4e881d1.tar.gz
ports-32e4bb8eac7a7fbe4b4a4d7b888ac75dc4e881d1.zip
Notes
Diffstat (limited to 'devel/bisoncpp')
-rw-r--r--devel/bisoncpp/Makefile8
-rw-r--r--devel/bisoncpp/distinfo4
-rw-r--r--devel/bisoncpp/files/patch-scanner__lex.cc18
3 files changed, 14 insertions, 16 deletions
diff --git a/devel/bisoncpp/Makefile b/devel/bisoncpp/Makefile
index 0007e43dbf90..9d7398aaf46e 100644
--- a/devel/bisoncpp/Makefile
+++ b/devel/bisoncpp/Makefile
@@ -1,13 +1,13 @@
# $FreeBSD$
PORTNAME= bisoncpp
-PORTVERSION= 4.05.00
+PORTVERSION= 4.08.00
CATEGORIES= devel
MASTER_SITES= SF/${PORTNAME}/bisonc%2B%2B/${PORTVERSION}
DISTNAME= bisonc++_${PORTVERSION}
EXTRACT_SUFX= .orig.tar.gz
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= 5u623l20@gmail.com
COMMENT= LALR(1) parser generator that generates C++ classes
LICENSE= GPLv3
@@ -23,7 +23,7 @@ PLIST_SUB+= PORTVERSION="${PORTVERSION}"
WRKSRC= ${WRKDIR}/bisonc++-${PORTVERSION}
-USE_GCC= 4.7
+USE_GCC= yes
USES= shebangfix
@@ -43,8 +43,6 @@ SHEBANG_FILES= build \
parser/driver/build \
scanner/driver/build
-.include <bsd.port.options.mk>
-
post-patch:
@${REINPLACE_CMD} 's|%%PREFIX%%|${PREFIX}|g; \
s|%%PORTVERSION%%|${PORTVERSION}|g' \
diff --git a/devel/bisoncpp/distinfo b/devel/bisoncpp/distinfo
index 95438d2c478f..8ce4962d83a6 100644
--- a/devel/bisoncpp/distinfo
+++ b/devel/bisoncpp/distinfo
@@ -1,2 +1,2 @@
-SHA256 (bisonc++_4.05.00.orig.tar.gz) = 02bc8562821e21def97c107e92ef719d457856a075fa428ed41a9274d25ed3e6
-SIZE (bisonc++_4.05.00.orig.tar.gz) = 667852
+SHA256 (bisonc++_4.08.00.orig.tar.gz) = 39fd079d252867f6e2a38e2ef46d8aeb02ebf71e8d515249703d6d7c641a48b5
+SIZE (bisonc++_4.08.00.orig.tar.gz) = 667353
diff --git a/devel/bisoncpp/files/patch-scanner__lex.cc b/devel/bisoncpp/files/patch-scanner__lex.cc
index 14703f672e36..f994b2f42716 100644
--- a/devel/bisoncpp/files/patch-scanner__lex.cc
+++ b/devel/bisoncpp/files/patch-scanner__lex.cc
@@ -1,11 +1,11 @@
---- ./scanner/lex.cc.orig 2013-08-10 10:17:17.000000000 +0200
-+++ ./scanner/lex.cc 2013-11-27 19:14:33.000000000 +0100
-@@ -2836,7 +2836,7 @@
+--- scanner/lex.cc.orig 2014-04-04 14:46:17.624123806 +0600
++++ scanner/lex.cc 2014-04-04 14:46:39.301107135 +0600
+@@ -2702,7 +2702,7 @@
{
- #line 192 "lexer"
+ #line 193 "lexer"
{
-- d_number = stoul(d_matched);
-+ d_number = A2x(d_matched);
- return Parser::NUMBER;
- }
-
+- d_number = stoul(d_matched);
++ d_number = A2x(d_matched);
+ return Parser::NUMBER;
+ }
+ }