aboutsummaryrefslogtreecommitdiff
path: root/devel/boehm-gc-threaded
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-06-12 09:17:03 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-06-12 09:17:03 +0000
commit36aec2ee4d4789c8cc6ad940264e1a101d8a7977 (patch)
treefadc33ad2f29c6931b7a10a46ca3d20a561a3331 /devel/boehm-gc-threaded
parent59642d1219c0fc9ff42830b664320824c78e3a3f (diff)
downloadports-36aec2ee4d4789c8cc6ad940264e1a101d8a7977.tar.gz
ports-36aec2ee4d4789c8cc6ad940264e1a101d8a7977.zip
Notes
Diffstat (limited to 'devel/boehm-gc-threaded')
-rw-r--r--devel/boehm-gc-threaded/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/devel/boehm-gc-threaded/Makefile b/devel/boehm-gc-threaded/Makefile
index 14514f4f7cfe..d215c9c7870c 100644
--- a/devel/boehm-gc-threaded/Makefile
+++ b/devel/boehm-gc-threaded/Makefile
@@ -28,8 +28,8 @@ INSTLIBS= cord gc gccpp
GC_VARIANT= threaded
SOVER= 1
-OPTIONS= PARALLEL_MARK "Parallel-thread marking (faster for SMP)" off \
- FULLDEBUG "Debugging support (see documentation)" off
+OPTIONS_DEFINE= PARALLEL_MARK DEBUG
+PARALLEL_MARK_DESC= Parallel-thread marking (faster for SMP)
PLIST_FILES= ${INSTLIBS:S,^,lib/lib,g:S,$,-${GC_VARIANT}.so.${SOVER},g} \
${INSTLIBS:S,^,lib/lib,g:S,$,-${GC_VARIANT}.so,g} \
@@ -41,11 +41,11 @@ PLIST_FILES= ${INSTLIBS:S,^,lib/lib,g:S,$,-${GC_VARIANT}.so.${SOVER},g} \
BROKEN= Does not compile on ia64
.endif
-.if defined(WITH_PARALLEL_MARK)
+.if ${PORT_OPTIONS:MPARALLEL_MARK}
CONFIGURE_ARGS+= --enable-parallel-mark
.endif
-.if defined(WITH_FULLDEBUG)
+.if ${PORT_OPTIONS:MDEBUG}
CONFIGURE_ARGS+= --enable-gc-debug
PKGNAMESUFFIX:= ${PKGNAMESUFFIX}+fulldebug
.endif