aboutsummaryrefslogtreecommitdiff
path: root/devel/boehm-gc/Makefile
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2007-02-05 22:12:46 +0000
committerStanislav Sedov <stas@FreeBSD.org>2007-02-05 22:12:46 +0000
commita95d629b9d701507c22d4866b725fd8c67c361ce (patch)
treee7c8da554fee9b89bf8bb8a192b5596321a5327d /devel/boehm-gc/Makefile
parent589c390232f6565563c1543bd13a83482a37631b (diff)
downloadports-a95d629b9d701507c22d4866b725fd8c67c361ce.tar.gz
ports-a95d629b9d701507c22d4866b725fd8c67c361ce.zip
Notes
Diffstat (limited to 'devel/boehm-gc/Makefile')
-rw-r--r--devel/boehm-gc/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/devel/boehm-gc/Makefile b/devel/boehm-gc/Makefile
index 40777725ab40..b613c02e6cb4 100644
--- a/devel/boehm-gc/Makefile
+++ b/devel/boehm-gc/Makefile
@@ -31,10 +31,10 @@ OPTIONS= REDIRECT "Define malloc(3)-family replacements" off \
CONFIGURE_ARGS+= --enable-threads=posix --enable-thread-local-alloc
.if ${OSVERSION} < 502102
CONFIGURE_ENV= CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS}" \
- LIBS="${LIBS} -lc_r"
+ LIBS="${LIBS} ${PTHREAD_LIBS:C/-pthread/-lc_r/}"
.else
CONFIGURE_ENV= CFLAGSS="${CFLAGS} ${PTHREAD_CFLAGS}" \
- LIBS="${LIBS} -lpthread"
+ LIBS="${LIBS} ${PTHREAD_LIBS:C/-pthread/-lpthread/}"
.endif
.if defined(WITH_PARALLEL_MARK)
CONFIGURE_ARGS+= --enable-parallel-mark