aboutsummaryrefslogtreecommitdiff
path: root/devel/boehm-gc/Makefile
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2019-03-08 14:49:46 +0000
committerSteve Wills <swills@FreeBSD.org>2019-03-08 14:49:46 +0000
commit3ae5500526cf04168727aabcf60893519ef2c5be (patch)
tree39ddd7f1dda8de0a99e0d153482ab46fafe27e75 /devel/boehm-gc/Makefile
parentea86c30f2bd1544bb56937353540f14807d6d8af (diff)
downloadports-3ae5500526cf04168727aabcf60893519ef2c5be.tar.gz
ports-3ae5500526cf04168727aabcf60893519ef2c5be.zip
Notes
Diffstat (limited to 'devel/boehm-gc/Makefile')
-rw-r--r--devel/boehm-gc/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/devel/boehm-gc/Makefile b/devel/boehm-gc/Makefile
index a42ea5bfc518..004ba7fd0ed7 100644
--- a/devel/boehm-gc/Makefile
+++ b/devel/boehm-gc/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= gc
-PORTVERSION= 8.0.2
+PORTVERSION= 8.0.4
CATEGORIES= devel
MASTER_SITES= http://www.hboehm.info/gc/gc_source/ \
https://github.com/ivmai/bdwgc/releases/download/v${PORTVERSION}/
@@ -21,11 +21,12 @@ LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
BUILD_DEPENDS= ${LOCALBASE}/lib/libatomic_ops.a:devel/libatomic_ops
-GNU_CONFIGURE= yes
USES= cpe libtool pathfix pkgconfig
+USE_LDCONFIG= yes
+
CPE_VENDOR= boehm-demers-weiser
CPE_PRODUCT= garbage_collector
-USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
TEST_TARGET= check
# NOTE: do not --disable-static, static is useful for e.g. lang/crystal
@@ -49,7 +50,7 @@ PLIST_FILES= ${CORDLIBS:S,^,lib/lib,:S,$,-${GC_VARIANT}.a,} \
${GCLIBS:S,^,lib/lib,:S,$,-${GC_VARIANT}.a,} \
${GCLIBS:S,^,lib/lib,:S,$,-${GC_VARIANT}.so,} \
${GCLIBS:S,^,lib/lib,:S,$,-${GC_VARIANT}.so.1,} \
- ${GCLIBS:S,^,lib/lib,:S,$,-${GC_VARIANT}.so.1.4.2,} \
+ ${GCLIBS:S,^,lib/lib,:S,$,-${GC_VARIANT}.so.1.4.3,} \
${GCCPPLIBS:S,^,lib/lib,:S,$,-${GC_VARIANT}.a,} \
${GCCPPLIBS:S,^,lib/lib,:S,$,-${GC_VARIANT}.so,} \
${GCCPPLIBS:S,^,lib/lib,:S,$,-${GC_VARIANT}.so.1,} \