aboutsummaryrefslogtreecommitdiff
path: root/devel/boehm-gc
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1999-11-01 00:43:07 +0000
committerSteve Price <steve@FreeBSD.org>1999-11-01 00:43:07 +0000
commit13bf4e0156c95c73099d71e81b0c06864f7cc067 (patch)
treee7a311dff65b2e6f14d37703c3bf8af18958bd20 /devel/boehm-gc
parent615932e68664de2677180c9b9da8acb1f98ac87d (diff)
downloadports-13bf4e0156c95c73099d71e81b0c06864f7cc067.tar.gz
ports-13bf4e0156c95c73099d71e81b0c06864f7cc067.zip
Notes
Diffstat (limited to 'devel/boehm-gc')
-rw-r--r--devel/boehm-gc/Makefile9
-rw-r--r--devel/boehm-gc/distinfo2
-rw-r--r--devel/boehm-gc/files/patch-aa47
3 files changed, 39 insertions, 19 deletions
diff --git a/devel/boehm-gc/Makefile b/devel/boehm-gc/Makefile
index 123fc6c33dab..feb116763872 100644
--- a/devel/boehm-gc/Makefile
+++ b/devel/boehm-gc/Makefile
@@ -1,15 +1,16 @@
# New ports collection makefile for: boehm-gc
-# Version required: 4.10
+# Version required: 5.0alpha3
# Date created: 15 November 1996
# Whom: Mike McGaughey <mmcg@cs.monash.edu.au>
#
# $FreeBSD$
#
-DISTNAME= gc4.14
-PKGNAME= boehm-gc-4.14
+DISTNAME= gc5.0alpha3
+PKGNAME= boehm-gc-5.0a3
CATEGORIES= devel
-MASTER_SITES= http://reality.sgi.com/boehm_mti/gc_source/
+MASTER_SITES= http://www.hpl.hp.com/personal/Hans_Boehm/gc/gc_source/ \
+ http://reality.sgi.com/boehm_mti/gc_source/
MAINTAINER= mmcg@cs.monash.edu.au
diff --git a/devel/boehm-gc/distinfo b/devel/boehm-gc/distinfo
index 01b8f5c0e88b..0061eb49f623 100644
--- a/devel/boehm-gc/distinfo
+++ b/devel/boehm-gc/distinfo
@@ -1 +1 @@
-MD5 (gc4.14.tar.gz) = 2b852a33443116dbaa163494fd423027
+MD5 (gc5.0alpha3.tar.gz) = af5221c6ce00d7dd1c4e0662e0c87008
diff --git a/devel/boehm-gc/files/patch-aa b/devel/boehm-gc/files/patch-aa
index 526ddcef7e5c..2a418517811e 100644
--- a/devel/boehm-gc/files/patch-aa
+++ b/devel/boehm-gc/files/patch-aa
@@ -1,17 +1,27 @@
---- Makefile.orig Tue Jul 20 02:13:46 1999
-+++ Makefile Tue Jul 20 02:17:01 1999
-@@ -16,8 +16,35 @@
+--- Makefile.orig Sat Sep 11 01:49:18 1999
++++ Makefile Tue Oct 12 17:27:25 1999
+@@ -8,15 +8,42 @@
+ # c++ interface to gc.a
+ # cord/de - builds dumb editor based on cords.
+ ABI_FLAG=
+-CC=cc $(ABI_FLAG)
+-CXX=CC $(ABI_FLAG)
++CC+= $(ABI_FLAG)
++CXX+= $(ABI_FLAG)
+ AS=as $(ABI_FLAG)
+ # The above doesn't work with gas, which doesn't run cpp.
+ # Define AS as `gcc -c -x assembler-with-cpp' instead.
# Under Irix 6, you will have to specify the ABI (-o32, -n32, or -64)
# if you use something other than the default ABI on your machine.
-CFLAGS= -O -DATOMIC_UNCOLLECTABLE -DNO_SIGNALS -DNO_EXECUTE_PERMISSION -DALL_INTERIOR_POINTERS -DSILENT
-
+# We want this to be a drop-in linkable library, hence the -DREDIRECT.
+# The new c++-t and c++-nt (test and notest) are because we don't want
+# to fill anyone's log with leak messages! - MMCG
+
-+CFLAGS= -O -DNO_SIGNALS -DALL_INTERIOR_POINTERS -DATOMIC_UNCOLLECTABLE \
-+ -DNO_EXECUTE_PERMISSION -DSILENT -DREDIRECT_MALLOC=GC_malloc
++GCFLAGS= -DNO_SIGNALS -DALL_INTERIOR_POINTERS -DATOMIC_UNCOLLECTABLE \
++ -DNO_EXECUTE_PERMISSION -DSILENT
++CFLAGS+= $(GCFLAGS)
+
+LEAKFLAGS=$(CFLAGS) -DFIND_LEAK
+
@@ -33,11 +43,19 @@
+ ${INSTALL_DATA} libleak.a libgc.a ${PREFIX}/lib
+ ${INSTALL_DATA} gc.h gc_cpp.h ${PREFIX}/include
+ ${INSTALL_MAN} gc.man ${PREFIX}/man/man3/gc.3
-+
+
# For dynamic library builds, it may be necessary to add flags to generate
# PIC code, e.g. -fPIC on Linux.
+@@ -138,7 +165,7 @@
+ -DDONT_ADD_BYTE_AT_END -DALL_INTERIOR_POINTERS
+ # Flags for building libgc.a -- the last two are required.
+
+-CXXFLAGS= $(CFLAGS)
++CXXFLAGS+= $(GCFLAGS)
+ AR= ar
+ RANLIB= ranlib
-@@ -183,8 +210,6 @@
+@@ -202,8 +229,6 @@
# not time-critical anyway.
# Set SPECIALCFLAGS to -q nodirect_code on Encore.
@@ -46,7 +64,7 @@
pcr: PCR-Makefile gc_private.h gc_hdrs.h gc.h gcconfig.h mach_dep.o $(SRCS)
make -f PCR-Makefile depend
make -f PCR-Makefile
-@@ -222,13 +247,18 @@
+@@ -245,6 +270,12 @@
./if_mach HP_PA "" $(CXX) $(CXXFLAGS) -o test_cpp $(srcdir)/test_cpp.cc gc_cpp.o gc.a -ldld
./if_not_there test_cpp $(CXX) $(CXXFLAGS) -o test_cpp $(srcdir)/test_cpp.cc gc_cpp.o gc.a `./threadlibs`
@@ -57,11 +75,12 @@
+ @echo "Use ./test_cpp 1 to test the leak library"
+
c++: gc_cpp.o $(srcdir)/gc_cpp.h test_cpp
- rm -f on_sparc_sunos5_4
- ./if_mach SPARC SUNOS5 touch on_sparc_sunos5_4
- ./if_mach SPARC SUNOS5 $(AR) rus gc.a gc_cpp.o
- ./if_not_there on_sparc_sunos5_4 $(AR) ru gc.a gc_cpp.o
- ./if_not_there on_sparc_sunos5_4 $(RANLIB) gc.a || cat /dev/null
+ rm -f dont_ar_4
+ ./if_mach SPARC SUNOS5 touch dont_ar_4
+@@ -253,7 +284,6 @@
+ ./if_mach M68K AMIGA $(AR) -vrus gc.a gc_cpp.o
+ ./if_not_there dont_ar_4 $(AR) ru gc.a gc_cpp.o
+ ./if_not_there dont_ar_4 $(RANLIB) gc.a || cat /dev/null
- ./test_cpp 1
echo > c++