aboutsummaryrefslogtreecommitdiff
path: root/devel/boehm-gc
diff options
context:
space:
mode:
authorCarlos J. Puga Medina <cpm@FreeBSD.org>2016-04-29 15:22:19 +0000
committerCarlos J. Puga Medina <cpm@FreeBSD.org>2016-04-29 15:22:19 +0000
commit146c716b8c27dc5c1595865578bb110aeeb4eb71 (patch)
tree60d5504c135dcba27a074fa8e365d7c5dac2384f /devel/boehm-gc
parent4efbbe5d03506f2d4b532ba7a484a1a961ac07ed (diff)
downloadports-146c716b8c27dc5c1595865578bb110aeeb4eb71.tar.gz
ports-146c716b8c27dc5c1595865578bb110aeeb4eb71.zip
- Add configuration to force using mmap
- Regenerate patches with makepatch - Update MAINTAINER to my @FreeBSD.org address - Bump PORTREVISION PR: 208995 Submitted by: andrew Approved by: junovitch (mentor)
Notes
Notes: svn path=/head/; revision=414277
Diffstat (limited to 'devel/boehm-gc')
-rw-r--r--devel/boehm-gc/Makefile5
-rw-r--r--devel/boehm-gc/files/patch-configure12
-rw-r--r--devel/boehm-gc/files/patch-doc_gc.man8
3 files changed, 18 insertions, 7 deletions
diff --git a/devel/boehm-gc/Makefile b/devel/boehm-gc/Makefile
index b71452ad688d..16c5f20c7898 100644
--- a/devel/boehm-gc/Makefile
+++ b/devel/boehm-gc/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gc
PORTVERSION= 7.4.2
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= devel
MASTER_SITES= http://www.hboehm.info/gc/gc_source/
PKGNAMEPREFIX= boehm-
@@ -11,7 +11,7 @@ PKGNAMEPREFIX= boehm-
PKGNAMESUFFIX= -${GC_VARIANT}
.endif
-MAINTAINER= cpm@fbsd.es
+MAINTAINER= cpm@FreeBSD.org
COMMENT= Garbage collection and memory leak detection for C and C++
LICENSE= BDWGC
@@ -91,7 +91,6 @@ post-install:
${STAGEDIR}${PREFIX}/libdata/pkgconfig/bdw-gc-${GC_VARIANT}.pc
.else # ! GC_VARIANT
-
post-patch:
@${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/doc/gc.man
@${REINPLACE_CMD} \
diff --git a/devel/boehm-gc/files/patch-configure b/devel/boehm-gc/files/patch-configure
new file mode 100644
index 000000000000..9848faeedf84
--- /dev/null
+++ b/devel/boehm-gc/files/patch-configure
@@ -0,0 +1,12 @@
+--- configure.orig 2014-06-03 20:08:54 UTC
++++ configure
+@@ -15639,6 +15639,9 @@ else
+ fi
+
+ case "${host}" in
++ *-freebsd*)
++ gc_use_mmap=yes
++ ;;
+ *-linux*)
+ # FIXME: This seems to be no longer needed as configured in gcconfig.h
+ #gc_use_mmap=yes
diff --git a/devel/boehm-gc/files/patch-doc_gc.man b/devel/boehm-gc/files/patch-doc_gc.man
index fd480b5acd75..1d61806b6385 100644
--- a/devel/boehm-gc/files/patch-doc_gc.man
+++ b/devel/boehm-gc/files/patch-doc_gc.man
@@ -1,6 +1,6 @@
---- doc/gc.man.orig 2012-07-25 14:54:48.000000000 +0300
-+++ doc/gc.man 2012-07-25 14:57:40.000000000 +0300
-@@ -11,7 +11,7 @@
+--- doc/gc.man.orig 2014-05-22 20:47:28 UTC
++++ doc/gc.man
+@@ -11,7 +11,7 @@ void GC_free(void *ptr);
void * GC_realloc(void *ptr, size_t size);
.br
.sp
@@ -9,7 +9,7 @@
.LP
.SH DESCRIPTION
.I GC_malloc
-@@ -88,6 +88,48 @@
+@@ -88,6 +88,48 @@ This may temporarily write protect pages
.LP
Other facilities not discussed here include limited facilities to support incremental collection on machines without appropriate VM support, provisions for providing more explicit object layout information to the garbage collector, more direct support for ``weak'' pointers, support for ``abortable'' garbage collections during idle time, etc.
.LP