aboutsummaryrefslogtreecommitdiff
path: root/devel/bonobo/Makefile
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2001-05-04 21:39:58 +0000
committerAde Lovett <ade@FreeBSD.org>2001-05-04 21:39:58 +0000
commit03af2187bd388708aa7234d923ec38192b6fc7a2 (patch)
tree7ce23e0d0c750d353ac0da5306ba035076e0adf0 /devel/bonobo/Makefile
parentdd85694bb4fdd0d68574a5b609e8e026c8a16a4e (diff)
Update to GNOME 1.4 -- massive changes all around, for the sake of
CVS repo bloat, I'll only list the updates. graphics/imlib 1.9.9 -> 1.9.10 textproc/xml-i18n-tools 0.8 -> 0.8.1 x11/gnomelibs 1.2.11 -> 1.2.13 devel/oaf 0.6.2 -> 0.6.5 devel/gconf 0.12 -> 1.0.0 devel/gnomevfs 0.5 -> 1.0 graphics/gdk-pixbuf 0.9.0 -> 0.11.0 sysutils/gnomecontrolcenter 1.2.2 -> 1.4.0.1 print/gnomeprint 0.25 -> 0.28 devel/bonobo 0.37 -> 1.0.3 audio/gnomeaudio 1.0.0 -> 1.4.0 x11/gnomecore 1.2.4 -> 1.4.0.3 devel/libgtop 1.0.11 -> 1.0.12 x11/gnomeapplets 1.2.4 -> 1.4.0.1 misc/gnomeuserdocs NEW 1.4.1 misc/gnomeutils 1.2.1 -> 1.4.0 deskutils/gnomepim 1.2.0 -> 1.4.0 games/gnomegames 1.2.0 -> 1.4.0.1 print/ggv 0.95 -> 1.0 editors/ghex 1.1.4 -> 1.2 devel/bugbuddy 1.2 -> 2.0.1 devel/glade 0.5.11 -> 0.6.2 sysutils/gtop 1.0.12 -> 1.0.13 x11/xalf NEW 0.11 x11-toolkits/py-gtk 0.6.6 -> 0.6.7 x11-toolkits/py-gnome 1.0.53 -> 1.4.0 x11-toolkits/guile-gtk 0.19 -> 0.20 x11-toolkits/guile-gnome 0.10 -> 0.20 devel/libsigc++ 1.0.1 -> 1.0.3 x11-toolkits/gnome-- 1.1.15 -> 1.1.17 x11-toolkits/panel-- NEW 0.1 x11-fm/gnomemc 4.5.51 -> 4.5.54
Notes
Notes: svn path=/head/; revision=42257
Diffstat (limited to 'devel/bonobo/Makefile')
-rw-r--r--devel/bonobo/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/devel/bonobo/Makefile b/devel/bonobo/Makefile
index 10e4f37e1873..d16b5de35886 100644
--- a/devel/bonobo/Makefile
+++ b/devel/bonobo/Makefile
@@ -6,20 +6,19 @@
#
PORTNAME= bonobo
-PORTVERSION= 0.37
+PORTVERSION= 1.0.3
CATEGORIES= devel gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= unstable/sources/bonobo
+MASTER_SITE_SUBDIR= stable/sources/bonobo
MAINTAINER= ade@FreeBSD.org
-LIB_DEPENDS= gnomeprint.13:${PORTSDIR}/print/gnomeprint \
- oaf.0:${PORTSDIR}/devel/oaf
+LIB_DEPENDS= gnomeprint.16:${PORTSDIR}/print/gnomeprint
USE_X_PREFIX= yes
USE_PERL5= yes
USE_GMAKE= yes
-USE_GNOME= yes
+USE_GNOMECTRL= yes
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
LIBTOOLFILES= configure libefs/configure
@@ -33,4 +32,9 @@ pre-patch:
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+# XXX: hack - will be fixed in next release - say hi to
+# GNOME release engineering :)
+post-patch:
+ @find ${WRKSRC} -name '*.idl' | xargs touch
+
.include <bsd.port.mk>