aboutsummaryrefslogtreecommitdiff
path: root/devel/boost-all/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2009-12-29 13:50:29 +0000
committerPav Lucistnik <pav@FreeBSD.org>2009-12-29 13:50:29 +0000
commit129e62f60676aab32deebe63e56978ec605e392e (patch)
treeb11985009a77e1650cc18f2868adc2a44d96f529 /devel/boost-all/Makefile
parentb262319bab08074b8c9e1674a3a5a699baad77ca (diff)
Notes
Diffstat (limited to 'devel/boost-all/Makefile')
-rw-r--r--devel/boost-all/Makefile17
1 files changed, 11 insertions, 6 deletions
diff --git a/devel/boost-all/Makefile b/devel/boost-all/Makefile
index 2768d904cb2d..2ae28b9bcd74 100644
--- a/devel/boost-all/Makefile
+++ b/devel/boost-all/Makefile
@@ -13,9 +13,10 @@ EXTRACT_ONLY= # empty
COMMENT?= The "meta-port" for boost libraries
-OPTIONS= JAM "Boost.Jam - boost.org build utility" on \
- LIBRARIES "C++ source and shared libraries" on \
+OPTIONS= JAM "Boost.Jam - Build tool from the boost.org" on \
+ LIBRARIES "Free portable C++ libraries" on \
PYTHON "Boost.Python - interfacing Python and C++" off \
+ PYSTE "Boost.Pyste - Boost.Python code generator" off \
DOCS "Documentation & examples" on
NO_BUILD= yes
@@ -24,19 +25,23 @@ NO_BUILD= yes
.include "common.mk"
.if !defined(WITHOUT_LIBRARIES)
-RUN_DEPENDS+= ${PREFIX}/lib/libboost_thread.so:${PORTSDIR}/devel/boost-libs
+RUN_DEPENDS+= ${LOCALBASE}/lib/libboost_thread.so:${PORTSDIR}/devel/boost-libs
.endif
.if !defined(WITHOUT_JAM)
-RUN_DEPENDS+= ${PREFIX}/bin/bjam:${PORTSDIR}/devel/boost-jam
+RUN_DEPENDS+= ${LOCALBASE}/bin/bjam:${PORTSDIR}/devel/boost-jam
.endif
.if !defined(WITHOUT_PYTHON)
-RUN_DEPENDS+= ${PREFIX}/lib/libboost_python.so:${PORTSDIR}/devel/boost-python-libs
+RUN_DEPENDS+= ${LOCALBASE}/lib/libboost_python.so:${PORTSDIR}/devel/boost-python-libs
+.endif
+
+.if !defined(WITHOUT_PYSTE)
+RUN_DEPENDS+= ${LOCALBASE}/bin/pyste.py:${PORTSDIR}/devel/boost-pyste
.endif
.if !defined(WITHOUT_DOCS)
-RUN_DEPENDS+= ${PREFIX}/share/doc/boost/doc/html/index.html:${PORTSDIR}/devel/boost-docs
+RUN_DEPENDS+= ${LOCALBASE}/share/doc/boost/doc/html/index.html:${PORTSDIR}/devel/boost-docs
.endif
do-install: